aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-01-25 23:20:31 +0100
committerLudovic Courtès <ludo@gnu.org>2019-01-26 00:06:55 +0100
commit1379319fe7724d6cf077dc205f06c8cc179de943 (patch)
tree94a9bcf2db116da3d1b23b65b0042da0ee7c0732 /gnu/packages/haskell-check.scm
parent9b104bfeefd08554015dc4e5369fe09366113387 (diff)
downloadguix-1379319fe7724d6cf077dc205f06c8cc179de943.tar.gz
guix-1379319fe7724d6cf077dc205f06c8cc179de943.zip
doc: Switch from "GuixSD" to "Guix System".
* doc/guix.texi (Introduction): Add footnote about the change from "GuixSD" to "Guix System". Replace occurrences of "GuixSD" with "Guix System", "Guix", "system", or other appropriate phrases.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
0 files changed, 0 insertions, 0 deletions
'>+ (define progress 0)
(define (build file)
(with-mutex progress-lock
- (report-compilation file total completed))
+ (report-compilation file total progress)
+ (set! progress (+ 1 progress)))
;; Exit as soon as something goes wrong.
(exit-on-exception
@@ -185,9 +186,7 @@ files are for HOST, a GNU triplet such as \"x86_64-linux-gnu\"."
#:output-file (string-append build-directory "/"
(scm->go relative))
#:opts (append warning-options
- (optimization-options relative)))))))
- (with-mutex progress-lock
- (set! completed (+ 1 completed))))
+ (optimization-options relative))))))))
(with-augmented-search-path %load-path source-directory
(with-augmented-search-path %load-compiled-path build-directory