aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Goryachev via Guix-patches via <guix-patches@gnu.org>2024-08-05 13:44:54 +0300
committerAndrew Tropin <andrew@trop.in>2024-08-05 17:32:15 +0400
commit18a201260abf194be844ead408018ece31739353 (patch)
treece7325175b166c412263b8f30d5ceed04b7361a3
parentddfc3cc6f755f31f823e18e8d5d7b994fe640cd1 (diff)
downloadguix-18a201260abf194be844ead408018ece31739353.tar.gz
guix-18a201260abf194be844ead408018ece31739353.zip
gnu: Add erlang-yconf.
* gnu/packages/erlang-xyz.scm (erlang-yconf): New variable. Change-Id: I01618befa77933613a60defca2a8c25067754e49 Signed-off-by: Andrew Tropin <andrew@trop.in>
-rw-r--r--gnu/packages/erlang-xyz.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index 99de5a36da..9bd0ef0826 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -386,6 +386,23 @@ Erlang/Elixir.")
(home-page "https://hex.pm/packages/fast_yaml")
(license license:asl2.0)))
+(define-public erlang-yconf
+ (package
+ (name "erlang-yconf")
+ (version "1.0.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri "yconf" version))
+ (sha256
+ (base32 "12bcb0w0nc30bws4lx2ghnz7n755r6nf9a75nb3i31zkfcr82iz9"))))
+ (build-system rebar-build-system)
+ (inputs (list erlang-fast-yaml))
+ (synopsis "YAML configuration processor")
+ (description "This package provides YAML configuration processor.")
+ (home-page "https://hex.pm/packages/yconf")
+ (license license:asl2.0)))
+
(define-public erlang-unicode-util-compat
(package
(name "erlang-unicode-util-compat")