aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWojtek Kosior <koszko@koszko.org>2023-12-06 22:06:00 +0100
committerW. Kosior <koszko@koszko.org>2025-03-21 13:59:28 +0100
commit13b8460171747da313db35fccd75f80720ec4f73 (patch)
tree605f9c37b573a7908af1aebae2271a81006132bb
parent239c38a806b7f508f4cfa9adbfcac4ffc177b605 (diff)
downloadguix-13b8460171747da313db35fccd75f80720ec4f73.tar.gz
guix-13b8460171747da313db35fccd75f80720ec4f73.zip
gnu: Add guile-myra-test-utils.
* gnu/packages/guile-xyz.scm (guile-myra-test-utils): New variable. Change-Id: I20ae86fa5fab953524786bffefa3cac9703128df
-rw-r--r--gnu/packages/guile-xyz.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index abf8d3b46a..b018996e8b 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -47,6 +47,9 @@
;;; Copyright © 2022, 2025 Evgeny Pisemsky <mail@pisemsky.site>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2023 Andrew Tropin <andrew@trop.in>
+;;; Copyright © 2023 Wojtek Kosior <koszko@koszko.org>
+;;; Additions and modifications by Wojtek Kosior are additionally
+;;; dual-licensed under the Creative Commons Zero v1.0.
;;; Copyright © 2024 Ilya Chernyshov <ichernyshovvv@gmail.com>
;;; Copyright © 2024 Artyom Bologov <mail@aartaka.me>
;;; Copyright © 2024 Felix Lechner <felix.lechner@lease-up.com>
@@ -5155,6 +5158,58 @@ run SRFI 64 test suites. It gives Automake insight into the individual
tests being run, resulting clearer and more specific output.")
(license license:gpl3+)))
+(define-public guile-myra-test-utils
+ (package
+ (name "guile-myra-test-utils")
+ (version "0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.koszko.org/myra-test-utils")
+ (commit "4efdcfc38ec4f7d7ba2fbc3852ece0bd1e2be502")))
+ (sha256
+ (base32
+ "1pzdk2h6i6d57wxfmghrv61j8n84xj2zbl9ybwd3z35lykdrl0f0"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:modules `(((guix build guile-build-system)
+ #:select (target-guile-effective-version))
+ ,@%default-gnu-imported-modules)
+ #:imported-modules `((guix build guile-build-system)
+ ,@%default-gnu-imported-modules)
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-executables
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (_ (format #t "out: ~s~%" out))
+ (version (target-guile-effective-version))
+ (_ (format #t "version: ~s~%" version))
+ (bin (string-append out "/bin"))
+ (scm (string-append out "/share/guile/site/" version))
+ (go (string-append out "/lib/guile/" version
+ "/site-ccache")))
+ (wrap-program (string-append bin "/guile-test-driver")
+ `("GUILE_LOAD_PATH" prefix (,scm))
+ `("GUILE_LOAD_COMPILED_PATH" prefix (,go)))))))))
+ (native-inputs
+ (list autoconf automake guile-3.0 pkg-config lawrence-boilerplate))
+ (inputs
+ (list guile-3.0))
+ (home-page "https://git.koszko.org/myra-test-utils/about")
+ (synopsis "Extra facilities for running SRFI 64 test suites in GNU Guile")
+ (description "One part of the package — a test driver extracted from GNU
+Guix — allows SRFI-64 tests to be easily executed through Automake's
+@command{make check}. This is the same driver as also distributed with
+Automake, albeit with some extra improvements.
+
+The other part — @code{(myra-test-utils)} module — exports improved variants
+of SRFI-64's @code{test-*} forms as well as some extra facilities to aid with
+writing tests.")
+ (license license:gpl3+)))
+
(define-public guile-semver
(package
(name "guile-semver")