aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-25 09:56:11 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:58:41 +0200
commit11ba039b2e6b0c9a7df6268f333ed593b64074dc (patch)
tree206fd6e78773067307abfd8f033a5a65c192f4c5
parentc5723dbb462e3b52acdb7f8bae2603a56816daf8 (diff)
downloadguix-11ba039b2e6b0c9a7df6268f333ed593b64074dc.tar.gz
guix-11ba039b2e6b0c9a7df6268f333ed593b64074dc.zip
gnu: Add rust-rstest-0.13.
* gnu/packages/crates-io.scm (rust-rstest-0.13): New variable. Change-Id: If3aaad4342441c752617f2fa739f53e3e0abfc54
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index fb55b062f9..f927a85c5d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -61493,6 +61493,27 @@ contains the API endpoint response objects.")
and table-based tests.")
(license (list license:expat license:asl2.0))))
+(define-public rust-rstest-0.13
+ (package
+ (inherit rust-rstest-0.15)
+ (name "rust-rstest")
+ (version "0.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rstest" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1p04kbsvk2xna7fk5657p0zi76qrcglrxkw33ay147fbjdgjjfdr"))))
+ (arguments
+ `(#:skip-build? #t ; Cut the dependency graph.
+ #:cargo-inputs
+ (("rust-async-std" ,rust-async-std-1)
+ ("rust-futures" ,rust-futures-0.3)
+ ("rust-futures-timer" ,rust-futures-timer-3)
+ ("rust-rstest-macros" ,rust-rstest-macros-0.13)
+ ("rust-rustc-version" ,rust-rustc-version-0.4))))))
+
(define-public rust-rstest-0.12
(package
(inherit rust-rstest-0.15)