aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-27 23:48:23 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:24 +0200
commit0fea04c383befa3c75c838790964985c12e18ca2 (patch)
treeb20ecc816f6d5803f076a6e02843c258a3678f41
parente2515315a2e12cef439b8c0a00bef52ff211dedd (diff)
downloadguix-0fea04c383befa3c75c838790964985c12e18ca2.tar.gz
guix-0fea04c383befa3c75c838790964985c12e18ca2.zip
gnu: Add texlive-velthuis-bin.
* gnu/packages/tex.scm (texlive-velthuis-bin): New variable. (texlive-velthuis)[propagated-inputs]: Add TEXLIVE-VELTHUIS-BIN. Change-Id: Ib0f69bc3edb44b45164858ae48bd883dbddaee1d
-rw-r--r--gnu/packages/tex.scm88
1 files changed, 87 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index caba8a54e7..fd00bb9435 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -32498,7 +32498,7 @@ style).")
(outputs '("out" "doc"))
(build-system texlive-build-system)
(native-inputs (list texlive-metafont))
- (propagated-inputs (list texlive-xetex-devanagari))
+ (propagated-inputs (list texlive-velthuis-bin texlive-xetex-devanagari))
(home-page "https://ctan.org/pkg/devanagari")
(synopsis "Typeset Devanagari")
(description
@@ -32509,6 +32509,52 @@ languages typically printed in the Devanagari script. The package provides
fonts, in both Metafont and Type 1 formats.")
(license license:gpl3+)))
+(define-public texlive-velthuis-bin
+ (package
+ (inherit texlive-bin)
+ (name "texlive-velthuis-bin")
+ (source
+ (origin
+ (inherit texlive-source)
+ (modules '((guix build utils)
+ (ice-9 ftw)))
+ (snippet
+ #~(let ((delete-other-directories
+ (lambda (root dirs)
+ (with-directory-excursion root
+ (for-each
+ delete-file-recursively
+ (scandir "."
+ (lambda (file)
+ (and (not (member file (append '("." "..") dirs)))
+ (eq? 'directory (stat:type (stat file)))))))))))
+ (delete-other-directories "libs" '())
+ (delete-other-directories "utils" '("devnag"))
+ (delete-other-directories "texk" '())))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ #~(cons "--enable-devnag" (delete "--enable-web2c" #$flags)))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "utils/devnag"
+ (invoke "make" "check")))))
+ (replace 'install
+ (lambda _
+ (with-directory-excursion "utils/devnag"
+ (invoke "make" "install"))))))))
+ (native-inputs '())
+ (inputs '())
+ (propagated-inputs '())
+ (home-page (package-home-page texlive-velthuis))
+ (synopsis "Binary for @code{texlive-velthuis}")
+ (description
+ "This package provide the binary for @code{texlive-velthuis}.")
+ (license (package-license texlive-velthuis))))
+
(define-public texlive-venn
(package
(name "texlive-venn")
@@ -32600,6 +32646,46 @@ strong on layout, from simple alternate-line indentation to the @code{Mouse's
tale} from @emph{Alice in Wonderland}.")
(license license:lppl)))
+(define texlive-vlna-bin
+ (package
+ (inherit texlive-bin)
+ (name "texlive-vlna-bin")
+ (source
+ (origin
+ (inherit texlive-source)
+ (modules '((guix build utils)
+ (ice-9 ftw)))
+ (snippet
+ #~(let ((delete-other-directories
+ (lambda (root dirs)
+ (with-directory-excursion root
+ (for-each
+ delete-file-recursively
+ (scandir "."
+ (lambda (file)
+ (and (not (member file (append '("." "..") dirs)))
+ (eq? 'directory (stat:type (stat file)))))))))))
+ (delete-other-directories "libs" '())
+ (delete-other-directories "utils" '("vlna"))
+ (delete-other-directories "texk" '())))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ #~(cons* "--enable-vlna" (delete "--enable-web2c" #$flags)))
+ ((#:phases _)
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "utils/vlna"
+ (invoke "make" "check")))))
+ (replace 'install
+ (lambda _
+ (with-directory-excursion "utils/vlna"
+ (invoke "make" "install"))))))))
+ (native-inputs '())
+ (inputs '())))
+
(define-public texlive-vlna
(package
(name "texlive-vlna")