aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-01 10:47:12 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:11:51 -0400
commit0d5746ee7ca337dcc82553ca6dd794b04bb6563d (patch)
tree2d073c1dc57ed0941251d7bad5e88d9d822bc3de
parente8d163b49ad7bf4912ee5fbfdc2f043e19c68b88 (diff)
downloadguix-0d5746ee7ca337dcc82553ca6dd794b04bb6563d.tar.gz
guix-0d5746ee7ca337dcc82553ca6dd794b04bb6563d.zip
gnu: imgui: Use unsigned int vertex indexes.
* gnu/packages/toolkits.scm (imgui) [arguments]: Add the "-DImDrawIdx=unsigned int" compiler option to the build phase.
-rw-r--r--gnu/packages/toolkits.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/toolkits.scm b/gnu/packages/toolkits.scm
index 3030e3aa49..82b9490e62 100644
--- a/gnu/packages/toolkits.scm
+++ b/gnu/packages/toolkits.scm
@@ -66,7 +66,12 @@
(replace 'build
(lambda* (#:key inputs #:allow-other-keys)
;; Build main library.
- (apply invoke #$(cc-for-target) "-I" (getcwd)
+ (apply invoke #$(cc-for-target)
+ ;; This option is necessary at least for OpenBoardView,
+ ;; otherwise it would fail with the "Too many vertices in
+ ;; ImDrawList using 16-bit indices".
+ "-DImDrawIdx=unsigned int"
+ "-I" (getcwd)
"-I" (search-input-directory inputs "include/freetype2")
"-g" "-O2" "-fPIC" "-shared"
"-lGL" "-lSDL2" "-lglfw"