aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages zwave)
  #:use-module (guix packages)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module (guix build-system node)
  #:use-module (gnu packages)
  #:use-module (gnu packages base)
  #:use-module (gnu packages node-xyz)
  #:use-module (gnu packages libusb)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages python)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xml))

(define-public open-zwave
  (package
    (name "open-zwave")
    (version "1.6")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/OpenZWave/open-zwave/")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "0xgs4mmr0480c269wx9xkk67ikjzxkh8xcssrdx0f5xcl1lyd333"))
              (patches (search-patches "open-zwave-hidapi.patch"))
              (modules '((guix build utils)))
              (snippet
               '(begin
                  ;; Set RUNPATH on the 'MinOZW' executable.
                  (substitute* "cpp/examples/MinOZW/Makefile"
                    (("\\$\\(LDFLAGS\\)")
                     "$(LDFLAGS) -Wl,-rpath=$(PREFIX)/lib"))

                  ;; XXX: There's a bundled TinyXML under cpp/tinyxml.  Keep
                  ;; it because using our own TinyXML leads to double-free
                  ;; down the road.

                  ;; Delete the bundled HIDAPI.
                  (delete-file-recursively "cpp/hidapi")
                  #t))))
    (build-system gnu-build-system)
    (arguments
     '(#:phases (modify-phases %standard-phases
                  (delete 'configure))            ;no 'configure' script

       #:make-flags (list "BUILD=debug"
                          (string-append "PREFIX="
                                         (assoc-ref %outputs "out"))
                          (string-append "pkgconfigdir="
                                         (assoc-ref %outputs "out")
                                         "/lib/pkgconfig"))

       ;; "make check" and "make fulltest" are only concerned with checking
       ;; the device XML database and it's not entirely clear what to get from
       ;; them.
       #:tests? #f))
    (native-inputs (list which pkg-config perl ;for tests
                         perl-xml-simple))
    (inputs (list hidapi eudev))
    (home-page "http://www.openzwave.net/")
    (synopsis "Access Z-Wave devices from C++ programs")
    (description
     "OpenZWave (or OZW) is a C++ library that interfaces with selected Z-Wave
PC controllers.  It allows developers to create applications that manipulate
and respond to devices on a Z-Wave network, without requiring in-depth
knowledge of the Z-Wave protocol.")
    (license license:lgpl3+)))

(define-public node-openzwave-shared
  (package
    (name "node-openzwave-shared")
    (version "1.7.2")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/OpenZWave/node-openzwave-shared")
             (commit (string-append "v" version))))
       (file-name (git-file-name name version))
       (sha256
        (base32
         "1bqqy12dzqj05j9wsh50dmn84dddmhz0gjzvd3y20z4hpy1v8rsc"))))
    (inputs
     (list open-zwave node-nan))
    (native-inputs
     (list which python pkg-config))
    (build-system node-build-system)
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (add-before 'build 'patch-compiler
           (lambda _
             (substitute* "binding.gyp"
               (("std=c\\+\\+11")
                "std=c++17"))))
         (replace 'build
           ;; For some reason, `npm install` doesn't build
           ;; the addon automatically, so we do it explicitly here.
           ;; We go through `npx` so the npmrc file sets the
           ;; configuration up properly.
           (lambda* (#:key native-inputs inputs #:allow-other-keys)
             (invoke (search-input-file (or native-inputs inputs) "/bin/npx")
                     "--call"
                     (string-append
                      (search-input-file
                       (or native-inputs inputs)
                       "/lib/node_modules/npm/bin/node-gyp-bin/node-gyp")
                      " rebuild")))))))
    (home-page "https://github.com/OpenZWave/node-openzwave-shared")
    (synopsis "Node.js bindings for OpenZWave")
    (description
     "With the @code{node-openzwave-shared} package, you can easily control
and manage your Z-Wave devices (lights, dimmers, blinds, you name it) from
within Node.js applications.  This library also supports secure
devices (e.g. door locks) that require encryption.  All widely used Node.js
versions are supported with the help of @code{node-nan}.

This library is currently able to:
@itemize @bullet
@item
scan a Z-Wave network and report on connected devices;
@item
write values to Z-Wave nodes;
@item
monitor the network for changes;
@item
heal nodes and/or the network; and
@item
perform management tasks: add or remove nodes, replace failed nodes,
manage their group associations, etc.
@end itemize")
    (license license:isc)))
libgit2-compatibility.patch")))) (outputs '("out" "bin" "debug")) ;"bin' contains jamid (build-system gnu-build-system) (arguments (list ;; XXX: The test suites reportedly takes 2 h 30 to run by upstream's CI. ;; Many tests also fail, within and without the containerized ;; environment. Some issues have recently been fixed, so try again in ;; the next release. #:tests? #f ;; The agent links the daemon binary with libguile, which enables the ;; execution of test plans described in Scheme. It may be useful in ;; user scripts too, until more general purpose Scheme bindings are made ;; available (see: test/agent/README.md). #:configure-flags #~(list "--enable-agent" "--enable-debug") #:make-flags #~(list"V=1") ;build verbosely #:phases #~(modify-phases %standard-phases (add-after 'unpack 'change-directory/maybe (lambda _ ;; Allow building from the tarball or a git checkout. (false-if-exception (chdir "daemon")))) (add-after 'install 'delete-static-libraries ;; Remove 100+ MiB of static libraries. "--disable-static" cannot ;; be used as the test suite requires access to private symbols ;; not included in the shared library. (lambda _ (for-each delete-file (find-files (string-append #$output "/lib") "\\.a$")))) (add-after 'install 'move-jamid ;; This reduces the size of the main output, due to not depending ;; on sdbus-c++. (lambda* (#:key outputs #:allow-other-keys) (let ((libexec (string-append #$output:bin "/libexec")) (share (string-append #$output:bin "/share"))) (mkdir-p libexec) (rename-file (search-input-file outputs "libexec/jamid") (string-append libexec "/jamid")) (mkdir-p share) (rename-file (search-input-directory outputs "share/dbus-1") (string-append share "/dbus-1")))))))) (inputs (list alsa-lib asio dhtnet eudev ffmpeg-jami guile-3.0 jack-1 jsoncpp libarchive libgit2-1.8 libnatpmp libsecp256k1 libupnp opendht openssl pjproject-jami pulseaudio sdbus-c++ speex speexdsp webrtc-audio-processing/jami yaml-cpp)) (native-inputs (list autoconf automake cppunit libtool perl ;to generate manpages with pod2man pkg-config which)) (synopsis "Jami core library and daemon") (description "This package provides a library and daemon implementing the Jami core functionality. Jami is a secure and distributed voice, video and chat communication platform that requires no centralized server and leaves the power of privacy in the hands of the user. It supports the SIP and IAX protocols, as well as decentralized calling using P2P-DHT. The @samp{\"bin\"} output contains the D-Bus daemon (@command{jamid}) as well as the Jami D-Bus service definitions.") (home-page "https://jami.net/") (license license:gpl3+))) ;;; Private package; this is used in source form: the project build system has ;;; no install target. (define sortfilterproxymodel ;; Use the latest commit available from the 'qt-6' branch. (let ((commit "6cc21205dbf36640613f0e6e67b2b13b1855c377") (revision "0")) (package (name "sortfilterproxymodel") ;; There are no recent release tag; the module version defined in the ;; source is used (see: ;; https://github.com/oKcerG/SortFilterProxyModel/blob/ ;; 5a930885b7ea99f7f41c25fce08bf8006ee54e3f/ ;; qqmlsortfilterproxymodel.cpp#L574C15-L574C15). (version (git-version "0.2" revision commit)) (source (origin (method git-fetch) (uri (git-reference ;; The upstream is ;; https://github.com/oKcerG/SortFilterProxyModel, but ;; it lacks Qt 6 support, so use this fork, which is the ;; one used by Jami. (url "https://github.com/atraczyk/SortFilterProxyModel") (commit commit))) (file-name (git-file-name name version)) (sha256 (base32 "1n54jkimr3a818i3w7w3lnbqn47x72nnr5xi9vk0mdnbwri3viwy")))) (build-system qt-build-system) (arguments (list #:qtbase qtbase ;use Qt 6 #:tests? #f ;no test suite #:configure-flags #~(list "BUILD_SFPM_PIC=ON"))) (inputs (list qtdeclarative)) (home-page "https://github.com/oKcerG/SortFilterProxyModel") (synopsis "Improved QSortFilterProxyModel implementation for QML") (description "SortFilterProxyModel is an implementation of QSortFilterProxyModel conveniently exposed for QML.") (license license:expat)))) (define-public jami (package (name "jami") (version %jami-nightly-version) (source (origin (method git-fetch) (uri (git-reference (url "https://review.jami.net/jami-client-qt") (commit (string-append "nightly/" %jami-nightly-version)))) (file-name (git-file-name name version)) (sha256 (base32 "1wqi50n80khyngj48brc8wg3m6jq471h9gm62yxpj4f8z5j81ncd")) (patches (search-patches "jami-enable-testing.patch" "jami-libjami-headers-search.patch" "jami-qwindowkit.patch" "jami-skip-tests-requiring-internet.patch" "jami-tests-qtwebengine-ifdef-to-if.patch" "jami-unbundle-dependencies.patch")))) (build-system qt-build-system) (outputs '("out" "debug")) (arguments (list #:qtbase qtbase #:configure-flags #~(list "-DWITH_DAEMON_SUBMODULE=OFF" "-DBUILD_TESTING=ON" ;; Disable the webengine since it grows the closure size by ;; about 450 MiB and requires more resources. "-DWITH_WEBENGINE=OFF" ;; Use libwrap to link directly to libjami instead of ;; communicating via D-Bus to jamid, the Jami daemon. "-DENABLE_LIBWRAP=ON" ;; Ensure FetchContent contribs are looked from the system. "-DFETCHCONTENT_TRY_FIND_PACKAGE_MODE=ALWAYS") #:phases #~(modify-phases %standard-phases (add-after 'unpack 'fix-version-string (lambda _ (substitute* "src/app/version.h" (("VERSION_STRING") "BUILD_DATE") ;to avoid a redefinition error (("// clang-format on.*" anchor) (string-append "const char VERSION_STRING[] = \"" #$version "\";\n" anchor))))) (add-after 'unpack 'copy-3rdparty-source-dependencies (lambda _ (copy-recursively #$(package-source sortfilterproxymodel) "3rdparty/SortFilterProxyModel"))) (add-before 'configure 'fake-x11-environment (lambda _ ;; This works around the lack of configuration for the X11 ;; push-to-talk feature, which is auto-detected via the ;; XDG_SESSION_TYPE environment variable (see: ;; https://git.jami.net/savoirfairelinux/jami-client-qt/-/issues/1504). (setenv "XDG_SESSION_TYPE" "x11"))) (replace 'check (lambda* (#:key tests? parallel-tests? #:allow-other-keys) (when tests? (setenv "QT_QPA_PLATFORM" "offscreen") (setenv "QT_QUICK_BACKEND" "software") ;; The tests require a writable HOME. (setenv "HOME" "/tmp") (let ((ctest-args (list "-V" "--output-on-failure" "-j" (if parallel-tests? (number->string (parallel-job-count)) "1")))) (display "Running unit tests...\n") (apply invoke "ctest" "-R" "Unit_Tests" ctest-args) ;; The QML test suite is currently disabled as it segfaults ;; (see: ;; https://git.jami.net/savoirfairelinux/jami-client-qt/-/issues/1631). ;; (display "Running functional tests...\n") (apply invoke ;; "ctest" "-R" "Qml_Tests" ctest-args) ))))))) (native-inputs (list googletest pkg-config python qthttpserver qttools qtwebsockets vulkan-headers)) (inputs (list ffmpeg-jami glib ;for integration with GNOME libjami libnotify libxcb libxkbcommon md4c network-manager qrencode qt5compat qtdeclarative qtmultimedia qtnetworkauth qtpositioning qtsvg qwindowkit tidy-html ;used by src/app/htmlparser.h vulkan-loader)) (home-page "https://jami.net") (synopsis "Qt Jami client") (description "This package provides the Jami Qt client. Jami is a secure and distributed voice, video and chat communication platform that requires no centralized server and leaves the power of privacy in the hands of the user. It supports the SIP and IAX protocols, as well as decentralized calling using P2P-DHT.") (license license:gpl3+))) (define-public jami-docs ;; There aren't any tags, so use the latest commit. (let ((revision "2") (commit "a48997de84cc4933bd111fa93fbf6a58189b166d")) (package (name "jami-docs") (version (git-version "0.0.0" revision commit)) (source (origin (method git-fetch) (uri (git-reference (url "https://git.jami.net/savoirfairelinux/jami-docs") (commit commit))) (file-name (git-file-name name version)) (sha256 (base32 "0a1kcflvk39aag2vk83cn4m0ifkgb3gvwkr8pbbvf0hcd2cj2j31")))) (build-system copy-build-system) (arguments (list #:phases #~(modify-phases %standard-phases (add-after 'unpack 'build (lambda _ (invoke "make" "info" "html" "man" "LANGS=" "-j" (number->string (parallel-job-count)))))) #:install-plan ;; TODO: Install localized info manuals and HTML. ''(("_build/out/texinfo/jami.info" "share/info/") ("_build/out/html" "share/doc/jami/") ("_build/out/man/jami.1" "share/man/man1/")))) (native-inputs (list python python-myst-parser python-sphinx python-sphinx-rtd-theme texinfo)) (home-page "https://git.jami.net/") (synopsis "Documentation for Jami") (description "This package contains the documentation of Jami. Jami is a secure and distributed voice, video and chat communication platform that requires no centralized server and leaves the power of privacy in the hands of the user. It supports the SIP and IAX protocols, as well as decentralized calling using P2P-DHT.") (license license:fdl1.3+))))