aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages xnee)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xorg))

(define-public xnee
  (package
    (name "xnee")
    (version "3.19")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/xnee/xnee-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "04n2lac0vgpv8zsn7nmb50hf3qb56pmj90dmwnivg09gyrf1x92j"))))
    (build-system gnu-build-system)
    (arguments
     '(#:configure-flags '("CFLAGS=-O2 -g -fcommon")))
    (inputs
     (list gtk+-2
           libx11
           libxext
           libxi
           libxtst
           xorgproto))
    (native-inputs
      (list pkg-config))
    (home-page "https://www.gnu.org/software/xnee/")
    (synopsis "Record, replay and distribute user actions under X11")
    (description
     "GNU Xnee is a program that can record, replay and distribute user
actions in X11.  It can be used to automate user interactions for testing or
demonstration purposes.")
    (license gpl3+)))
ail'>...* gnu/packages/bioinformatics.scm (r-dyngen): New variable. Ricardo Wurmus 2022-02-15gnu: python-gffutils: Update to 0.10.1....* gnu/packages/bioinformatics.scm (python-gffutils): Update to 0.10.1. [arguments]: Remove obsolete phase. Respect TESTS? in check phase while at it. Marius Bakke 2022-01-31gnu: Add scvelo....* gnu/packages/bioinformatics.scm (scvelo): New variable. Ricardo Wurmus 2022-01-31gnu: python-louvain-0.6: Update to 0.7.1....* gnu/packages/graph.scm (python-louvain-0.6): Update to 0.7.1. [arguments]: Add build phases 'find-igraph and 'pretend-version. [native-inputs]: Add python-setuptools-scm and python-wheel. Rename this variable... (python-louvain-0.7): ...to this, naturally. * gnu/packages/bioinformatics.scm (python-scanpy)[propagated-inputs]: Update reference to python-louvain-0.6. Ricardo Wurmus 2022-01-31gnu: bwa-meth: Remove trailing #T from build phase....* gnu/packages/bioinformatics.scm (bwa-meth)[arguments]: Remove trailing #T from build phase. Ricardo Wurmus 2022-01-31gnu: bwa-meth: Update to 0.2.3....* gnu/packages/bioinformatics.scm (bwa-meth): Update to 0.2.3. Ricardo Wurmus 2022-01-27gnu: pigx-sars-cov2-ww: Fix Python module capture....The build system expects all Python modules to be on PYTHONPATH. * gnu/packages/bioinformatics.scm (pigx-sars-cov2-ww)[arguments]: Set PYTHONPATH variable in new build phase. Ricardo Wurmus 2022-01-27gnu: pigx-scrnaseq: Fix Python module capture....The build system expects all Python modules to be on PYTHONPATH. * gnu/packages/bioinformatics.scm (pigx-scrnaseq)[arguments]: Set PYTHONPATH variable in new build phase. Ricardo Wurmus 2022-01-27gnu: pigx-bsseq: Fix Python module capture....The build system expects all Python modules to be on PYTHONPATH. * gnu/packages/bioinformatics.scm (pigx-bsseq)[arguments]: Set PYTHONPATH variable in new build phase. Ricardo Wurmus 2022-01-27gnu: pigx-chipseq: Fix Python module capture....The build system expects all Python modules to be on PYTHONPATH. * gnu/packages/bioinformatics.scm (pigx-chipseq)[arguments]: Set PYTHONPATH variable in new build phase. Ricardo Wurmus 2022-01-27gnu: pigx-rnaseq: Fix Python module capture....The build system expects all Python modules to be on PYTHONPATH. * gnu/packages/bioinformatics.scm (pigx-rnaseq)[arguments]: Set PYTHONPATH variable in new build phase. Ricardo Wurmus 2022-01-22gnu: cwltool: Update to 3.1.20220119140128....* gnu/packages/bioinformatics.scm (cwltool): Update to 3.1.20220119140128. [propagated-inputs]: Change from PYTHON-RDFLIB-5 to PYTHON-RDFLIB. [native-inputs]: Remove PYTHON-RDFLIB-JSONLD. Marius Bakke 2022-01-22gnu: python-pyvcf: Build with old setuptools....* gnu/packages/bioinformatics.scm (python-pyvcf)[native-inputs]: Add PYTHON-SETUPTOOLS. Marius Bakke 2022-01-21gnu: Add r-scseqcomm....* gnu/packages/bioinformatics.scm (r-scseqcomm): New variable. zimoun 2022-01-21gnu: Add r-icellnet....* gnu/packages/bioinformatics.scm (r-icellnet): New variable. zimoun 2022-01-20gnu: samtools-0.1: Install headers and library....* gnu/packages/bioinformatics.scm (samtools-0.1)[arguments]: Add build phases 'install-library and 'install-headers. Ricardo Wurmus 2022-01-20gnu: Add r-doubletfinder....* gnu/packages/bioinformatics.scm (r-doubletfinder): New variable. Ricardo Wurmus 2022-01-18gnu: python-rdflib: Update to 6.1.1....* gnu/packages/rdf.scm (python-rdflib): Update to 6.1.1. [arguments]: Remove #:tests. Add #:phases. [native-inputs]: Change from PYTHON-NOSE to PYTHON-PYTEST. (python-rdflib-5): New variable. (python2-rdflib): Inherit from PYTHON-RDFLIB-5. * gnu/packages/python-xyz.scm (python-prov): Change from PYTHON-RDFLIB to PYTHON-RDFLIB-5. * gnu/packages/bioinformatics.scm (cwltool): Likewise. Marius Bakke 2022-01-17Merge branch 'version-1.4.0'...With resolved conflicts in: gnu/packages/gnome.scm gnu/packages/openstack.scm gnu/packages/python-xyz.scm Maxim Cournoyer 2022-01-17gnu: sambamba: Update to 0.8.2....* gnu/packages/bioinformatics.scm (sambamba): Update to 0.8.2. [arguments]: Sett CC and D_LD in build phase. [native-inputs]: Add ld-gold-wrapper and binutils-gold. Ricardo Wurmus 2022-01-10gnu: clipper: Remove obsolete phase....* gnu/packages/bioinformatics.scm (clipper)[arguments]<#:phases>: Remove 'make-files-writable phase. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Sarah Morgensen 2022-01-10gnu: python-biom-format: Remove obsolete phase....* gnu/packages/bioinformatics.scm (python-biom-format)[arguments] <#:phases>: Remove 'make-files-writable phase. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Sarah Morgensen 2022-01-10gnu: python-pysam: Update to 0.18.0....* gnu/packages/bioinformatics.scm (python-pysam): Update to 0.18.0. [source]: Add FIXME to clarify bundled libraries in use. [phases]{check}: Streamline. [propagated-inputs]: Use latest htslib (1.14). [native-inputs]: Use latest samtools and bcftools (1.14). Remove python-nose. Maxim Cournoyer 2022-01-10gnu: bcftools: Update to 1.14....* gnu/packages/bioinformatics.scm (bcftools): Update to 1.14. (bcftools-1.12): New variable. (bcftools-1.10): Use package/inherit and delete trailing #t. [name]: Delete field. Maxim Cournoyer 2022-01-10gnu: samtools: Update to 1.14....* gnu/packages/bioinformatics.scm (samtools): Update to 1.14. [modules]: Delete argument. [phases]{install-library, install-headers}: Delete phases. This version no longer includes the legacy library (it links to htslib directly). (samtools-1.12): New variable. Maxim Cournoyer 2022-01-10gnu: htslib: Update to 1.14....* gnu/packages/bioinformatics.scm (htslib): Update to 1.14. (htslib-1.12): New variable. (htslib-1.10, htslib-1.9, htslib-1.3) (htslib-for-samtools-1.2): Normalize style. Maxim Cournoyer 2022-01-11gnu: stringtie: Update to 2.2.0....* gnu/packages/bioinformatics.scm (stringtie): Update to 2.2.0. [source]: Simplify snippet. [arguments]: Add make-flags; update build phases. [inputs]: Remove samtools-0.1; add bzip2, htslib-for-stringtie, and libdeflate. [license]: Change to Expat license. Ricardo Wurmus 2022-01-11gnu: Add htslib-for-stringtie....* gnu/packages/bioinformatics.scm (htslib-for-stringtie): New variable. * gnu/packages/patches/htslib-for-stringtie.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Ricardo Wurmus 2022-01-04gnu: r-archr: Update to 1.0.1-1.92ab814....* gnu/packages/bioinformatics.scm (r-archr): Update to 1.0.1-1.92ab814. Ricardo Wurmus 2021-12-30gnu: Remove trailing period from synopsis....* gnu/packages/anddroid.scm (android-liblog, git-repo)[synopsis]: Remove trailing period. * gnu/packages/audio.scm (audio-to-midi)[synopsis]: Likewise. * gnu/packages/bioinformatics.scm (python-mygene, python-scanpy, nanosv)[synopsis]: Likewise. * gnu/packages/cran.scm (r-gsubfn)[synopsis]: Likewise. * gnu/packages/crates-io.scm (rust-ascii-1, rust-bindgen-0.59, rust-byte-unit-4, rust-clircle-0.3, rust-dashmap-4, rust-dhcp4r-0.2, rust-fast-float-0.2, rust-fst-0.4, rust-futures-core-preview-0.3, rust-http-types-2, rust-hyper-0.14, rust-indexmap-1, rust-minimal-lexical-0.1, rust-oorandom-11.1, rust-runtime-raw-0.3, rust-sharded-slab-0.1, rust-takeable-option-0.4, rust-tower-service-0.3, rust-ttf-parser-0.12)[synopsis]: Likewise. * gnu/packages/disk.scm (f3)[synopsis]: Likewise. * gnu/packages/emacs-xyz.scm (emacs-scribble-mode, emacs-psession)[synopsis]: Likewise. * gnu/packages/golang.scm (go-github-com-kylelemons-godebug)[synopsis]: Likewise. * gnu/packages/haskell-xyz.scm (ghc-fsnotify, ghc-libyaml, ghc-emojis, ghc-regex-tdfa, ghc-th-lift-instances, ghc-commonmark-pandoc)[synopsis]: Likewise. * gnu/packages/java.scm (java-commons-jxpath, java-jakarta-regexp)[synopsis]: Likewise. * gnu/packages/lisp-xyz.scm (sbcl-cl-annot, sbcl-envy)[synopsis]: Likewise. * gnu/packages/mail.scm (go-gitlab.com-shackra-goimapnotify)[synopsis]: Likewise. * gnu/packages/maven.scm (maven-wagon-http-shared, maven-surefire-plugin)[synopsis]: Likewise. * gnu/packages/perl.scm (perl-text-soundex)[synopsis]: Likewise. * gnu/packages/python-check.scm (python-httmock)[synopsis]: Likewise. * gnu/packages/python-web.scm (python-bottle)[synopsis]: Likewise. * gnu/packages/python-xyz.scm (python-olefile, python-tokenize-rt, python-pylzma)[synopsis]: Likewise. * gnu/packages/tex.scm (texlive-docstrip)[synopsis]: Likewise. Vagrant Cascadian 2021-12-30gnu: python-pyspoa: Fix trailing whitespace in synopsis....* gnu/packages/bioinformatics.scm (python-pyspoa)[synopsis]: Fix trailing whitespace. Vagrant Cascadian 2021-12-30gnu: lofreq: Fix trailing whitespace in synopsis....* gnu/packages/bioinformatics.scm (lofreq)[synopsis]: Fix trailing whitespace. Vagrant Cascadian 2021-12-30gnu: arriba: Fix trailing whitespace in synopsis....* gnu/packages/bioinformatics.scm (arriba)[synopsis]: Fix trailing whitespace. Vagrant Cascadian 2021-12-29gnu: ivar: Fix trailing whitespace in description....* gnu/packages/bioinformatics.scm (ivar)[description]: Fix trailing whitespace. Vagrant Cascadian