aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages xnee)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xorg))

(define-public xnee
  (package
    (name "xnee")
    (version "3.19")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/xnee/xnee-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "04n2lac0vgpv8zsn7nmb50hf3qb56pmj90dmwnivg09gyrf1x92j"))))
    (build-system gnu-build-system)
    (arguments
     '(#:configure-flags '("CFLAGS=-O2 -g -fcommon")
       #:make-flags '("LIBSEMA=-lpthread")))
    (inputs
     (list gtk+-2
           libx11
           libxext
           libxi
           libxtst
           xorgproto))
    (native-inputs
      (list pkg-config))
    (home-page "https://www.gnu.org/software/xnee/")
    (synopsis "Record, replay and distribute user actions under X11")
    (description
     "GNU Xnee is a program that can record, replay and distribute user
actions in X11.  It can be used to automate user interactions for testing or
demonstration purposes.")
    (license gpl3+)))
man.scm?id=462ad9f56b9665b8d22960acee73ad91f1052c9c'>Merge branch 'master' into core-updatesMarius Bakke 2019-08-03gnu: man-pages: Update to 5.02....* gnu/packages/man.scm (man-pages): Update to 5.02. Tobias Geerinckx-Rice 2019-05-25gnu: Remove help2man@1.47.6....* gnu/packages/man.scm (help2man): Update to 1.47.10. (help2man/latest): Remove variable. Marius Bakke 2019-05-24gnu: help2man: Update to 1.47.10....* gnu/packages/man.scm (help2man/latest): Update to 1.47.10. Marius Bakke 2019-05-11gnu: man-db: Update to 2.8.5....* gnu/packages/man.scm (man-db): Update to 2.8.5. [arguments]: Add systemd unit directory to #:configure-flags. Tobias Geerinckx-Rice 2019-05-09gnu: man-pages: Update to 5.01....* gnu/packages/man.scm (man-pages): Update to 5.01. Tobias Geerinckx-Rice 2019-03-08gnu: man-pages: Update to 5.00....* gnu/packages/man.scm (man-pages): Update to 5.00. [source]: Re-format. Tobias Geerinckx-Rice 2019-03-05gnu: scdoc: Update to 1.9.4....* gnu/packages/man.scm (scdoc): Update to 1.9.4. Rutger Helling 2019-02-27gnu: libpipeline: Update to 1.5.1....* gnu/packages/man.scm (libpipeline): Update to 1.5.1. Tobias Geerinckx-Rice 2019-01-31gnu: scdoc: Update to 1.8.1....* gnu/packages/man.scm (scdoc): Update to 1.8.1. Rutger Helling 2019-01-17Revert "Revert "gnu: man-db: Embed absolute reference to 'preconv'.""...This reverts commit ccb15b343e35d76a5c7c693f4c00d3f5b5a4cc39. Now that we've fixed the segfault with groff's preconv (see 73b2ce87956b0d9168dcfa234128b91e0e41a4c7), it's safe to re-apply this fix. Marius Bakke 2019-01-16gnu: Move dbm databases to new module....* gnu/packages/databases.scm (gdbm, bdb, bdb-5.3): Move from here... * gnu/packages/dbm.scm: ...to this new module. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * gnu/packages/audio.scm, gnu/packages/avahi.scm, gnu/packages/backup.scm, gnu/packages/cobol.scm, gnu/packages/cyrus-sasl.scm, gnu/packages/databases.scm, gnu/packages/finance.scm, gnu/packages/game-development.scm, gnu/packages/gnome.scm, gnu/packages/guile.scm, gnu/packages/ibus.scm, gnu/packages/kerberos.scm, gnu/packages/linux.scm, gnu/packages/mail.scm, gnu/packages/man.scm, gnu/packages/nvi.scm, gnu/packages/openldap.scm, gnu/packages/package-management.scm, gnu/packages/php.scm, gnu/packages/pulseaudio.scm, gnu/packages/python.scm, gnu/packages/rdf.scm, gnu/packages/ruby.scm, gnu/packages/sawfish.scm: Update module references. Ricardo Wurmus 2018-12-20gnu: Add scdoc....* gnu/packages/man.scm (scdoc): New variable. Rutger Helling 2018-11-19gnu: help2man: Add 1.47.8....* gnu/packages/man.scm (help2man/latest): New variable. Ludovic Courtès