aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages xnee)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xorg))

(define-public xnee
  (package
    (name "xnee")
    (version "3.19")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/xnee/xnee-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "04n2lac0vgpv8zsn7nmb50hf3qb56pmj90dmwnivg09gyrf1x92j"))))
    (build-system gnu-build-system)
    (arguments
     '(#:configure-flags '("CFLAGS=-O2 -g -fcommon")))
    (inputs
     (list gtk+-2
           libx11
           libxext
           libxi
           libxtst
           xorgproto))
    (native-inputs
      (list pkg-config))
    (home-page "https://www.gnu.org/software/xnee/")
    (synopsis "Record, replay and distribute user actions under X11")
    (description
     "GNU Xnee is a program that can record, replay and distribute user
actions in X11.  It can be used to automate user interactions for testing or
demonstration purposes.")
    (license gpl3+)))
span>Leo Famulari 2017-11-17gnu: Move testing packages from python.scm to check.scm....Ricardo Wurmus 2017-11-13gnu: Move web packages from python to python-web....Ludovic Courtès 2017-10-03gnu: vdirsyncer: Update to 0.16.3....Leo Famulari 2017-09-01gnu: vdirsyncer: Update to 0.16.2....Leo Famulari 2017-08-10gnu: vdirsyncer: Update to 0.16.1....Tobias Geerinckx-Rice 2017-07-02gnu: vdirsyncer: Update to 0.16.0....Leo Famulari 2017-04-30gnu: radicale: Update to 1.1.2 [fixes CVE-2017-8342]....Leo Famulari 2017-03-01gnu: vdirsyncer: Update to 0.15.0....Leo Famulari 2017-02-18gnu: vdirsyncer: Use add-installed-pythonpath in the check phase....Leo Famulari 2017-02-18gnu: vdirsyncer: Don't fail the test suite when the build machine is slow....Leo Famulari 2017-01-06gnu: vdirsyncer: Update to 0.14.1....Leo Famulari 2016-12-06gnu: radicale: Skip the test suite....Leo Famulari 2016-11-15gnu: vdirsyncer: Fix build by setting correct PYTHONPATH....Hartmut Goebel 2016-10-27Merge branch 'master' into core-updatesMark H Weaver 2016-10-26gnu: vdirsyncer: Update to 0.14.0....Leo Famulari 2016-10-15gnu: radicale: Run the test suite with py.test....Leo Famulari 2016-10-09gnu: vdirsyncer: Update to 0.13.1....Leo Famulari 2016-08-24gnu: vdirsyncer: Update to 0.12.1....Leo Famulari 2016-08-01gnu: vdirsyncer: Update to 0.11.3....Leo Famulari 2016-06-20gnu: vdirsyncer: Update to 0.11.2....Leo Famulari 2016-05-23gnu: vdirsyncer: Update to 0.11.0....Leo Famulari 2016-04-27gnu: vdirsyncer: Update to 0.10.0....Leo Famulari 2016-04-10gnu: vdirsyncer: Update to 0.9.3....Leo Famulari 2016-03-13gnu: vdirsyncer: Update 0.9.2....Leo Famulari 2016-02-15gnu: vdirsyncer: Update to 0.9.0....Leo Famulari 2016-02-02gnu: vdirsyncer: Update to 0.8.1....Leo Famulari 2016-01-15gnu: Add vdirsyncer....Leo Famulari 2016-01-15gnu: Add radicale....Leo Famulari