aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages xnee)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xorg))

(define-public xnee
  (package
    (name "xnee")
    (version "3.19")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/xnee/xnee-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "04n2lac0vgpv8zsn7nmb50hf3qb56pmj90dmwnivg09gyrf1x92j"))))
    (build-system gnu-build-system)
    (arguments
     '(#:configure-flags '("CFLAGS=-O2 -g -fcommon")))
    (inputs
     (list gtk+-2
           libx11
           libxext
           libxi
           libxtst
           xorgproto))
    (native-inputs
      (list pkg-config))
    (home-page "https://www.gnu.org/software/xnee/")
    (synopsis "Record, replay and distribute user actions under X11")
    (description
     "GNU Xnee is a program that can record, replay and distribute user
actions in X11.  It can be used to automate user interactions for testing or
demonstration purposes.")
    (license gpl3+)))
cm?id=14b256f10e11210adf8cc476c40e9ef2def37bd5'>gnu: glslang: Skip a test on powerpc-linux....Efraim Flashner 2024-04-07gnu: glslang: Give more information on test failures....Efraim Flashner 2024-04-04gnu: glslang: Fix building on riscv64-linux....Efraim Flashner 2024-04-01gnu: vulkan-validationlayers: Update to 1.3.280.0....dan 2024-04-01gnu: Add vulkan-utility-libraries....dan 2024-04-01gnu: vulkan-tools: Update to 1.3.280.0....dan 2024-04-01gnu: volk: Update to 1.3.280.0....dan 2024-04-01gnu: vulkan-loader: Update to 1.3.280.0....dan 2024-04-01gnu: vulkan-headers: Update to 1.3.280.0....dan 2024-04-01gnu: shaderc: Update to 2024.0....dan 2024-04-01gnu: spirv-cross: Update to 1.3.280.0....dan 2024-04-01gnu: glslang: Update to 1.3.280.0....dan 2024-04-01gnu: spirv-tools: Update to 1.3.280.0....dan 2024-04-01gnu: spirv-headers: Update to 1.3.280.0....dan 2024-01-03gnu: vulkan-loader: Fix cross-compiling....Zheng Junjie 2023-11-30gnu: Add spirv-llvm-translator....Efraim Flashner