aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages xnee)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xorg))

(define-public xnee
  (package
    (name "xnee")
    (version "3.19")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/xnee/xnee-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "04n2lac0vgpv8zsn7nmb50hf3qb56pmj90dmwnivg09gyrf1x92j"))))
    (build-system gnu-build-system)
    (arguments
     '(#:configure-flags '("CFLAGS=-O2 -g -fcommon")))
    (inputs
     (list gtk+-2
           libx11
           libxext
           libxi
           libxtst
           xorgproto))
    (native-inputs
      (list pkg-config))
    (home-page "https://www.gnu.org/software/xnee/")
    (synopsis "Record, replay and distribute user actions under X11")
    (description
     "GNU Xnee is a program that can record, replay and distribute user
actions in X11.  It can be used to automate user interactions for testing or
demonstration purposes.")
    (license gpl3+)))
>...Marius Bakke 2022-06-27gnu: CMake: Bootstrap with system jsoncpp....Marius Bakke 2022-05-13gnu: cmake-bootstrap: Use $SSL_CERT_DIR/$SSL_CERT_FILE....Maxime Devos 2022-01-10gnu: cmake-bootstrap: Update to 3.21.4....Maxim Cournoyer 2021-12-13gnu: Simplify package inputs....Ludovic Courtès 2021-11-11gnu: cmake-bootstrap: Update to 3.21.3....Maxim Cournoyer 2021-09-21gnu: cmake: Skip CPack TXZ test on i686....Ludovic Courtès 2021-07-29Merge branch 'master' into core-updates-frozen...Marius Bakke 2021-07-28gnu: cmake: Update to 3.21.1....Ricardo Wurmus 2021-05-09gnu: CMake: Update to 3.20.2....Marius Bakke 2021-03-06Merge branch 'master' into core-updatesChristopher Baines 2021-02-15gnu: cmake-shared: Update to 1.1.0-32....Raghav Gururajan 2021-02-03Merge branch 'master' into core-updatesChristopher Baines 2021-01-31gnu: Add cmake-shared....Raghav Gururajan 2020-12-30gnu: cmake-bootstrap: Update to 3.19.2....Maxim Cournoyer 2020-12-26gnu: cmake: Update to 3.19.2....Greg Hogan 2020-12-17gnu: Remove 'curl-minimal'....Marius Bakke 2020-11-29Merge remote-tracking branch 'origin/master' into core-updatesChristopher Baines 2020-11-26gnu: cmake: Update to 3.19.1....Tobias Geerinckx-Rice 2020-11-24gnu: cmake: Update to 3.19.0....Maxim Cournoyer 2020-11-19gnu: cmake-minimal: Remove some documentation....Efraim Flashner 2020-11-19gnu: cmake: Only build ccmake on user facing cmake....Efraim Flashner