aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages xnee)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xorg))

(define-public xnee
  (package
    (name "xnee")
    (version "3.19")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/xnee/xnee-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "04n2lac0vgpv8zsn7nmb50hf3qb56pmj90dmwnivg09gyrf1x92j"))))
    (build-system gnu-build-system)
    (arguments
     '(#:configure-flags '("CFLAGS=-O2 -g -fcommon")))
    (inputs
     (list gtk+-2
           libx11
           libxext
           libxi
           libxtst
           xorgproto))
    (native-inputs
      (list pkg-config))
    (home-page "https://www.gnu.org/software/xnee/")
    (synopsis "Record, replay and distribute user actions under X11")
    (description
     "GNU Xnee is a program that can record, replay and distribute user
actions in X11.  It can be used to automate user interactions for testing or
demonstration purposes.")
    (license gpl3+)))
-02-27 16:44:58 +0300'>2017-02-27.gitignore: Remove stale entries....Alex Kost 2017-02-10build: Add build-aux/ar-lib to .gitignore....Clément Lassieur 2017-01-13etc: Support indentation of whole files....Ludovic Courtès 2017-01-12etc: Add 'indent-package.el' script....Ludovic Courtès 2016-11-24Add system start-up files for "guix publish"....Hartmut Goebel 2016-11-16daemon: Add "builtin:download" derivation builder....Ludovic Courtès 2016-07-05build: Ignore texi2pdf temporary files....David Craven 2016-03-23doc: Add "lightweight desktop" OS config example....Ludovic Courtès 2016-01-28Update .gitignore....Mathieu Lirzin 2016-01-12doc: Show bootstrapping at the package level....Ludovic Courtès 2015-11-26Add 'guix-daemon.conf' job for Upstart....Mario Daniel Ruiz Saavedra 2015-10-14guix system: Add 'dmd-graph' command....Ludovic Courtès 2015-10-10services: Introduce extensible services....Ludovic Courtès 2015-08-30build: Produce 'guix-config' instead of using compile-time tricks....Mathieu Lirzin 2015-08-27Add 'guix graph'....Ludovic Courtès 2015-07-15Add 'guix-daemon.service' file for systemd....Ludovic Courtès 2015-07-07Prevent Git from silently ignoring new files....Mathieu Lirzin