aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages xnee)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xorg))

(define-public xnee
  (package
    (name "xnee")
    (version "3.19")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/xnee/xnee-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "04n2lac0vgpv8zsn7nmb50hf3qb56pmj90dmwnivg09gyrf1x92j"))))
    (build-system gnu-build-system)
    (arguments
     '(#:configure-flags '("CFLAGS=-O2 -g -fcommon")))
    (inputs
     (list gtk+-2
           libx11
           libxext
           libxi
           libxtst
           xorgproto))
    (native-inputs
      (list pkg-config))
    (home-page "https://www.gnu.org/software/xnee/")
    (synopsis "Record, replay and distribute user actions under X11")
    (description
     "GNU Xnee is a program that can record, replay and distribute user
actions in X11.  It can be used to automate user interactions for testing or
demonstration purposes.")
    (license gpl3+)))
ail'>...Efraim Flashner 2024-02-16gnu: ani-cli: Update to 4.8....port19 2024-02-14gnu: celluloid: Update to 0.26....kiasoc5 2024-02-05gnu: mbedtls-apache: Rename to mbedtls-lts....Hilton Chain 2024-02-01gnu: mpv-mpris: Switch to gnu-build-system....Josselin Poiret 2024-01-22gnu: h264bitstream: Update to 0.2.0-1.ae72f73....Oleg Pykhalov 2024-01-21gnu: Add h264bitstream....Petr Hodina 2024-01-18gnu: mpv: Propagate most libraries....Maxim Cournoyer 2024-01-18gnu: libdvdnav: Propagate libdvdread....Maxim Cournoyer 2024-01-18gnu: libplacebo: Propagate lcms, shaderc and vulkan-loader....Maxim Cournoyer 2024-01-11gnu: ffmpeg-jami: Sync configure flags with upstream Jami....Maxim Cournoyer 2024-01-09gnu: ffmpeg-jami: Relocate to (gnu packages video)....Maxim Cournoyer 2024-01-08gnu: obs: Fix VLC plugin....Oleg Pykhalov 2024-01-07gnu: mkvtoolnix: Remove input labels and use gexps....Ludovic Courtès 2024-01-07gnu: mkvtoolnix: Update to 80.0....Antoine Côté 2024-01-07gnu: libmatroska: Update to 1.7.1....Antoine Côté 2024-01-05gnu: ffmpeg: Update to 6.1.1 (fixes CVE-2023-47342, CVE-2023-47344)....Maxim Cournoyer 2023-12-22gnu: mpv: Update to 0.37.0....Zheng Junjie 2023-12-22gnu: libplacebo: Use gexps....Hilton Chain 2023-12-22gnu: libplacebo: Update to 6.338.1....Zheng Junjie 2023-12-20gnu: Add obs-pipewire-audio-capture....Oleg Pykhalov 2023-12-10gnu: mediainfo: Update to 23.11....Tobias Geerinckx-Rice 2023-12-10gnu: libmediainfo: Update to 23.11....Tobias Geerinckx-Rice 2023-12-10Merge remote-tracking branch 'origin/master' into rust-team...Efraim Flashner 2023-11-28gnu: rav1e: Don't build the static library....Efraim Flashner 2023-12-05gnu: mlt: Update to 7.22.0....Vinicius Monego 2023-11-19gnu: Add ani-cli....jaeme 2023-11-25gnu: yt-dlp: Update to 2023.10.13....Jaeme Sifat 2023-11-25gnu: obs-looking-glass: Update to B6....Oleg Pykhalov 2023-11-14gnu: ffmpeg-2.8: Update to 2.8.22....Efraim Flashner 2023-11-14gnu: ffmpeg-3.4: Update to 3.4.13....Efraim Flashner 2023-11-14gnu: ffmpeg-5: Update to 5.1.4....Efraim Flashner 2023-11-06gnu: streamlink: Update to 6.3.1....Efraim Flashner 2023-11-06gnu: mpv-mpris: Update to 1.1....Efraim Flashner 2023-10-30gnu: Add ffmpeg-normalize....Vinicius Monego 2023-10-30gnu: Add ffmpeg-progress-yield....Vinicius Monego 2023-10-18Revert "build: cargo-build-system: Disable tests by default."...Efraim Flashner 2023-10-18build: cargo-build-system: Disable tests by default....Efraim Flashner 2023-10-18gnu: rav1e: Update to 0.6.6....Efraim Flashner