aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2022 Ivan Vilata i Balaguer <ivan@selidor.net>
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages xfig)
  #:use-module (guix packages)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages freedesktop)
  #:use-module (gnu packages ghostscript)
  #:use-module (gnu packages xorg)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages image)
  #:use-module (gnu packages ghostscript)
  #:use-module (gnu packages imagemagick)
  #:use-module (gnu packages netpbm)
  #:use-module (gnu packages compression))

(define-public fig2dev
  (package
    (name "fig2dev")
    (version "3.2.9")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "mirror://sourceforge/mcj/"
                           name "-" version ".tar.xz"))
       (sha256
        (base32
         "1cch429zbmrg2zy1mkx9xwnpvkjhmlw40c88bvi2virws744dqhm"))))
    (build-system gnu-build-system)
    (arguments
     (list
      #:modules '((guix build gnu-build-system)
                  (guix build utils)
                  (srfi srfi-26))
      #:phases
      #~(modify-phases %standard-phases
          (add-after 'install 'wrap-program
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((programs
                     (find-files (string-append #$output "/bin")))
                    (path
                     (search-path-as-list
                      '("bin")
                      (map (cut assoc-ref inputs <>)
                           (list "ghostscript" "imagemagick")))))
                (for-each (lambda (program)
                            (wrap-program program
                              `("PATH" ":" prefix ,path)))
                          programs)))))))
    (inputs
     (list libpng zlib
           ;; Quoth INSTALL:
           ;; “To run fig2dev, the packages
           ;;    ghostscript, and one out of
           ;;    netpbm | ImageMagick | GraphicsMagick
           ;; are needed to produce various bitmap output formats, or process
           ;; fig files with embedded images.”
           ghostscript
           imagemagick))
    (native-inputs
     ;; XXX: Tests fail if netpbm is absent.
     (list netpbm))
    (home-page "https://sourceforge.net/projects/mcj")
    (synopsis "Translate Fig to other graphic description formats")
    (description "Fig2dev is a set of tools for creating TeX documents with
graphics which are portable, in the sense that they can be printed in a wide
variety of environments.")
    (license
     (license:non-copyleft "file://Makefile.am"
                           "See <https://spdx.org/licenses/Xfig.html>."))))

(define-public transfig
  (deprecated-package "transfig" fig2dev))

(define-public xfig
  (package
    (name "xfig")
    (version "3.2.9")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "mirror://sourceforge/mcj/"
                           name "-" version ".tar.xz"))
       (sha256
        (base32
         "1xy2zqbd1wn2fij95kgnj39850r7xk74kvx7kp0dxhmvs429vv8k"))
       ;; TODO: Remove these patches and snippet when updating,
       ;; upstreamed since commit `84375ac05e923b46bbacc8b336b0dfbe29497b6b'.
       (patches
        (search-patches "xfig-Enable-error-message-for-missing-libraries.patch"
                        "xfig-Use-pkg-config-to-set-fontconfig-CFLAGS-and-LIBS.patch"
                        "xfig-Fix-double-free-when-requesting-MediaBox.patch"))
       (modules '((guix build utils)))
       (snippet
        ;; The patch-dot-desktop-files phase requires a relative name.
        #~(begin
            (substitute* "xfig.desktop"
              (("^(Exec=)/usr/bin/" _ key) key))
            ;; This forces autoreconf to be invoked, needed for patches
            ;; to be effective.
            (delete-file "configure")))))
    (build-system gnu-build-system)
    (arguments
     (list
      #:modules '((guix build gnu-build-system)
                  (guix build utils)
                  (srfi srfi-26))
      #:phases
      #~(modify-phases %standard-phases
          (add-after 'install 'wrap-program
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((path
                     (search-path-as-list
                      '("bin")
                      (map (cut assoc-ref inputs <>)
                           (list "ghostscript" "fig2dev")))))
                (wrap-program (string-append #$output "/bin/xfig")
                  `("PATH" ":" prefix ,path))))))))
    (native-inputs
     (list pkg-config
           ;; TODO: Remove the import on (gnu packages autotools)
           ;; and related packages in the next update.
           autoconf automake libtool
           ;; For tests.
           desktop-file-utils))
    (inputs
     (list ghostscript
           fig2dev
           libxaw3d
           libjpeg-turbo
           libpng
           libxpm
           libx11
           libxft
           libxt))
    (home-page "https://mcj.sourceforge.net/")
    (synopsis "Interactive drawing tool")
    (description
     "Xfig is an interactive drawing tool which runs under X Window System.
In xfig, figures may be drawn using objects such as circles, boxes, lines,
spline curves, text, etc.  It is also possible to import images in formats
such as GIF, JPEG, EPSF (PostScript), etc.  Those objects can be created,
deleted, moved or modified.  Attributes such as colors or line styles can be
selected in various ways.  For text, 35 fonts are available.")
    (license
     (license:non-copyleft "file://Makefile.am"
                           "See <https://spdx.org/licenses/Xfig.html>."))))
pfs-blocksutil")) (propagated-inputs (list go-github-com-ipfs-go-block-format)) (home-page "https://github.com/ipfs/go-ipfs-blocksutil") (synopsis "Utility functions for working with IPFS blocks") (description "This package provides an utility functions for working with @url{https://github.com/ipfs/go-block-format, IPFS blocks}.") (license license:expat)))) (define-public go-github-com-ipfs-go-cid (package (name "go-github-com-ipfs-go-cid") (version "0.4.1") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipfs/go-cid") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0gfd5dg0shj2daraai2kkf8sg24jp5cr6dsv857wp4q1ni612a23")))) (build-system go-build-system) (arguments (list #:import-path "github.com/ipfs/go-cid")) (propagated-inputs (list go-github-com-multiformats-go-multihash go-github-com-multiformats-go-multibase go-github-com-multiformats-go-varint)) (home-page "https://github.com/ipfs/go-cid") (synopsis "Content ID v1 implemented in Go") (description "Implementation in Go of the @url{https://github.com/ipld/cid, CID spec}. It is used in @code{go-ipfs} and related packages to refer to a typed hunk of data.") (license license:expat))) (define-public go-github-com-ipfs-go-cidutil (package (name "go-github-com-ipfs-go-cidutil") (version "0.1.0") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipfs/go-cidutil") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0j18wf42rfxrrh2fjdbjsjvjqxwgvg46b9wl6y5ig22fx5hvpm1n")))) (build-system go-build-system) (arguments (list #:import-path "github.com/ipfs/go-cidutil")) (propagated-inputs (list go-github-com-ipfs-go-cid go-github-com-multiformats-go-multibase go-github-com-multiformats-go-multicodec go-github-com-multiformats-go-multihash)) (home-page "https://github.com/ipfs/go-cidutil") (synopsis "Utility functions and types for working with CIDs") (description "@code{go-cidutil} implements various utilities and helper functions for working with @url{https://github.com/ipld/cid, CIDs}.") (license license:expat))) (define-public go-github-com-ipfs-go-ipfs-cmdkit-files (let ((commit "386fcf8f18a185ec121676665fe2d9574496048d") (revision "0")) (package (name "go-github-com-ipfs-go-ipfs-cmdkit-files") (version (git-version "1.1.3" revision commit)) (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipfs/go-ipfs-cmdkit") (commit commit))) (file-name (git-file-name name version)) (sha256 (base32 "0qk6fshgdmhp8dip2ksm13j6nywi41m9mn0czkvmw6b697z85l2r")))) (build-system go-build-system) (arguments `(#:go ,@(if (supported-package? go-1.16) `(,go-1.16) `(,gccgo-11)) #:unpack-path "github.com/ipfs/go-ipfs-cmdkit" #:import-path "github.com/ipfs/go-ipfs-cmdkit/files")) (home-page "https://github.com/ipfs/go-ipfs-cmdkit") (synopsis "Shared types, functions and values for go-ipfs") (description "@command{cmdkit} offers some types, functions and values that are shared between @command{go-ipfs/commands} and its rewrite @command{go-ipfs-cmds}.") (license license:expat)))) (define-public go-github-com-ipfs-go-ipfs-delay (package (name "go-github-com-ipfs-go-ipfs-delay") (version "0.0.1") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipfs/go-ipfs-delay") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0a5acj622sk1hibnh893mya4h86nsy1dan0wlh9q444c04iqpviw")))) (build-system go-build-system) (arguments (list #:import-path "github.com/ipfs/go-ipfs-delay")) (home-page "https://github.com/ipfs/go-ipfs-delay") (synopsis "Configurable delays to other objects") (description "This package implements a threadsafe configurable delays to other objects.") (license license:expat))) (define-public go-github-com-ipfs-go-ipfs-ds-help (package (name "go-github-com-ipfs-go-ipfs-ds-help") (version "1.1.1") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipfs/go-ipfs-ds-help") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "1xmn9pdyrcim9ahqs9pkh0c9ac71gilb3pb48kcagq8zxf22i4bj")))) (build-system go-build-system) (arguments (list #:import-path "github.com/ipfs/go-ipfs-ds-help")) (propagated-inputs (list go-github-com-ipfs-go-cid go-github-com-ipfs-go-datastore go-github-com-multiformats-go-base32 go-github-com-multiformats-go-multihash)) (home-page "https://github.com/ipfs/go-ipfs-ds-help") (synopsis "Utilities for parsing and creating datastore keys") (description "@code{go-ipfs-ds-help} provides utilities for parsing and creating datastore keys used by @code{go-ipfs} (Kubo).") (license license:expat))) (define-public go-github-com-ipfs-go-datastore (package (name "go-github-com-ipfs-go-datastore") (version "0.6.0") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipfs/go-datastore") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "1xbhh3gm7bgd2d1p821w8gmbh87aix1g1ynhbl7gjaxxyhrsh68n")))) (build-system go-build-system) (arguments (list #:import-path "github.com/ipfs/go-datastore")) (native-inputs (list go-gopkg-in-check-v1)) (propagated-inputs (list go-github-com-google-uuid go-github-com-ipfs-go-detect-race go-github-com-ipfs-go-ipfs-delay go-github-com-jbenet-goprocess go-go-uber-org-multierr go-golang-org-x-xerrors)) (home-page "https://github.com/ipfs/go-datastore") (synopsis "Key-value datastore interfaces") (description "Datastore is a generic layer of abstraction for data store and database access. It is a simple API with the aim to enable application development in a datastore-agnostic way, allowing datastores to be swapped seamlessly without changing application code. Thus, one can leverage different datastores with different strengths without committing the application to one datastore throughout its lifetime.") (license license:expat))) (define-public go-github-com-ipfs-go-detect-race (package (name "go-github-com-ipfs-go-detect-race") (version "0.0.1") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipfs/go-detect-race") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0rqb0q66d7z852j5mhlr025dz698c44w014g4mx587amr1rvwqna")))) (build-system go-build-system) (arguments (list #:import-path "github.com/ipfs/go-detect-race")) (home-page "https://github.com/ipfs/go-detect-race") (synopsis "Detect if compiled with race") (description "Check if the race detector is running.") (license license:expat))) (define-public go-github-com-ipfs-go-ipfs-exchange-interface (package (name "go-github-com-ipfs-go-ipfs-exchange-interface") (version "0.2.1") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipfs/go-ipfs-exchange-interface") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0h5jizhjq4yz9sikqc6yhv5gsb8fgv67v0qjzagyhfznfx8kwv1d")))) (build-system go-build-system) (arguments (list #:import-path "github.com/ipfs/go-ipfs-exchange-interface")) (propagated-inputs (list go-github-com-ipfs-go-block-format go-github-com-ipfs-go-cid)) (home-page "https://github.com/ipfs/go-ipfs-exchange-interface") (synopsis "The IPFS Exchange interface") (description "@code{go-ipfs-exchange-interface} defines the IPFS exchange interface.") (license license:expat))) (define-public go-github-com-ipfs-go-ipfs-redirects-file (package (name "go-github-com-ipfs-go-ipfs-redirects-file") (version "0.1.1") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipfs/go-ipfs-redirects-file") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "16lisd5jbniang85jzfwfigw0kmz73913fsrfj49nh92mpw50qpz")))) (build-system go-build-system) (arguments (list #:import-path "github.com/ipfs/go-ipfs-redirects-file")) (native-inputs (list go-github-com-tj-assert)) (propagated-inputs (list go-github-com-pkg-errors go-github-com-ucarion-urlpath)) (home-page "https://github.com/ipfs/go-ipfs-redirects-file") (synopsis "IPFS Web Gateway _redirects file format parser") (description "Package redirects provides Netlify style _redirects file format parsing.") (license license:expat))) (define-public go-github-com-ipfs-go-ipfs-util (package (name "go-github-com-ipfs-go-ipfs-util") (version "0.0.3") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipfs/go-ipfs-util") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0x80c6a50zcv473xx0b39sz2xkwpiw3nmmjf51k5x7a4rx0rgvx4")))) (build-system go-build-system) (propagated-inputs (list go-github-com-mr-tron-base58 go-github-com-multiformats-go-multihash)) (arguments (list #:import-path "github.com/ipfs/go-ipfs-util")) (home-page "https://github.com/ipfs/go-ipfs-util") (synopsis "Common utilities used by @code{go-ipfs} and related packages") (description "Common utilities used by @code{go-ipfs} and other related Go packages.") (license license:expat))) (define-public go-github-com-ipfs-go-ipld-cbor (package (name "go-github-com-ipfs-go-ipld-cbor") (version "0.1.0") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipfs/go-ipld-cbor") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0yxk4sbf1fk9aaizzpz3h30049wqvaz0s3jnbdd5akhj7wg89h21")))) (build-system go-build-system) (arguments (list #:import-path "github.com/ipfs/go-ipld-cbor")) (propagated-inputs (list go-github-com-ipfs-go-block-format go-github-com-ipfs-go-cid go-github-com-ipfs-go-ipfs-util go-github-com-ipfs-go-ipld-format go-github-com-multiformats-go-multihash go-github-com-polydawn-refmt go-github-com-whyrusleeping-cbor-gen)) (home-page "https://github.com/ipfs/go-ipld-cbor") (synopsis "A cbor implementation of the @code{go-ipld-format}") (description "An implementation of a @url{https://cbor.io/, CBOR} encoded merkledag object.") (license license:expat))) (define-public go-github-com-ipfs-go-ipld-git (package (name "go-github-com-ipfs-go-ipld-git") (version "0.1.1") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipfs/go-ipld-git") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "1v52qzgmx7qym0qzkzkry2kfj58f9hh7c8qycg74sqbd9zb1ynjj")))) (build-system go-build-system) (arguments (list ;; XXX: It requires .git/objects, check if it's applicable to generate ;; git repo during check phase with make-test-repo.sh. #:tests? #f #:import-path "github.com/ipfs/go-ipld-git" #:phases #~(modify-phases %standard-phases (add-after 'unpack 'remove-test-data-files (lambda* (#:key import-path #:allow-other-keys) (with-directory-excursion (string-append "src/" import-path) (for-each delete-file (list "testdata.tar.gz" "codecov.yml" "make-test-repo.sh")))))))) (propagated-inputs (list go-github-com-multiformats-go-multihash go-github-com-ipld-go-ipld-prime go-github-com-ipfs-go-cid go-github-com-ipfs-go-block-format)) (home-page "https://github.com/ipfs/go-ipld-git") (synopsis "IPLD handlers for git objects") (description "This is an IPLD codec which handles git objects. Objects are transformed into IPLD graph as detailed below. Objects are demonstrated here using both @url{https://ipld.io/docs/schemas/,IPLD Schemas} and example JSON forms.") (license license:expat))) (define-public go-github-com-ipfs-go-ipld-format (package (name "go-github-com-ipfs-go-ipld-format") (version "0.6.0") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipfs/go-ipld-format") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0zl172ncmx9h5z2p3d0j1377xm9glw4zfyamks31p0pvvx2kyn7c")))) (build-system go-build-system) (arguments (list #:import-path "github.com/ipfs/go-ipld-format")) (propagated-inputs (list go-github-com-multiformats-go-multihash go-github-com-ipfs-go-block-format go-github-com-ipfs-go-cid)) (home-page "https://github.com/ipfs/go-ipld-format") (synopsis "IPLD Node and Resolver interfaces in Go") (description "@code{go-ipld-format} is a set of interfaces that a type needs to implement in order to be a part of the @acronym{IPLD, InterPlanetary Linked Data} merkle-forest.") (license license:expat))) (define-public go-github-com-ipfs-go-ipld-legacy (package (name "go-github-com-ipfs-go-ipld-legacy") (version "0.2.1") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipfs/go-ipld-legacy") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0sc2zc3lyxy30fzynwdpfrl8jhh1ynwixn1crrv8hzn93yix6550")))) (build-system go-build-system) (arguments (list #:go go-1.21 #:import-path "github.com/ipfs/go-ipld-legacy")) (native-inputs (list go-github-com-stretchr-testify)) (propagated-inputs (list go-github-com-ipfs-go-block-format go-github-com-ipfs-go-cid go-github-com-ipfs-go-ipld-format go-github-com-ipld-go-ipld-prime)) (home-page "https://github.com/ipfs/go-ipld-legacy") (synopsis "Translation layer for IPLD legacy code") (description "@code{go-ipld-format} is a translation layer between @code{go-ipld-prime} nodes and @code{go-ipld-format} legacy interface.") (license (list license:expat license:asl2.0)))) ;; XXX: This repository has been archived by the owner on Jun 20, 2023. It is ;; now read-only. We highly recommend switching to the maintained version at ;; https://github.com/ipfs/boxo/tree/main/verifcid. It's still in use by some ;; dependencies chain for unbundled inputs in Kubo. (define-public go-github-com-ipfs-go-verifcid (package (name "go-github-com-ipfs-go-verifcid") (version "0.0.3") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipfs/go-verifcid") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "05i6wp2nln0mlr1pivmva7j6bwa09k7jl04acx1lw65h4d9nxsjm")))) (build-system go-build-system) (arguments (list #:import-path "github.com/ipfs/go-verifcid")) (native-inputs (list go-github-com-stretchr-testify)) (propagated-inputs (list go-github-com-ipfs-go-cid go-github-com-multiformats-go-multihash)) (home-page "https://github.com/ipfs/go-verifcid") (synopsis "CID security code") (description "@code{go-verifcid} provides @url{https://github.com/ipld/cid, CID} security code prior to it getting merged into @code{go-cid}.") ;; This library is dual-licensed under Apache 2.0 and MIT terms: ;; LICENSE-MIT and LICENSE-APACHE. (license (list license:expat license:asl2.0)))) (define-public go-github-com-ipld-go-codec-dagpb (package (name "go-github-com-ipld-go-codec-dagpb") (version "1.6.0") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipld/go-codec-dagpb") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "1jbrwbgr222wsi95gdflbj350csja6k8vphdq7c9bm50ipr8bvkq")))) (build-system go-build-system) (arguments (list #:go go-1.21 #:import-path "github.com/ipld/go-codec-dagpb")) (propagated-inputs (list go-github-com-ipfs-go-cid go-github-com-ipld-go-ipld-prime go-google-golang-org-protobuf)) (home-page "https://github.com/ipld/go-codec-dagpb/") (synopsis "Implementation of the DAG-PB spec for Go") (description "An implementation of the @url{https://ipld.io/, IPLD DAG-PB} spec for @code{go-ipld-prime}.") (license (list license:expat license:asl2.0)))) (define-public go-github-com-ipld-go-ipld-prime (package (name "go-github-com-ipld-go-ipld-prime") (version "0.21.0") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipld/go-ipld-prime") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "1ycb08h0hvq3mw3sbjkjzp5sfcxmss155jxiv5gjg7myxvzk91ja")))) (build-system go-build-system) (arguments (list #:unpack-path "github.com/ipld/go-ipld-prime/" #:import-path "github.com/ipld/go-ipld-prime/" #:phases #~(modify-phases %standard-phases (add-after 'unpack 'copy-ipld-specfs (lambda* (#:key import-path #:allow-other-keys) (copy-recursively (string-append #$(this-package-native-input "specification-ipld") "/share/ipld/") (string-append "src/" import-path "/ipld"))))))) (native-inputs (list go-github-com-frankban-quicktest go-github-com-warpfork-go-testmark specification-ipld)) (propagated-inputs (list go-github-com-google-go-cmp go-github-com-ipfs-go-block-format go-github-com-ipfs-go-cid go-github-com-multiformats-go-multicodec go-github-com-multiformats-go-multihash go-github-com-polydawn-refmt go-gopkg-in-yaml-v2)) (home-page "https://github.com/ipld/go-ipld-prime") (synopsis "Golang interfaces for the IPLD Data Model") (description "@code{go-ipld-prime} is an implementation of the IPLD spec interfaces, a batteries-included codec implementations of IPLD for CBOR and JSON, and tooling for basic operations on IPLD objects (traversals, etc).") (license license:expat))) (define-public go-github-com-ipfs-go-log-v2 (package (name "go-github-com-ipfs-go-log-v2") (version "2.5.1") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipfs/go-log") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "1yh3sw8knpy364h8h8rqw193whnjd6fbc13cxh6zs29z3x2a7aqa")))) (build-system go-build-system) (propagated-inputs (list go-github-com-mattn-go-isatty go-go-uber-org-multierr go-go-uber-org-zap)) (arguments (list #:import-path "github.com/ipfs/go-log/v2")) (home-page "https://github.com/ipfs/go-log") (synopsis "Logging library used by @code{go-ipfs}") (description "@code{go-log} wraps @url{https://github.com/uber-go/zap, zap} to provide a logging facade. @code{go-log} manages logging instances and allows for their levels to be controlled individually.") (license license:expat))) (define-public go-github-com-ipfs-go-log (package (inherit go-github-com-ipfs-go-log-v2) (name "go-github-com-ipfs-go-log") (version "1.0.5") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipfs/go-log") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0gj2yqrv6wgpkv6f9c1anmw5kwg59plv0jrcxb3zmjrnk8fsn1jr")))) (propagated-inputs (list go-github-com-gogo-protobuf go-github-com-ipfs-go-log-v2 go-github-com-opentracing-opentracing-go go-go-uber-org-zap)) (arguments (list #:import-path "github.com/ipfs/go-log")))) (define-public go-github-com-ipfs-go-metrics-interface (package (name "go-github-com-ipfs-go-metrics-interface") (version "0.0.1") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ipfs/go-metrics-interface") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "09xc71175sfnqlizkbw066jagnbag9ihvs240z6g6dm2yx3w5xgy")))) (build-system go-build-system) (arguments (list #:import-path "github.com/ipfs/go-metrics-interface")) (propagated-inputs (list go-github-com-ipfs-go-cid go-github-com-ipfs-go-datastore go-github-com-multiformats-go-base32 go-github-com-multiformats-go-multihash)) (home-page "https://github.com/ipfs/go-metrics-interface") ;; XXX: The project neither has no a proper description, nor a README, see ;; <https://github.com/ipfs/go-metrics-interface/issues/1>. (synopsis "Metrics interface for IPFS") (description "Metrics interface for IPFS (Kubo).") (license license:expat))) (define-public go-github-com-whyrusleeping-cbor-gen (package (name "go-github-com-whyrusleeping-cbor-gen") (version "v0.0.0-20230818171029-f91ae536ca25") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/whyrusleeping/cbor-gen") (commit (go-version->git-ref version)))) (file-name (git-file-name name version)) (sha256 (base32 "08by7pqh4fcwf2va01iif75yqkfssi6d48334404mmv9jmhzim60")))) (build-system go-build-system) (arguments (list #:import-path "github.com/whyrusleeping/cbor-gen")) (propagated-inputs (list go-github-com-ipfs-go-cid go-github-com-google-go-cmp go-golang-org-x-xerrors)) (home-page "https://github.com/whyrusleeping/cbor-gen") (synopsis "Codegen for CBOR codecs on the specified types") (description "Basic utilities to generate fast path @url{https://cbor.io/, CBOR} codecs for types.") (license license:expat))) (define-public kubo (package (name "kubo") (version "0.29.0") (source (origin (method url-fetch/tarbomb) (uri (string-append "https://dist.ipfs.io/kubo/v" version "/kubo-source.tar.gz")) (sha256 (base32 "121zm4k0wz2iqrl65c7bdg5d2bvz3hvj4pavk5178dyd1p49bl5r")) (file-name (string-append name "-" version "-source")) (modules '((guix build utils))) (snippet '(for-each delete-file-recursively ;; TODO: unbundle the rest as well '("vendor/bazil.org" "vendor/github.com/alecthomas" "vendor/github.com/benbjohnson" "vendor/github.com/beorn7" "vendor/github.com/blang" "vendor/github.com/cenkalti" "vendor/github.com/cespare" "vendor/github.com/cheggaaa" "vendor/github.com/coreos" "vendor/github.com/davecgh" "vendor/github.com/docker" "vendor/github.com/dustin" "vendor/github.com/elgris" "vendor/github.com/facebookgo" "vendor/github.com/felixge" "vendor/github.com/flynn" "vendor/github.com/francoispqt" "vendor/github.com/fsnotify" "vendor/github.com/gabriel-vasile" "vendor/github.com/go-kit" "vendor/github.com/go-logfmt" "vendor/github.com/go-logr" "vendor/github.com/go-task" "vendor/github.com/godbus" "vendor/github.com/gogo" "vendor/github.com/golang" "vendor/github.com/google" "vendor/github.com/gorilla" "vendor/github.com/hashicorp" "vendor/github.com/huin" "vendor/github.com/ipfs/go-bitfield" "vendor/github.com/ipfs/go-block-format" "vendor/github.com/ipfs/go-cid" "vendor/github.com/ipfs/go-cidutil" "vendor/github.com/ipfs/go-datastore" "vendor/github.com/ipfs/go-detect-race" "vendor/github.com/ipfs/go-ipfs-delay" "vendor/github.com/ipfs/go-ipfs-redirects-file" "vendor/github.com/ipfs/go-ipfs-util" "vendor/github.com/ipfs/go-ipld-cbor" "vendor/github.com/ipfs/go-ipld-format" "vendor/github.com/ipfs/go-ipld-git" "vendor/github.com/ipfs/go-ipld-legacy" "vendor/github.com/ipfs/go-log" "vendor/github.com/ipfs/go-metrics-interface" "vendor/github.com/ipfs/go-verifcid" "vendor/github.com/ipld/go-codec-dagpb" "vendor/github.com/ipld/go-ipld-prime" "vendor/github.com/jackpal" "vendor/github.com/jbenet" "vendor/github.com/julienschmidt" "vendor/github.com/klauspost" "vendor/github.com/koron" "vendor/github.com/libp2p/go-buffer-pool" "vendor/github.com/libp2p/go-cidranger" "vendor/github.com/libp2p/go-doh-resolver" "vendor/github.com/libp2p/go-flow-metrics" "vendor/github.com/libp2p/go-libp2p-asn-util" "vendor/github.com/libp2p/go-msgio" "vendor/github.com/libp2p/go-nat" "vendor/github.com/libp2p/go-netroute" "vendor/github.com/libp2p/go-reuseport" "vendor/github.com/libp2p/go-socket-activation" "vendor/github.com/libp2p/go-yamux" "vendor/github.com/libp2p/zeroconf" "vendor/github.com/mattn" "vendor/github.com/mgutz" "vendor/github.com/miekg" "vendor/github.com/minio" "vendor/github.com/mitchellh" "vendor/github.com/mr-tron" "vendor/github.com/multiformats" "vendor/github.com/onsi" "vendor/github.com/opentracing" "vendor/github.com/pbnjay" "vendor/github.com/pion" "vendor/github.com/pkg" "vendor/github.com/pmezard" "vendor/github.com/polydawn" "vendor/github.com/prometheus" "vendor/github.com/quic-go" "vendor/github.com/rs" "vendor/github.com/spaolacci" "vendor/github.com/stretchr" "vendor/github.com/syndtr" "vendor/github.com/tidwall" "vendor/github.com/ucarion" "vendor/github.com/whyrusleeping" "vendor/go.uber.org" "vendor/golang.org" "vendor/google.golang.org/protobuf" "vendor/gopkg.in" "vendor/lukechampine.com"))))) (build-system go-build-system) (arguments (list #:unpack-path "github.com/ipfs/kubo" #:import-path "github.com/ipfs/kubo/cmd/ipfs" #:phases #~(modify-phases %standard-phases ;; FIXME: src/github.com/libp2p/go-libp2p-asn-util/asn.go:12:12: ;; pattern sorted-network-list.bin: cannot embed irregular file ;; sorted-network-list.bin ;; ;; This happens due to Golang can't determine the valid directory of ;; the module which is sourced during setup environment phase, but ;; easy resolved after coping to expected directory "vendor" within ;; the current package, see details in Golang source: ;; ;; - URL: <https://github.com/golang/go/blob/> ;; - commit: 82c14346d89ec0eeca114f9ca0e88516b2cda454 ;; - file: src/cmd/go/internal/load/pkg.go#L2059 (add-before 'build 'copy-input-to-vendor-directory (lambda* (#:key unpack-path #:allow-other-keys) (with-directory-excursion (string-append "src/" unpack-path) (copy-recursively (string-append #$(this-package-input "go-github-com-libp2p-go-libp2p-asn-util") "/src/github.com") "vendor/github.com")))) ;; https://github.com/ipfs/kubo/blob/master/docs/command-completion.md (add-after 'install 'install-bashcompletion (lambda _ (let ((completiondir (string-append #$output "/etc/bash_completion.d"))) (mkdir-p completiondir) (with-output-to-file (string-append completiondir "/ipfs") (lambda _ (invoke #$(if (%current-target-system) "ipfs" #~(string-append #$output "/bin/ipfs")) "commands" "completion" "bash"))))))))) (inputs (list ;; Direct requirements as seen in kubo's go.mod file. ;; ;; XXX: Uncomment out when package is available in Guix, ;; otherwise it will be sourced from provided vendor ;; directory. ;; go-bazil-org-fuse ;;go-contrib-go-opencensus-io-exporter-prometheus go-github-com-benbjohnson-clock go-github-com-blang-semver-v4 go-github-com-cenkalti-backoff-v4 ;;go-github-com-ceramicnetwork-go-dag-jose go-github-com-cheggaaa-pb go-github-com-coreos-go-systemd-v22 go-github-com-dustin-go-humanize go-github-com-elgris-jsondiff go-github-com-facebookgo-atomicfile go-github-com-fsnotify-fsnotify go-github-com-google-uuid go-github-com-hashicorp-go-multierror ;;go-github-com-ipfs-boxo go-github-com-ipfs-go-block-format go-github-com-ipfs-go-cid go-github-com-ipfs-go-cidutil go-github-com-ipfs-go-datastore go-github-com-ipfs-go-detect-race ;;go-github-com-ipfs-go-ds-badger ;;go-github-com-ipfs-go-ds-flatfs ;;go-github-com-ipfs-go-ds-leveldb ;;go-github-com-ipfs-go-ds-measure ;;go-github-com-ipfs-go-fs-lock ;;go-github-com-ipfs-go-ipfs-cmds go-github-com-ipfs-go-ipld-cbor go-github-com-ipfs-go-ipld-format go-github-com-ipfs-go-ipld-git go-github-com-ipfs-go-ipld-legacy go-github-com-ipfs-go-log go-github-com-ipfs-go-log-v2 go-github-com-ipfs-go-metrics-interface ;;go-github-com-ipfs-go-metrics-prometheus ;;go-github-com-ipfs-go-unixfsnode ;;go-github-com-ipfs-shipyard-nopfs ;;go-github-com-ipfs-shipyard-nopfs-ipfs ;;go-github-com-ipld-go-car ;;go-github-com-ipld-go-car-v2 go-github-com-ipld-go-codec-dagpb go-github-com-ipld-go-ipld-prime go-github-com-jbenet-go-random go-github-com-jbenet-go-temp-err-catcher go-github-com-jbenet-goprocess go-github-com-julienschmidt-httprouter go-github-com-libp2p-go-doh-resolver ;;go-github-com-libp2p-go-libp2p ;;go-github-com-libp2p-go-libp2p-http ;;go-github-com-libp2p-go-libp2p-kad-dht ;;go-github-com-libp2p-go-libp2p-kbucket ;;go-github-com-libp2p-go-libp2p-pubsub ;;go-github-com-libp2p-go-libp2p-pubsub-router ;;go-github-com-libp2p-go-libp2p-record ;;go-github-com-libp2p-go-libp2p-routing-helpers ;;go-github-com-libp2p-go-libp2p-testing go-github-com-libp2p-go-socket-activation go-github-com-mitchellh-go-homedir go-github-com-multiformats-go-multiaddr go-github-com-multiformats-go-multiaddr-dns go-github-com-multiformats-go-multibase go-github-com-multiformats-go-multicodec go-github-com-multiformats-go-multihash go-github-com-opentracing-opentracing-go go-github-com-pbnjay-memory go-github-com-prometheus-client-golang go-github-com-stretchr-testify go-github-com-syndtr-goleveldb go-github-com-tidwall-gjson go-github-com-tidwall-sjson go-github-com-whyrusleeping-go-sysinfo go-github-com-whyrusleeping-multiaddr-filter ;;go-go-opencensus-io ;;go-go-opentelemetry-io-contrib-instrumentation-net-http-otelhttp ;;go-go-opentelemetry-io-contrib-propagators-autoprop ;;go-go-opentelemetry-io-otel ;;go-go-opentelemetry-io-otel-sdk ;;go-go-opentelemetry-io-otel-trace go-go-uber-org-dig go-go-uber-org-fx go-go-uber-org-multierr go-go-uber-org-zap go-golang-org-x-crypto go-golang-org-x-exp go-golang-org-x-mod go-golang-org-x-sync go-golang-org-x-sys go-google-golang-org-protobuf ;; ;; A list of indirect dependencies required for the vendored ;; models. ;; XXX: Remove them when all of the vendored packages are ;; available. ;; go-github-com-alecthomas-units ; github.com/ipfs/boxo go-github-com-cespare-xxhash go-github-com-docker-go-units ; github.com/containerd/cgroups go-github-com-felixge-httpsnoop ; go.opentelemetry.io/contrib/instrumentation/net/http/otelhttp go-github-com-flynn-noise ; github.com/libp2p/go-libp2p go-github-com-gabriel-vasile-mimetype ; github.com/ipfs/boxo go-github-com-go-logr-stdr ; go.opentelemetry.io/otel go-github-com-golang-groupcache ; go.opencensus.io/trace go-github-com-google-gopacket ; github.com/libp2p/go-libp2p-kad-dht go-github-com-gorilla-mux ; github.com/ipfs/boxo go-github-com-gorilla-websocket ; github.com/libp2p/go-libp2p go-github-com-hashicorp-golang-lru ; github.com/libp2p/go-libp2p-kad-dht go-github-com-hashicorp-golang-lru-v2 ; github.com/ipfs/boxo go-github-com-ipfs-go-bitfield ; github.com/ipfs/boxo go-github-com-ipfs-go-ipfs-redirects-file ; github.com/ipfs/boxo go-github-com-ipfs-go-verifcid ; github.com/ipfs/go-blockservice go-github-com-klauspost-compress ; github.com/libp2p/go-libp2p go-github-com-libp2p-go-buffer-pool ; github.com/libp2p/go-libp2p go-github-com-libp2p-go-cidranger ; github.com/libp2p/go-libp2p-kbucket go-github-com-libp2p-go-flow-metrics ; github.com/libp2p/go-libp2p go-github-com-libp2p-go-libp2p-asn-util ; github.com/libp2p/go-libp2p-kbucket go-github-com-libp2p-go-msgio ; github.com/libp2p/go-libp2p-kad-dht go-github-com-libp2p-go-nat ; github.com/libp2p/go-libp2p go-github-com-libp2p-go-reuseport ; github.com/libp2p/go-libp2p go-github-com-libp2p-go-yamux-v4 ; github.com/libp2p/go-libp2p go-github-com-libp2p-zeroconf-v2 ; github.com/libp2p/go-libp2p go-github-com-multiformats-go-multiaddr-fmt ; github.com/libp2p/go-libp2p go-github-com-multiformats-go-multistream ; github.com/libp2p/go-libp2p go-github-com-pion-webrtc-v3 ; github.com/libp2p/go-libp2p go-github-com-prometheus-statsd-exporter ; contrib.go.opencensus.io/exporter/prometheus go-github-com-quic-go-quic-go ; github.com/libp2p/go-libp2p go-github-com-quic-go-webtransport-go ; github.com/libp2p/go-libp2p go-github-com-rs-cors ; github.com/ipfs/go-ipfs-cmds go-github-com-whyrusleeping-base32 ; github.com/ipfs/boxo go-github-com-whyrusleeping-cbor ; github.com/ipld/go-car go-github-com-whyrusleeping-chunker ; github.com/ipfs/boxo go-github-com-whyrusleeping-go-keyspace ; github.com/libp2p/go-libp2p-kad-dht go-golang-org-x-oauth2 ; github.com/ipfs/boxo go-golang-org-x-term ; github.com/ipfs/go-ipfs-cmds go-golang-org-x-xerrors ; github.com/whyrusleeping/cbor-gen go-gopkg-in-square-go-jose-v2 ; github.com/ceramicnetwork/go-dag-jose )) (native-inputs (append (if (%current-target-system) (list this-package) '()) (list python-minimal-wrapper zsh))) (home-page "https://ipfs.tech") (synopsis "Go implementation of IPFS, a peer-to-peer hypermedia protocol") (description "IPFS is a global, versioned, peer-to-peer file system. It combines good ideas from Git, BitTorrent, Kademlia, SFS, and the Web. It is like a single bittorrent swarm, exchanging git objects. IPFS provides an interface as simple as the HTTP web, but with permanence built in. You can also mount the world at @code{/ipfs}.") (license license:expat))) (define-public go-ipfs (deprecated-package "go-ipfs" kubo))