aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages wv)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages image)
  #:use-module (gnu packages pkg-config)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:))

(define-public wv
  (package
    (name "wv")
    (version "1.2.9")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://abiword.org/downloads/wv/"
                           version "/wv-" version ".tar.gz"))
       (sha256
        (base32 "17f16lkdv1c3amaz2hagiicih59ynpp4786k1m2qa1sw68xhswsc"))))
    (build-system gnu-build-system)
    (inputs
      (list glib libgsf libjpeg-turbo libpng zlib))
    (native-inputs
      (list `(,glib "bin") pkg-config))
    (synopsis "Microsoft Word conversion library and utilities")
    (description
     "wv converts files written by Word 2000, 97, 95, and 6 (known internally as
Word 9, 8, 7, and 6) to HTML or LaTeX.  Word 2 documents can still be converted
to plain text but will lack formatting.

Other programs can use wv as a library to convert Word documents to other
formats.  AbiWord uses it as its Word importer, and KWord uses concepts and
code from wv in theirs.")
    (home-page "https://wvware.sourceforge.net/")
    (license license:gpl2+)))
023-07-26 10:40:15 -0400'>2023-07-26services: mpd; Refactor start slot directory initialization....Maxim Cournoyer 2023-07-26services: mpd: List log-level in decreasing verbosity order in doc....Maxim Cournoyer 2023-07-25services: mpd: Rename %set-user-group to set-user-group....Maxim Cournoyer 2023-07-25services: mpd: Streamline mpd-user-sanitizer and mympd-user-sanitizer....Maxim Cournoyer 2023-07-25services: mpd: Add an 'update' action to trigger a database update....Maxim Cournoyer 2023-07-25services: mpd: Add auto-update? field to mpd-configuration....Maxim Cournoyer 2023-04-02services: mympd: Use records for user and group fields....Bruno Victal 2023-04-02services: mpd: Use proper records for user and group fields....Bruno Victal 2023-04-02services: mpd: Fix unintentional API breakage for mixer-type field....Bruno Victal 2023-04-02services: replace bare serializers with (serializer ...)...Bruno Victal 2023-03-24services: mpd: Set PulseAudio-related variables....Bruno Victal 2023-03-24services: audio: Remove redundant list-of-string? predicate....Bruno Victal 2023-03-24services: mympd: Require 'syslog service when configured to log to syslog....Bruno Victal 2023-02-05services: mpd: Fix serialization procedure for list-of-string....Bruno Victal 2023-02-05services: Add mympd-service-type....Bruno Victal 2023-02-05services: mpd: Do not hardcode environment variables....Bruno Victal 2023-02-05services: mpd: Refactor MPD service....Bruno Victal 2023-02-05services: mpd: Rewrite using 'define-configuration'....Bruno Victal 2020-12-06services: mpd: Make /var/run/mpd/USER user-owned....Ludovic Courtès 2020-11-06services: mpd: Fix daemon startup....Ludovic Courtès 2020-11-06services: mpd: Always create the "mpd" user account....Ludovic Courtès 2020-11-06services: mpd: Do not eagerly look for a user....Maxim Cournoyer 2020-05-13services: Add missing import....Ludovic Courtès