aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages wv)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages image)
  #:use-module (gnu packages pkg-config)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:))

(define-public wv
  (package
    (name "wv")
    (version "1.2.9")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://abiword.org/downloads/wv/"
                           version "/wv-" version ".tar.gz"))
       (sha256
        (base32 "17f16lkdv1c3amaz2hagiicih59ynpp4786k1m2qa1sw68xhswsc"))))
    (build-system gnu-build-system)
    (inputs
      (list glib libgsf libjpeg-turbo libpng zlib))
    (native-inputs
      (list `(,glib "bin") pkg-config))
    (synopsis "Microsoft Word conversion library and utilities")
    (description
     "wv converts files written by Word 2000, 97, 95, and 6 (known internally as
Word 9, 8, 7, and 6) to HTML or LaTeX.  Word 2 documents can still be converted
to plain text but will lack formatting.

Other programs can use wv as a library to convert Word documents to other
formats.  AbiWord uses it as its Word importer, and KWord uses concepts and
code from wv in theirs.")
    (home-page "https://wvware.sourceforge.net/")
    (license license:gpl2+)))
h-path'....Ludovic Courtès 2018-05-13packages: 'find-packages-by-name' properly honors version prefixes....Ludovic Courtès 2018-04-08discovery: Remove dependency on (guix ui)....Ludovic Courtès 2018-04-08Add (guix self)....Ludovic Courtès 2017-11-07packages: 'fold-packages' takes #:select? parameter....Ludovic Courtès 2017-09-01packages: 'fold-packages' takes an optional 'modules' parameter....Ludovic Courtès 2017-06-11packages: Add 'specifications->manifest'....Ludovic Courtès 2017-05-03Add (guix discovery)....Ludovic Courtès 2017-05-03ui: Rename '_' to 'G_'....Ludovic Courtès 2017-05-01packages: Remove support for PACKAGE-VERSION deprecated syntax....Ludovic Courtès 2017-03-08packages: Use PACKAGE@VERSION syntax when reporting ambiguities....Ludovic Courtès 2017-02-27packages: Add 'search-auxiliary-file'....Alex Kost 2017-01-28Use 'mlambda' instead of 'memoize'....Ludovic Courtès 2017-01-28Add (guix memoization)....Ludovic Courtès 2016-09-20ui: Do not shadow '_' where it's used as a literal syntax match....Ludovic Courtès 2016-09-06packages: Add 'package-superseded' and associated support....Ludovic Courtès 2016-07-28packages: Add 'hidden-package'....Ludovic Courtès 2016-06-20packages: Export 'scheme-modules'....Ludovic Courtès 2016-05-04utils: Move combinators to (guix combinators)....Ludovic Courtès 2016-04-14packages: Add 'search-patches'....Alex Kost 2016-03-08packages: Gracefully report packages not found....Ludovic Courtès 2016-03-08packages: Support the deprecated "NAME-VERSION" syntax....Ludovic Courtès 2016-03-08packages: Clarify NAME-VERSION deprecation message....Ludovic Courtès 2016-03-02utils: Use '@' for separating package names and version numbers....Mathieu Lirzin 2016-03-02packages: Factorize package specification search....Mathieu Lirzin 2016-02-24Do not check package freshness during upgrade....Alex Kost 2015-12-20packages: Remove now redundant graph procedures....Ludovic Courtès