aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages wv)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages image)
  #:use-module (gnu packages pkg-config)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:))

(define-public wv
  (package
    (name "wv")
    (version "1.2.9")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://abiword.org/downloads/wv/"
                           version "/wv-" version ".tar.gz"))
       (sha256
        (base32 "17f16lkdv1c3amaz2hagiicih59ynpp4786k1m2qa1sw68xhswsc"))))
    (build-system gnu-build-system)
    (inputs
      (list glib libgsf libjpeg-turbo libpng zlib))
    (native-inputs
      (list `(,glib "bin") pkg-config))
    (synopsis "Microsoft Word conversion library and utilities")
    (description
     "wv converts files written by Word 2000, 97, 95, and 6 (known internally as
Word 9, 8, 7, and 6) to HTML or LaTeX.  Word 2 documents can still be converted
to plain text but will lack formatting.

Other programs can use wv as a library to convert Word documents to other
formats.  AbiWord uses it as its Word importer, and KWord uses concepts and
code from wv in theirs.")
    (home-page "https://wvware.sourceforge.net/")
    (license license:gpl2+)))
...* gnu/packages/irc.scm: Remove duplicate #:use-module (guix utils). Tobias Geerinckx-Rice 2023-07-23gnu: Add glirc....* gnu/packages/irc.scm (glirc): New public variable. Tobias Geerinckx-Rice 2023-07-28gnu: weechat: Update to 4.0.2....* gnu/packages/irc.scm (weechat): Update to 4.0.2. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> fanquake 2023-06-30gnu: weechat: Update to 4.0.0....* gnu/packages/irc.scm (weechat): Update to 4.0.0. [arguments]: Adjust the configure-flags to continue enable building the docs. Efraim Flashner 2023-05-20gnu: irssi: Update to 1.4.4....* gnu/packages/irc.scm (irssi): Update to 1.4.4. André Batista 2023-04-30gnu: inspircd: Build with mariadb....* gnu/packages/irc.scm (inspircd)[inputs]: Remove mysql. Add mariadb:dev. Efraim Flashner 2023-02-17gnu: Add chathistorysync....* gnu/packages/irc.scm (chathistorysync): New variable. Co-authored-by: ( <paren@disroot.org> Signed-off-by: Christopher Baines <mail@cbaines.net> jgart 2023-02-17gnu: Add go-gopkg-in-irc-v3....* gnu/packages/irc.scm (go-gopkg-in-irc-v3): New variable. Co-authored-by: ( <paren@disroot.org> Signed-off-by: Christopher Baines <mail@cbaines.net> jgart 2023-01-12gnu: kirc: Update to 0.3.2....* gnu/packages/irc.scm (kirc): Update to 0.3.2. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> jgart 2023-01-12gnu: litterbox: Update to 1.9....* gnu/packages/irc.scm (litterbox): Update to 1.9. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> jgart 2023-01-12gnu: catgirl: Update to 2.1....* gnu/packages/irc.scm (catgirl): Update to 2.1. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> jgart 2023-01-12gnu: weechat: Update to 3.8....* gnu/packages/irc.scm (weechat): Update to 3.8. [arguments]: Do not build tests any more: since version 3.8, ‘make test’ is successful when tests are not built. [native-inputs]: Remove dependency on cpputest as tests are not built any more. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Sébastien Helleu 2022-12-11gnu: ii: Use G-expressions....* gnu/packages/irc.scm (ii)[arguments]: Rewrite as G-expressions. Tobias Geerinckx-Rice 2022-12-11gnu: ii: Update to 2.0....* gnu/packages/irc.scm (ii): Update to 2.0. Tobias Geerinckx-Rice 2022-11-19gnu: irssi: Update to 1.4.3....* gnu/packages/irc.scm (irssi): Update to 1.4.3. Signed-off-by: Christopher Baines <mail@cbaines.net> jgart 2022-11-05gnu: srain: Update to 1.5.0....* gnu/packages/irc.scm (srain): Update to 1.5.0. Vinicius Monego 2022-08-21gnu: srain: Update to 1.4.1....* gnu/packages/irc.scm (srain): Update to 1.4.1. Vinicius Monego 2022-07-31gnu: qttools: Rename to qttools-5....Automated with: git grep -l qttools | xargs sed 's/\bqttools\b/\0-5/g' -i git checkout NEWS Maxim Cournoyer