aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages wv)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages image)
  #:use-module (gnu packages pkg-config)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:))

(define-public wv
  (package
    (name "wv")
    (version "1.2.9")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://abiword.org/downloads/wv/"
                           version "/wv-" version ".tar.gz"))
       (sha256
        (base32 "17f16lkdv1c3amaz2hagiicih59ynpp4786k1m2qa1sw68xhswsc"))))
    (build-system gnu-build-system)
    (inputs
      (list glib libgsf libjpeg-turbo libpng zlib))
    (native-inputs
      (list `(,glib "bin") pkg-config))
    (synopsis "Microsoft Word conversion library and utilities")
    (description
     "wv converts files written by Word 2000, 97, 95, and 6 (known internally as
Word 9, 8, 7, and 6) to HTML or LaTeX.  Word 2 documents can still be converted
to plain text but will lack formatting.

Other programs can use wv as a library to convert Word documents to other
formats.  AbiWord uses it as its Word importer, and KWord uses concepts and
code from wv in theirs.")
    (home-page "https://wvware.sourceforge.net/")
    (license license:gpl2+)))
>2024-08-31gnu: guile-2.0: Add libxcrypt dependency....* gnu/packages/guile.scm (guile-2.0): Add libxcrypt dependency, and include it in the pkg-config file's flags. * gnu/packages/commencement.scm (guile-final): Explicitely exclude libxcrypt dependency. Change-Id: Ie01913971b225c4dd23dcfdb96348d4e11042da8 Josselin Poiret 2024-08-31gnu: guile-1.8: Add libxcrypt dependency....* gnu/packages/guile.scm (guile-1.8): Add libxcrypt dependency, and include it in the pkg-config file's flags. Change-Id: I050e8d2bee0b6195a6a854338d39a9594b0088b9 Josselin Poiret 2024-08-28gnu: guile-git: Switch to libgit2 1.8....* gnu/packages/guile.scm (guile-git)[inputs]: Replace ‘libgit2-1.7’ by ‘libgit2-1.8’. Change-Id: I0b9c6f9efb813c2af589ebf291c6f66ff81b87d9 Ludovic Courtès 2024-08-28gnu: guile-git: Update to 0.8.0....* gnu/packages/guile.scm (guile-git): Update to 0.8.0. Change-Id: I97ed6c88402e53935d7f1cec335a7982f3e33417 Ludovic Courtès 2024-08-21gnu: guile-zlib: Update to 0.2.1....* gnu/packages/guile.scm (guile-zlib): Update to 0.2.1. [arguments]: Remove. Change-Id: Id19309dfcaece713ad2a56294d18bf91ddcdc6e9 Ludovic Courtès 2024-07-19Revert "gnu: guile: Update to 3.0.10."...This reverts commit e31299010f6b8ccb3ccd1cc34a0d03483387ea36 and 24163eea584663568b68e19f364256fc7396b61f. The upgrade causes build failures, as noticeably by running ‘guix pull’, that are being investigated at <https://issues.guix.gnu.org/72183>. Change-Id: I946b43d938666d9dcddf1e5d856b02462bd8e453 Ludovic Courtès 2024-07-19gnu: guile: Update to 3.0.10....* gnu/packages/guile.scm (guile-3.0-latest): Update to 3.0.10. Change-Id: Id9d58199f1fa3307c94f442c185307d2f4a9ce6f David Thompson