aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2019-2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2021 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages wget)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix gexp)
  #:use-module (gnu packages)
  #:use-module (gnu packages bash)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages documentation)
  #:use-module (gnu packages gnunet)
  #:use-module (gnu packages gnupg)
  #:use-module (gnu packages libidn)
  #:use-module (gnu packages pcre)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages python)
  #:use-module (gnu packages tls)
  #:use-module (gnu packages web)
  #:use-module (gnu packages xdisorg)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu))

(define-public wget
  (package
    (name "wget")
    (version "1.21.4")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/wget/wget-"
                          version ".tar.lz"))
      (sha256
       (base32
        "1nabhxx3rg28h2scba2mlawzjyx3dw07j2kjn76cpvahbyd630rn"))))
    (build-system gnu-build-system)
    (inputs
     (list gnutls libidn2 libpsl))
    (native-inputs
     (list lzip
           pkg-config
           perl
           python ;for testenv suite
           perl-http-daemon
           perl-io-socket-ssl))
    (home-page "https://www.gnu.org/software/wget/")
    (synopsis "Non-interactive command-line utility for downloading files")
    (description
     "GNU Wget is a non-interactive tool for fetching files using the HTTP,
HTTPS and FTP protocols.  It can resume interrupted downloads, use file name
wild cards, supports proxies and cookies, and it can convert absolute links
in downloaded documents to relative links.")
    (license license:gpl3+))) ; some files are under GPLv2+

(define-public wgetpaste
  (package
    (name "wgetpaste")
    (version "2.34")
    (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/zlin/wgetpaste")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
         (base32 "1z70wfzkrzlhhqm82i5gdk6clmsc06n9gsf2wizb1kzk3h61h296"))))
    (build-system gnu-build-system)
    (arguments
     `(#:modules ((guix build gnu-build-system)
                  (guix build utils)
                  (srfi srfi-1))
       #:phases
       (modify-phases %standard-phases
         (delete 'configure)
         (delete 'build)
         (replace 'install
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (bin (string-append out "/bin"))
                    (zsh (string-append out "/share/zsh/site-functions")))
               (install-file "wgetpaste" bin)
               (install-file "_wgetpaste" zsh))))
         (add-after 'install 'wrap-program
           ;; /bin/wgetpaste prides itself on relying only on the following
           ;; inputs, and doesn't need to execute arbitrary commands, so
           ;; override PATH completely to detect any new dependencies early.
           (lambda* (#:key outputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out")))
               (wrap-program (string-append out "/bin/wgetpaste")
                 `("PATH" ":" =
                   ,(delete-duplicates
                     (map (lambda (command) (dirname (which command)))
                          (list "bash" "mktemp" "sed" "sort" "tee" "tr"
                                "wget" "xclip")))))))))
       #:tests? #f))                    ; no test target
    (inputs
     (list bash-minimal wget xclip))
    (home-page "https://wgetpaste.zlin.dk/")
    (synopsis "Script that automates pasting to a number of pastebin services")
    (description
     "@code{wgetpaste} is an extremely simple command-line interface to various
online pastebin services.")
    (license license:expat)))

(define-public wget2
  (package
    (name "wget2")
    (version "2.2.0")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/wget/wget2-" version ".tar.gz"))
              (sha256
               (base32
                "0mykji96ap5acdh416x1d7c3h657mj6iy7zlllyd69pvny2rqfrb"))))
    (build-system gnu-build-system)
    (arguments
     (list #:phases #~(modify-phases %standard-phases
                        (add-after 'unpack 'skip-network-tests
                          (lambda _
                            (substitute* "tests/Makefile.in"
                              (("test-gpg-verify-no-file\\$\\(EXEEXT)") "")
                              (("test-gpg-valid\\$\\(EXEEXT)") "")
                              (("test-gpg-styles\\$\\(EXEEXT)") "")))))
           #:configure-flags
           #~(list "--enable-static=no"
                   "--with-bzip2=yes"
                   "--with-lzma=yes")))
    (inputs (list brotli
                  bzip2
                  gnutls/dane
                  gpgme
                  libidn2
                  libmicrohttpd
                  libpsl
                  `(,nghttp2 "lib")
                  pcre2
                  xz
                  zlib
                  `(,zstd "lib")))
    ;; TODO: Add libhsts.
    (native-inputs (list pkg-config))
    (home-page "https://gitlab.com/gnuwget/wget2")
    (synopsis "Successor of GNU Wget")
    (description
     "GNU Wget2 is the successor of GNU Wget, a file and recursive website
downloader.  Designed and written from scratch it wraps around libwget, that
provides the basic functions needed by a web client.")
    (properties '((ftp-directory . "/gnu/wget")))
    (license (list license:gpl3+ license:lgpl3+))))
sh, kdbusaddons, kdnssd, ki18n, kiconthemes, kio, kjobwidgets, knotifications, knotifyconfig, ktextwidgets, kwallet, kwidgetsaddons, kwindowsystem, kxmlgui, and solid; add kauth-5, kconfig-5, kconfigwidgets-5, kcompletion-5, kcoreaddons-5, kcrash-5, kdbusaddons-5, kdnssd-5, ki18n-5, kiconthemes-5, kio-5, kjobwidgets-5, knotifications-5, knotifyconfig-5, ktextwidgets-5, kwallet-5, kwidgetsaddons-5, kwindowsystem-5, kxmlgui-5, and solid-5. [native-inputs]: Remove kdoctools; add kdoctools-5. Change-Id: I16b512f63b821c0bad0f20c39b044edff38ba5f5 Zheng Junjie 2024-07-18gnu: wacomtablet: Fix build....* gnu/packages/kde-utils.scm (wacomtablet): Fix build. [inputs]: Remove kcoreaddons, ki18n, kglobalaccel, kconfig, kxmlgui, kwidgetsaddons, kwindowsystem, knotifications, and kdbusaddons; add kcoreaddons-5, ki18n-5, kglobalaccel-5, kconfig-5, kxmlgui-5, kwidgetsaddons-5, kwindowsystem-5, knotifications-5, and kdbusaddons-5. [native-inputs]: Remove kdoctools; add kdoctools-5. Change-Id: I0026e4eb3295ed30339cfba00e5a563d985a53b5 Zheng Junjie 2024-07-18gnu: okteta: Update to 0.26.15....* gnu/packages/kde-utils.scm (okteta): Update to 0.26.15. [inputs]: Remove kbookmarks, kcmutils, kcodecs, kcrash, kcompletion, kconfigwidgets, kdbusaddons, ki18n, kiconthemes, kio, knewstuff, kparts, kservice, kwidgetsaddons, and kxmlgui; add kbookmarks-5, kcmutils-5, kcodecs-5, kcrash-5, kcompletion-5, kconfigwidgets-5, kdbusaddons-5, ki18n-5, kiconthemes-5, kio-5, knewstuff-5, kparts-5, kservice-5, kwidgetsaddons-5, and kxmlgui-5. [native-inputs]: Remove kdoctools; add kdoctools-5. Change-Id: Ibcac770635ae87b8d0b41ac73828a47a5b1d41a9 Zheng Junjie 2024-07-18gnu: isoimagewriter: Update to 24.05.2....* gnu/packages/kde-utils.scm (isoimagewriter): Update to 24.05.2. Change-Id: I56a0a16d242786b7077e0154ec8afd0a89818722 Zheng Junjie 2024-07-18gnu: ark: Update to 24.05.2....* gnu/packages/kde-utils.scm (ark): Update to 24.05.2. [inputs]: Remove khtml and qtbase-5; add kfilemetadata. [arguments]: Set #:qtbase to qtbase; Use Gexps. * gnu/packages/patches/ark-skip-xar-test.patch: Adjust it. Change-Id: I225a2e0c6487001160cb7d81032b6dcd1fef12dd Zheng Junjie 2024-07-18gnu: fielding: Update to 0.1-pre-2.4ee9aea....* gnu/packages/kde-utils.scm (fielding): Update to 0.1-pre-2.4ee9aea. [inputs]: Remove qtdeclarative-5, qtquickcontrols2-5, and qtsvg-5; add kirigami-addons, qtdeclarative, and qtsvg. [arguments]: Set #:qtbase to qtbase. Change-Id: Iaf230a031a3f7b8580724534d7d8c7cec1811782 Zheng Junjie 2024-07-18gnu: Remove print-manager....* gnu/packages/kde-utils.scm (print-manager): Delete variable. Change-Id: I7461992e773e0e32393f666434d9f60432172c02 Zheng Junjie 2024-07-18gnu: kmouth: Update to 24.05.2....* gnu/packages/kde-utils.scm (kmouth): Update to 24.05.2. [arguments]: Set #:qtbase to qtbase. [inputs]: Remove qtbase-5 and qtspeech-5; add qtspeech. Change-Id: Ica7a0d1f5cedcea8d41a9abcb2fbed759abc4ec0 Zheng Junjie 2024-07-18gnu: kmousetool: Update to 24.05.2....* gnu/packages/kde-utils.scm (kmousetool): Update to 24.05.2. [inputs]: Remove qtbase-5; add kstatusnotifieritem and qtmultimedia. [arguments]: Set #:qtbase to qtbase. Change-Id: Ie2b2e5d782d54e31a16fd644cff42d4f0f25911c Zheng Junjie 2024-07-18gnu: kmag: Update to 24.05.2....* gnu/packages/kde-utils.scm (kmag): Update to 24.05.2. [inputs]: Remove qtbase-5; add libqaccessibilityclient. [arguments]: Set #:qtbase to qtbase. Change-Id: I5a97c7015c7a4c9c56cb3fab085f0b33512987b3 Zheng Junjie 2024-07-18gnu: kontrast: Update to 24.05.2....* gnu/packages/kde-utils.scm (kontrast): Update to 24.05.2. [arguments]: Set #:qtbase to qtbase. [inputs]: Remove qtdeclarative-5, qtgraphicaleffects, qtquickcontrols2-5, and qtsvg-5; add qtdeclarative, futuresql, qcoro-qt6, and qtsvg. [native-inputs]: Add python-minimal. Change-Id: I13ea2db2e29ddc2e7427049c15d8ffd73693d1ba Zheng Junjie 2024-07-18gnu: kfind: Update to 24.05.2....* gnu/packages/kde-utils.scm (kfind): Update to 24.05.2. [arguments]: Set #:qtbase to qtbase. [inputs]: Add kxmlgui and qt5compat. Change-Id: I174d27d8882ec700a2ca3e32be4445fe3205c815 Zheng Junjie 2024-07-18gnu: keysmith: Update to 24.05.2....* gnu/packages/kde-utils.scm (keysmith): Update to 24.05.2. [inputs]: Remove qtdeclarative-5, qtgraphicaleffects, qtquickcontrols2-5, and qtsvg-5; add qqc2-desktop-style, qtsvg, and qtdeclarative. [native-inputs]: Add python-minimal. [arguments]: Set #:qtbase to qtbase. Change-Id: I0f83720f980680cb44c4bb5c77360a1d3c582859 Zheng Junjie 2024-07-18gnu: kdialog: Update to 24.05.2....* gnu/packages/kde-utils.scm (kdialog): Update to 24.05.2. [arguments]: Set #:qtbase to qtbase. Change-Id: I3b973e30b25ef64e0e99815dfb4d911afc321eb7 Zheng Junjie 2024-07-18gnu: kcharselect: Update to 24.05.2....* gnu/packages/kde-utils.scm (kcharselect): Update to 24.05.2. [arguments]: Set #:qtbase to qtbase. Change-Id: I4beac555d0adbeafe218547f3d202a50eae98c0d Zheng Junjie 2024-07-18gnu: kcalc: Update to 24.05.2....* gnu/packages/kde-utils.scm (kcalc): Update to 24.05.2. [arguments]: Set #:qtbase to qtbase. Change-Id: Ie081b24a7780ea6fe7b3e9e384244b0c159def8a Zheng Junjie 2024-07-18gnu: kate: Update to 24.05.2....* gnu/packages/kde-utils.scm (kate): Update to 24.05.2. [inputs]: Remove kactivities, plasma-framework, qtbase-5, qtscript, and qtx11extras; add plasma-activities, ktextwidgets, libplasma, and libxkbcommon. [arguments]: Set #:qtbase to qtbase. Change-Id: I2e54e303b6b0b2b4b753ac7c61fd5094f6aaa37a Zheng Junjie 2024-07-18gnu: kbackup: Update to 24.05.2....* gnu/packages/kde-utils.scm (kbackup): Update to 24.05.2. [inputs]: Add kstatusnotifieritem and qt5compat. [arguments]: Set #:qtbase to qtbase. Change-Id: Ieef8488bed9a414ba928990562ebe83616c638a1 Zheng Junjie 2024-07-18gnu: sweeper: Update to 24.05.2....* gnu/packages/kde-utils.scm (sweeper): Update to 24.05.2. [inputs]: Remove kactivities-stats and qtbase-5; add plasma-activities-stats. [arguments]: Set #:qtbase to qtbase. Change-Id: I4d4496b556ce52942be2796395ee7e94acd0524b Zheng Junjie 2024-07-18gnu: kdebugsettings: Update to 24.05.2....* gnu/packages/kde-utils.scm (kdebugsettings): Update to 24.05.2. [arguments]: Set #:qtbase to qtbase. Change-Id: Ia30a0a8a9904a3fd9bba9fe5fc8b0a4d125ae9d1 Zheng Junjie 2024-07-18gnu: filelight: Update to 24.05.2....* gnu/packages/kde-utils.scm (filelight): Update to 24.05.2. [inputs]: Remove qtgraphicaleffects, qtquickcontrols2-5, and qtsvg-5; add kirigami-addons and qtsvg. [arguments]: Set #:qtbase to qtbase. Change-Id: I03fa741b6bac95c29d1bb9cc49b6d13be7df85ce Zheng Junjie