aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages wdiff)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages texinfo)
  #:use-module (gnu packages screen)
  #:use-module (gnu packages base))

(define-public wdiff
  (package
    (name "wdiff")
    (version "1.2.2")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/wdiff/wdiff-"
                          version ".tar.gz"))
      (sha256
       (base32
        "0sxgg0ms5lhi4aqqvz1rj4s77yi9wymfm3l3gbjfd1qchy66kzrl"))))
    (build-system gnu-build-system)
    (arguments
     `(#:phases (modify-phases %standard-phases
                  (add-before 'check 'fix-sh
                    (lambda _
                      (substitute* "tests/testsuite"
                        (("#! /bin/sh")
                         (string-append "#!" (which "sh")))))))))
    (native-inputs
     (list which
           ;; For some reason wdiff.info gets rebuilt.
           texinfo))
    (home-page "https://www.gnu.org/software/wdiff/")
    (synopsis "Word difference finder")
    (description
     "GNU Wdiff is a front-end to the diff program from Diffutils that
allows you to compare files on a word-by-word basis, where a word is anything
between whitespace.")
    (license gpl3+)))
97'>1d8d0f1fd764bffd70e28f81aac96150d41a02ba /gnu/packages/crates-windows.scm parent84a02f7dd6bec370480f617171493be6c14633cf (diff)downloadguix-55d48b8bb88e4f6973e1fa993fc4739edfe64897.tar.gz
guix-55d48b8bb88e4f6973e1fa993fc4739edfe64897.zip
gnu: rust-cipher: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-cipher-0.4, rust-cipher-0.3, rust-cipher-0.2): Move from here ... * gnu/packages/crates-crypto.scm: ... to here. Change-Id: I52d8ae28b64ad7e81eaea349fdd4ffa045928c5c
Diffstat (limited to 'gnu/packages/crates-windows.scm')
-rw-r--r--gnu/packages/crates-windows.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/crates-windows.scm b/gnu/packages/crates-windows.scm
index 2131609dff..f03de31fca 100644
--- a/gnu/packages/crates-windows.scm
+++ b/gnu/packages/crates-windows.scm
@@ -37,6 +37,7 @@
#:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (gnu packages)
+ #:use-module (gnu packages crates-crypto)
#:use-module (gnu packages crates-io))
(define-public rust-anstyle-wincon-3