aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages wdiff)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages texinfo)
  #:use-module (gnu packages screen)
  #:use-module (gnu packages base))

(define-public wdiff
  (package
    (name "wdiff")
    (version "1.2.2")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/wdiff/wdiff-"
                          version ".tar.gz"))
      (sha256
       (base32
        "0sxgg0ms5lhi4aqqvz1rj4s77yi9wymfm3l3gbjfd1qchy66kzrl"))))
    (build-system gnu-build-system)
    (arguments
     `(#:phases (modify-phases %standard-phases
                  (add-before 'check 'fix-sh
                    (lambda _
                      (substitute* "tests/testsuite"
                        (("#! /bin/sh")
                         (string-append "#!" (which "sh")))))))))
    (native-inputs
     (list which
           ;; For some reason wdiff.info gets rebuilt.
           texinfo))
    (home-page "https://www.gnu.org/software/wdiff/")
    (synopsis "Word difference finder")
    (description
     "GNU Wdiff is a front-end to the diff program from Diffutils that
allows you to compare files on a word-by-word basis, where a word is anything
between whitespace.")
    (license gpl3+)))
. [security fixes]...This contains a fix for CVE-2024-8508. * gnu/packages/dns.scm (unbound): Update to 1.21.1. Change-Id: I2ed1806a0859c5dbd729d18a074220ab13b53223 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Ashish SHUKLA via Guix-patches via 2024-09-08gnu: ldns: Update to 1.8.4....* gnu/packages/dns.scm (ldns): Update to 1.8.4. * gnu/packages/patches/ldns-drill-examples.patch: Adjust diff. Change-Id: I52480085d45890b73278b2b529764482c591c9ac Tobias Geerinckx-Rice 2024-09-17gnu: smartdns: Update to 46....* gnu/packages/dns.scm (smartdns): Update to 46. Change-Id: I4d1472d3ec027d89a550bf5cada74019074bb049 Signed-off-by: Ludovic Courtès <ludo@gnu.org> Hilton Chain 2024-08-31gnu: dns: Add 'bash' input for 'wrap-program'....It is required for cross-compilation. * gnu/packages/dns.scm (knot-resolver)[inputs]: Add 'bash-minimal'. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: Ib39ca58fe52346bb083e0aa7a0d00059b5bc946d Maxime Devos 2024-08-18gnu: knot-resolver: Update to 5.7.4....* gnu/packages/dns.scm (knot-resolver): Update to 5.7.4. Change-Id: I1902c3ced083c5cbb360aa65517cde339b5e0893 Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Ashish SHUKLA 2024-08-18gnu: knot: Update to 3.3.8...* gnu/packages/dns.scm (knot): Update to 3.3.8. Change-Id: Ia9c2a07c852af13383dfb1d37ae1350a25bae533 Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Ashish SHUKLA 2024-08-17gnu: unbound: Fix cross-compilation....* gnu/packages/dns.scm (unbound)[native-inputs]: Add python-wrapper. Change-Id: I98f5e11dad2d89a4f25fca8e0935134b39e779e3 Zheng Junjie 2024-08-17gnu: unbound: Update to 1.21.0....* gnu/packages/dns.scm (unbound): Update to 1.21.0. Change-Id: Ie398f85371aeaa673034d3c1545f31d2c9305f92 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Ashish SHUKLA 2024-06-24gnu: openresolv: Update to 3.13.2....* gnu/packages/dns.scm (openresolv): Update to 3.13.2. * gnu/packages/patches/openresolv-restartcmd-guix.patch: Adjust. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Sergey Trofimov 2024-06-24gnu: isc-bind: Update to 9.19.24....* gnu/packages/dns.scm (isc-bind): Update to 9.19.24. Change-Id: I0fc1128191dbda349ac27a9d1b7bf67b59caac39 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Wilko Meyer 2024-06-02gnu: knot: Remove input labels....* gnu/packages/dns.scm (knot)[inputs]: Remove labels. Change-Id: I03be6db350b939f8a17c8a2e572dda62b16b48af Ludovic Courtès 2024-06-02gnu: knot: Build against libbpf 0.8....Commit 12d2a6e5a6f412d91ba0c34a1c3c080c6c587cc6 introduced a regression whereby ./configure would error out for lack of libxdp. * gnu/packages/dns.scm (knot)[inputs]: Replace LIBBPF with LIBBPF-0.8. Change-Id: Ifeeacc27705d4d617ee0c58672f22d5f9de06389 Ludovic Courtès 2024-03-17gnu: smartdns: Update to 45....* gnu/packages/dns.scm (smartdns): Update to 45. [arguments]<#:make-flags>: Obtain version with ‘package-version’. [native-inputs]: Add which. Change-Id: I1b572753cba53f6e8f8105541c1292e03dec9053 Hilton Chain 2024-02-28gnu: bind: Update to 9.19.21 [security fixes]....The current release fixes CVE-2023-50387 and other security issues. Previous releases fix many other security issues. * gnu/packages/dns.scm (bind): Update to 9.19.21. [source]: Remove 'patches' field. * gnu/packages/patches/bind-re-add-attr-constructor-priority.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove it. Reported-by: Felix Lechner <felix.lechner@lease-up.com> Change-Id: I2415de88f16d9c952a1adcee5219980a3a19bb59 John Kehayias 2024-02-28gnu: knot-resolver: Update to 5.7.1 [security fixes]....Fixes CVE-2023-50868 and CVE-2023-50387 as well as other security issues. * gnu/packages/dns.scm (knot-resolver): Update to 5.7.1. Change-Id: I8d3b084d6ff356593651ff4864edc7cffadcf442 Reported-by: Felix Lechner <felix.lechner@lease-up.com> Change-Id: I2b2304aaf96582bca81d3f20a5d5a60c3daff68d John Kehayias 2024-02-28gnu: knot: Update to 3.3.4....* gnu/packages/dns.scm (knot): Update to 3.3.4. Change-Id: I5ea3bdd8060da8c32c404473197e02bcb3018d7b John Kehayias 2024-02-28gnu: unbound: Update to 1.19.1 [security fixes]....Fixes CVE-2023-50387 and CVE-2023-50868 * gnu/packages/dns.scm (unbound): Update to 1.19.1. Change-Id: I25f87ce60c87d1ed9dfbb41983039440fb396191 Reported-by: Felix Lechner <felix.lechner@lease-up.com> Change-Id: If6bb9b782d775dfacbc6d4c6dedc3e6cfeb2b6b3 John Kehayias 2024-02-28gnu: dnsmasq: Update to 2.90 [security fixes]....Fixes CVE 2023-50387 and CVE 2023-50868. * gnu/packages/dns.scm (dnsmasq): Update to 2.90. Change-Id: Id814dd2a562fe3c90673b98f7e0d6f3571988a90 Reported-by: Felix Lechner <felix.lechner@lease-up.com> Change-Id: I191a62d62f202c65d7063eed0368affc115d82ca John Kehayias