aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2020, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2022 Denis Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2023 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages valgrind)
  #:use-module (srfi srfi-1)
  #:use-module (guix build-system gnu)
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix utils)
  #:use-module (gnu packages)
  #:use-module (gnu packages base)
  #:use-module (gnu packages gdb)
  #:use-module (gnu packages perl))

(define-public valgrind
  (package
    (name "valgrind")
    (version "3.22.0")
    (source (origin
              (method url-fetch)
              (uri (list (string-append "https://sourceware.org/pub/valgrind"
                                        "/valgrind-" version ".tar.bz2")
                         (string-append "ftp://sourceware.org/pub/valgrind"
                                        "/valgrind-" version ".tar.bz2")))
              (sha256
               (base32
                "0k1ddnzxfpbng2sp5r31jjxsmp35g977rx6a8jcp4prcvmddn4f8"))))
    (build-system gnu-build-system)
    (outputs '("doc"                              ;16 MB
               "out"))
    (arguments
     `(,@(if (string-prefix? "powerpc" (or (%current-target-system)
                                           (%current-system)))
           `(#:make-flags '("CFLAGS+=-maltivec"))
           '())
       #:phases
       (modify-phases %standard-phases
         (add-after 'install 'patch-suppression-files
           (lambda* (#:key outputs #:allow-other-keys)
             ;; Don't assume the FHS.
             (let* ((out (assoc-ref outputs "out"))
                    (dir (string-append out "/lib/valgrind")))
               (substitute* (find-files dir "\\.supp$")
                 (("obj:/lib") "obj:*/lib")
                 (("obj:/usr/X11R6/lib") "obj:*/lib")
                 (("obj:/usr/lib") "obj:*/lib")))))
         (add-after 'install 'install-doc
           (lambda* (#:key outputs #:allow-other-keys)
             (let ((orig (format #f "~a/share/doc" (assoc-ref outputs "out")))
                   (dest (format #f "~a/share" (assoc-ref outputs "doc"))))
               (mkdir-p dest)
               (rename-file orig dest)))))))
    (native-inputs
     (list perl))
    (home-page "https://www.valgrind.org/")
    (synopsis "Debugging and profiling tool suite")
    (description
     "Valgrind is an instrumentation framework for building dynamic analysis
tools.  There are Valgrind tools that can automatically detect many memory
management and threading bugs, and profile your programs in detail.  You can
also use Valgrind to build new tools.")
    ;; https://valgrind.org/info/platforms.html
    (supported-systems (fold delete %supported-systems
                             '("i586-gnu" "armhf-linux" "riscv64-linux")))
    (license gpl2+)

    ;; Hide this variant so end users get the "interactive" Valgrind below.
    (properties '((hidden? . #t)))))

(define-public valgrind/interactive
  (package/inherit
   valgrind
   (inputs
    ;; GDB is needed to provide a sane default for `--db-command'.
    (list gdb `(,(canonical-package (libc-for-target)) "debug")))
   (properties '())))
'>...Tobias Geerinckx-Rice 2020-09-29gnu: escpr: Update to 1.7.7....Tobias Geerinckx-Rice 2020-09-29gnu: escpr: Install PPDs where CUPS can find them....Tobias Geerinckx-Rice 2020-07-04gnu: hplip: Update source hash....Tobias Geerinckx-Rice 2020-06-17gnu: foo2zjs: Update to 20200610....Tobias Geerinckx-Rice 2020-06-17gnu: hplip: Update to 3.20.6....Tobias Geerinckx-Rice 2020-06-06Merge branch 'master' into stagingMarius Bakke 2020-06-02gnu: hplip: Update to 3.20.5....Tobias Geerinckx-Rice 2020-05-26Merge branch 'master' into stagingMarius Bakke 2020-05-26gnu: CUPS: Update to 2.3.3....Marius Bakke 2020-05-26gnu: cups-filters: Update to 1.27.4....Marius Bakke 2020-05-18gnu: CUPS: Inherit replacement from cups-minimal....Marius Bakke 2020-05-17gnu: cups: Update to 2.3.3 [fixes CVE-2020-3898 & CVE-2019-8842]....Tobias Geerinckx-Rice 2020-05-04gnu: hplip: Fix build with Python 3.8....Marius Bakke 2020-04-30Merge branch 'master' into core-updates...Marius Bakke 2020-04-29gnu: foo2zjs: Update to 20200426....Tobias Geerinckx-Rice 2020-03-14Merge branch 'master' into core-updatesMarius Bakke 2020-03-11Merge branch 'master' into stagingMarius Bakke 2020-03-10gnu: hplip: Update to 3.20.3....Tobias Geerinckx-Rice 2020-03-10gnu: hplip: Update source hash....Tobias Geerinckx-Rice 2020-03-10Merge branch 'master' into core-updatesMarius Bakke 2020-03-09Merge branch 'master' into stagingMarius Bakke 2020-03-07gnu: hplip: Update to 3.20.2....Tobias Geerinckx-Rice 2020-02-24gnu: cups-filters: Update to 1.27.1....Marius Bakke 2020-02-14Merge branch 'master' into core-updatesMarius Bakke 2020-02-14gnu: cups-filters: Update to 1.27.0....Marius Bakke 2020-02-13gnu: foo2zjs: Update to 20200207....Tobias Geerinckx-Rice 2020-01-22gnu: Replace uses of 'libjpeg' with 'libjpeg-turbo'....Marius Bakke 2020-01-19gnu: cups-filters: Update to 1.26.2....Marius Bakke 2020-01-19gnu: cups: Update to 2.3.1....Marius Bakke 2020-01-10gnu: hplip: Fix scanner model detection....Danny Milosavljevic