aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages uucp)
  #:use-module (gnu packages golang)
  #:use-module (gnu packages golang-build)
  #:use-module (gnu packages golang-compression)
  #:use-module (gnu packages golang-crypto)
  #:use-module (gnu packages golang-web)
  #:use-module (gnu packages golang-xyz)
  #:use-module (gnu packages texinfo)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix build-system go))

(define-public uucp
  (package
    (name "uucp")
    (version "1.07")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/uucp/uucp-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "0b5nhl9vvif1w3wdipjsk8ckw49jj1w85xw1mmqi3zbcpazia306"))))
    (build-system gnu-build-system)
    (arguments
     '(#:phases
       (modify-phases %standard-phases
         (replace 'configure
           (lambda* (#:key outputs #:allow-other-keys)
             ;; The old 'configure' script doesn't support the arguments
             ;; that we pass by default.
             (setenv "CONFIG_SHELL" (which "sh"))
             (let ((out (assoc-ref outputs "out")))
               (invoke "./configure"
                       (string-append "--prefix=" out)
                       (string-append "--infodir=" out
                                      "/share/info"))))))))
    (home-page "https://www.gnu.org/software/uucp/uucp.html")
    (synopsis "UUCP protocol implementation")
    (description
     "Taylor UUCP is the GNU implementation of UUCP (Unix-to-Unix Copy), a
set of utilities for remotely transferring files, email and net news
between computers.")
    (license gpl2+)))

(define-public nncp
  (package
    (name "nncp")
    (version "7.5.0")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "http://www.nncpgo.org/download/nncp-"
                           version ".tar.xz"))
       (sha256
        (base32
         "1r1zgj7gpkdmdm3wf31m0xi8y313kzd4dbyp4r4y8khnp32jvn8l"))
       (modules '((ice-9 ftw)
                  (guix build utils)))
       (snippet
        '(begin
           ;; Unbundle dependencies.
           ;; TODO: go.cypherpunks.ru was down at the time of
           ;; packaging. Unbundle go.cypherpunks dependencies as well once it
           ;; comes back online.
           (for-each (lambda (file)
                       (unless (member file (list "." ".." "go.cypherpunks.ru"))
                         (delete-file-recursively (string-append "src/vendor/" file))))
                     (scandir "src/vendor"))
           ;; Delete built documentation.
           (delete-file "doc/nncp.info")
           #t))))
    (build-system gnu-build-system)
    (arguments
     `(#:modules ((guix build gnu-build-system)
                  ((guix build go-build-system) #:prefix go:)
                  (guix build utils))
       #:imported-modules ,%go-build-system-modules
       #:phases
       (modify-phases %standard-phases
         (add-before 'unpack 'setup-go-environment
           (assoc-ref go:%standard-phases 'setup-go-environment))
         (add-after 'unpack 'go-unpack
           (lambda* (#:key source #:allow-other-keys)
             ;; Copy source to GOPATH.
             (copy-recursively "src" "../src/go.cypherpunks.ru/nncp/v7")
             ;; Move bundled dependencies to GOPATH.
             (for-each (lambda (dependency)
                         (rename-file (string-append "src/vendor/go.cypherpunks.ru/"
                                                     dependency)
                                      (string-append "../src/go.cypherpunks.ru/"
                                                     dependency)))
                       (list "balloon" "recfile"))
             ;; Delete empty bundled dependencies directory.
             (delete-file-recursively "src/vendor")))
         (replace 'configure
           (lambda* (#:key outputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out")))
               (setenv "GO_LDFLAGS" "-trimpath")
               ;; Set configuration path.
               (setenv "CFGPATH" "/etc/nncp.hjson")
               ;; Set output directories.
               (setenv "BINDIR" (string-append out "/bin"))
               (setenv "INFODIR" (string-append out "/share/info"))
               (setenv "DOCDIR" (string-append out "/share/doc/nncp")))
             ;; Set absolute store paths to sh and cat.
             (substitute* (list "src/pipe.go" "src/toss_test.go")
               (("/bin/sh") (which "sh")))
             (substitute* "src/toss_test.go"
               (("; cat") (string-append "; " (which "cat"))))
             ;; Remove module flags.
             (substitute* (list "bin/default.do" "bin/hjson-cli.do" "test.do")
               ((" -mod=vendor") "")
               ((" -m") ""))
             ;; Use the correct module path. `go list` does not report the
             ;; correct module path since we have moved the source files.
             (substitute* "bin/default.do"
               (("^mod=[^\n]*" all) "mod=go.cypherpunks.ru/nncp/v7"))
             ;; Disable timeout in tests. Tests can take longer than the
             ;; default timeout on spinning disks.
             (substitute* "test.do"
               (("test") "test -timeout 0"))))
         (replace 'check
           (lambda* (#:key tests? #:allow-other-keys)
             (when tests?
               (invoke "contrib/do" "-c" "test")))))))
    (inputs
     (list go-github-com-davecgh-go-xdr
           go-github-com-dustin-go-humanize
           go-github-com-flynn-noise
           go-github-com-gorhill-cronexpr
           go-github-com-hjson-hjson-go-v4
           go-github-com-klauspost-compress
           go-golang-org-x-crypto
           go-golang-org-x-net
           go-golang-org-x-term
           go-lukechampine-com-blake3))
    (native-inputs
     (list go texinfo))
    (home-page "http://www.nncpgo.org/")
    (synopsis "Store and forward utilities")
    (description "NNCP (Node to Node copy) is a collection of utilities
simplifying secure store-and-forward files, mail and command exchanging.
These utilities are intended to help build up small size (dozens of nodes)
ad-hoc friend-to-friend (F2F) statically routed darknet delay-tolerant
networks for fire-and-forget secure reliable files, file requests, Internet
mail and commands transmission.  All packets are integrity checked, end-to-end
encrypted, explicitly authenticated by known participants public keys.  Onion
encryption is applied to relayed packets.  Each node acts both as a client and
server, can use push and poll behaviour model.  Multicasting areas, offline
sneakernet/floppynet, dead drops, sequential and append-only CD-ROM/tape
storages, air-gapped computers and online TCP daemon with full-duplex
resumable data transmission exists are all supported.")
    (license gpl3)))
tle='2024-06-12 00:08:57 +0200'>2024-06-12gnu: godot: Update to 4.2.2....* gnu/packages/game-development.scm (godot): Update to 4.2.2. Change-Id: I4450c41439435d18b1e1fb727b9d42c683455831 Signed-off-by: Ludovic Courtès <ludo@gnu.org> Adriel Dumas--Jondeau 2024-06-11gnu: surgescript: Update to 0.6.0....* gnu/packages/game-development.scm (surgescript): Update to 0.6.0. Change-Id: Ie976d33f3f2df4ac5c37476fcd9675c122a5783a Signed-off-by: Christopher Baines <mail@cbaines.net> 宋文武 2024-05-15gnu: slade: Update to 3.2.5a....* gnu/packages/game-development.scm (slade): Update to 3.2.5a. [arguments]: Add a configure-flag to build slade.pk3. Change-Id: I739f9d292a685e86acd4d83c1a5de367f884c523 Efraim Flashner 2024-05-14gnu: renpy: Update to 8.3.0....* gnu/packages/game-development.scm (python-renpy): Update to 8.3.0. Liliana Marie Prikler 2024-05-14gnu: python-pygame-sdl2: Update to 2.1.0+renpy8.3.0....* gnu/packages/game-development.scm (python-pygame-sdl2): Update to 2.1.0+renpy8.3.0. Liliana Marie Prikler 2024-04-09Merge remote-tracking branch 'savannah/master' into mesa-updates...Change-Id: Iad185e2ced97067b3dff8fd722435a6c5e2c00e5 Christopher Baines 2024-04-06gnu: chipmunk: Update to 7.0.3-1.d0239ef....* gnu/packages/game-development.scm (chipmunk): Update to 7.0.3-1.d0239ef. [source]<snippet>: Remove fix included upstream. Change-Id: Iac849fffc1d9cf3528a4197ddf741d588fc866a5 Nicolas Goaziou 2024-04-06gnu: ode: Update to 0.16.5....* gnu/packages/game-development.scm (ode): Update to 0.16.5. Change-Id: I902c05582c2211d2f620970e74af00ba2f9be19c Nicolas Goaziou 2024-04-03gnu: godot: Update to 4.2.1....The previous version failed to build after an update to glslang. Godot looks for an include, Types.h, which is no longer included in the built glslang. Use the included glslang (which will match the included vulkan, too) for now. * gnu/packages/game-development.scm (godot): Update to 4.2.1. [source]: In snippet add (preserve) amd-fsr2, clipper2, glslang (for now), and libktx. [arguments]: Comment out "builtin_glslang=no" in #:scons-flags (for now). Change-Id: I8f6c20e3796ea96f2e6a6a167063f10a667bd4c3 John Kehayias 2024-02-25gnu: renpy: Update to 8.2.0....* gnu/packages/aux-files/renpy/renpy.in (path-to-saves): Honour RENPY_PATH_TO_SAVES. (path_to_logdir, predefined_searchpath): New procedures. * gnu/packages/game-development.scm (python-renpy): Update to 8.2.0. Liliana Marie Prikler 2024-02-25gnu: python-pygame-sdl2: Update to 2.1.0+renpy8.2.0....* gnu/packages/game-development.scm (python-pygame-sdl2): Update to 2.1.0+renpy8.2.0. Liliana Marie Prikler 2024-02-20gnu: python-pygame: Update to 2.5.2....* gnu/packages/game-development.scm (python-pygame): Update to 2.5.2. Change-Id: I8fc18627b16ff7e7aeeb84fdb2fdb82593e6ddb7 Ricardo Wurmus 2024-02-19gnu: Add python-pybox2d....* gnu/packages/game-development.scm (python-pybox2d): New variable. Change-Id: I1468a1f8cf5ce6170d643447001057eec02500fc Ricardo Wurmus 2024-02-08Revert update to Renpy 8.2....This reverts commits 9d53c236a69786508197c75d42923e8891c9212d, 2bfe8e95ef7d83961b80b6bacedd2c8c84e056bc, and 08ed3ec64ecd571d92d497b2493f5c0225102c99 as a temporary fix to <https://bugs.gnu.org/68982>. Liliana Marie Prikler 2024-02-05gnu: mbedtls-apache: Rename to mbedtls-lts....* gnu/packages/tls.scm (mbedtls-apache): Rename package to "mbedtls". Rename variable to… (mbedtls-lts): …this. (mbedtls-apache): Define as deprecated by mbedtls-lts. (mbedtls-for-hiawatha): Adjust accordingly. * doc/guix.texi: Likewise. * gnu/packages/emulators.scm (dolphin-emu,retroarch)[inputs]: Likewise. * gnu/packages/game-development.scm (godot-lts,godot)[inputs]: Likewise. * gnu/packages/hardware.scm (hueplusplus,openrgb)[inputs]: Likewise. * gnu/packages/haxe.scm (neko,haxe,hashlink)[inputs]: Likewise. * gnu/packages/irc.scm (inspircd)[inputs]: Likewise. * gnu/packages/julia-jll.scm (julia-mbedtls-jll)[arguments]<#:phases>,[inputs]: Likewise. * gnu/packages/julia.scm (julia)[arguments]<#:phases>,[inputs]: Likewise. * gnu/packages/linphone.scm (bctoolbox)[inputs]: Likewise. * gnu/packages/linux.scm (dislocker)[inputs]: Likewise. * gnu/packages/networking.scm (nng)[inputs]: Likewise. * gnu/packages/search.scm (dataparksearch)[inputs]: Likewise. * gnu/packages/video.scm (obs)[inputs]: Likewise. * gnu/packages/web.scm (hiawatha)[arguments]<#:phases>: Likewise. Change-Id: I0c58b3cd0bcf6e44e7b16a69f6d2739aa3c1545b Hilton Chain 2024-02-03gnu: raylib: Update to 5.0....* gnu/packages/game-development.scm (raylib): Update to 5.0. Change-Id: If3797a5f88bdd7f72d47f7f83556e16b319a38f9 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Juliana Sims 2024-01-28gnu: renpy: Fix hashes....* gnu/packages/game-development.scm (python-pygame-sdl2, python-renpy): Redownload sources from upstream and use the provided hashes. Fixes: Broken hashes for Ren'py <https://bugs.gnu.org/68644#20> Liliana Marie Prikler 2024-01-28gnu: python-renpy: Update to 8.2.0....* gnu/packages/game-development.scm (python-renpy): Update to 8.2.0. Liliana Marie Prikler 2024-01-28gnu: python-pygame-sdl2: Update to 2.1.0+renpy8.2.0....* gnu/packages/game-development.scm (python-pygame-sdl2): Update to 2.1.0+renpy8.2.0. Liliana Marie Prikler 2024-01-07gnu: dds: Update to 2.9.0-1.d2bc4c2....* gnu/packages/game-development.scm (dds): Update to 2.9.0-1.d2bc4c2. Change-Id: I3c6db4e81d70112f020f2d7a0f7db26069c7591f Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Nicolas Goaziou 2024-01-07gnu: bbcsdl: Update to 1.39a....* gnu/packages/game-development.scm (bbcsdl): Update to 1.39a. [arguments]: Replace bundled "DejaVuSans-Oblique.ttf" with symlink in the 'install' phase. Change-Id: I7b7c8ec8a8216812e1c7a1fab74695b14f4d3ca2 宋文武 2023-12-31gnu: Add informlib....* gnu/packages/game-development.scm (informlib): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Adam Faiz 2023-12-31gnu: Add inform....* gnu/packages/game-development.scm (inform): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Adam Faiz 2023-12-17gnu: python-renpy: Update to 8.1.3....* gnu/packages/game-development.scm (python-renpy): Update to 8.1.3. Change-Id: I5e265cdc0f83eda9ae19a3627fa8cd69ef103806 Liliana Marie Prikler 2023-12-17gnu: python-pygame-sdl2: Update to 2.1.0+renpy8.1.3....* gnu/packages/game-development.scm (python-pygame-sdl2): Update to 2.1.0+renpy8.1.3. Change-Id: Ide0baef4762b2c4174d10e07ec94427916ac41af Liliana Marie Prikler 2023-12-10gnu: openmw: Update to 0.48.0....* gnu/packages/game-development.scm (openmw): Update to 0.48.0. * gnu/packages/graphics.scm (openmw-openscenegraph): Update to commit 68c5c5. Change-Id: I5e1ae0d59ead8de7976714cb82e8d514c308f19a Signed-off-by: Ludovic Courtès <ludo@gnu.org> Rodion Goritskov 2023-11-23gnu: godot: Update to 4.1.3....* gnu/packages/game-development.scm (godot): Update to 4.1.3. Change-Id: Ia8844da04b568e32e9138b222ddfdca7868b010f Signed-off-by: Christopher Baines <mail@cbaines.net> Adriel Dumas--Jondeau 2023-10-28gnu: godot: Update to 4.1.2....* gnu/packages/game-development.scm (godot): Update to 4.1.2. Change-Id: I358305245305c2cf31e40ce1d33f28c97c224b52 John Kehayias