aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016–2018, 2020–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2019 Jens Mølgaard <jens@zete.tk>
;;; Copyright © 2020 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2023, 2024 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages upnp)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages base)
  #:use-module (gnu packages check)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages curl)
  #:use-module (gnu packages file)
  #:use-module (gnu packages gettext)
  #:use-module (gnu packages image)
  #:use-module (gnu packages javascript)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages logging)
  #:use-module (gnu packages mp3)
  #:use-module (gnu packages photo)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages pretty-print)
  #:use-module (gnu packages python)
  #:use-module (gnu packages sqlite)
  #:use-module (gnu packages video)
  #:use-module (gnu packages xiph)
  #:use-module (gnu packages xml)
  #:use-module (guix build-system cmake)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (guix utils)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (ice-9 match))

(define-public miniupnpc
  (package
    (name "miniupnpc")
    (version "2.1.20191224")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://miniupnp.tuxfamily.org/files/"
                           "miniupnpc-" version ".tar.gz"))
       (sha256
        (base32 "1kv6dpj93gckvwvgzxl4vdqpwnicb0c8p0xw53m2gh5naiw44ys4"))))
    (build-system gnu-build-system)
    (native-inputs
     `(("python" ,python-2)))
    (arguments
     ;; The build system does not use a configure script but depends on
     ;; `make'.  Hence we should pass parameters to `make' instead and remove
     ;; the configure phase.
     `(#:make-flags
       (list
        (string-append "SH=" (search-input-file %build-inputs "/bin/sh"))
        (string-append "INSTALLPREFIX=" (assoc-ref %outputs "out"))
        ,(string-append "CC=" (cc-for-target))

        ;; Allow executables to find libminiupnpc.so.
        (string-append "LDFLAGS=-Wl,-rpath="
                       (assoc-ref %outputs "out") "/lib"))
       #:phases
       (modify-phases %standard-phases
         (delete 'configure)
         (add-before 'install 'qualify-paths
           (lambda* (#:key outputs #:allow-other-keys)
             (substitute* "external-ip.sh"
               (("upnpc")
                (string-append (assoc-ref outputs "out") "/bin/upnpc")))
             #t)))))
    (home-page "http://miniupnp.free.fr/")
    (synopsis "UPnP protocol client library")
    (description
     "The MiniUPnPc client library facilitates access to the services provided
by any @dfn{Universal Plug and Play} (UPnP) @dfn{Internet Gateway Device} (IGD)
present on the network.  In UPnP terminology, MiniUPnPc is a UPnP Control Point.

It is useful whenever an application needs to listen for incoming connections
while running behind a UPnP-enabled router or firewall.  Such applications
include peer-to-peer applications, active-mode FTP clients, DCC file transfers
over IRC, instant messaging, network games, and most server software.")
    (license
     (license:x11-style "file://LICENSE" "See 'LICENSE' file in the distribution"))))

(define-public libupnp
  (package
    (name "libupnp")
    (version "1.14.18")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "https://github.com/pupnp/pupnp/releases/download"
                          "/release-" version "/libupnp-" version".tar.bz2"))
      (sha256
       (base32 "1sywi1l0sc9s55hryfwqb5y5fhyyqx6ida5i7bk8m1p27klwx9qn"))))
    (native-inputs
     (list pkg-config))
    (build-system gnu-build-system)
    (arguments
     ;; The tests require a network device capable of multicasting which is
     ;; not available in the build environment. See
     ;; https://lists.gnu.org/archive/html/guix-devel/2015-01/msg00312.html.
     `(#:tests? #f
       #:configure-flags '("--disable-static")))
    (home-page "https://pupnp.sourceforge.net")
    (synopsis "Portable SDK for UPnP Devices")
    (description
     "The portable SDK for UPnP Devices (libupnp) provides developers with an
API and code for building control points, devices, and bridges that are
compliant with Version 1.0 of the Universal Plug and Play Device Architecture
Specification and support several operating systems like Linux, *BSD, Solaris
and others.")
    (license license:bsd-3)))

(define-public readymedia
  (package
    (name "readymedia")
    (version "1.3.3")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://git.code.sf.net/p/minidlna/git")
             (commit (string-append
                      "v" (string-replace-substring version "." "_")))))
       (file-name (git-file-name name version))
       (sha256
        (base32 "1al04jx72bxwqch1nv9lx536mb6pvj7pgnqzy6lm32q6xa114yr2"))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags '("--with-os-name=Linux" ; uname -s
                           "--with-os-version=") ; uname -r
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'patch-source
           (lambda* (#:key inputs #:allow-other-keys)
             (substitute* "Makefile.am"
               ((".*LIBAVUTIL_LIBS.*") ""))
             (substitute* "minidlna.c"
               (("rm -rf")
                (string-append
                 (search-input-file inputs "/bin/rm") " -rf"))))))))
    (native-inputs (list autoconf automake gettext-minimal))
    (inputs
     (list coreutils-minimal
           ffmpeg
           flac
           libexif
           libid3tag
           libjpeg-turbo
           libvorbis
           sqlite
           zlib))
    (home-page "https://sourceforge.net/projects/minidlna/")
    (synopsis "DLNA/UPnP-AV media server")
    (description "ReadyMedia (formerly known as MiniDLNA) is a simple media
server, which serves multimedia content to compatible clients on the network.
It aims to be fully compliant with DLNA and UPnP-AV standards.")
    (license license:gpl2)))

(define-public gerbera
  (package
    (name "gerbera")
    (version "2.2.0")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/gerbera/gerbera")
             (commit (string-append "v" version))))
       (file-name (git-file-name name version))
       (sha256
        (base32 "1pqqjwza9fs59n2x685yvfb0sdwigknfxc4ihh3phpqyg99427kk"))))
    (build-system cmake-build-system)
    (arguments
     (list
      #:configure-flags
      #~(list "-DWITH_SYSTEMD=NO"
              "-DWITH_AVCODEC=YES"
              "-DWITH_TESTS=YES")))
    (inputs
     (list curl
           duktape
           exiv2
           ffmpeg
           file
           fmt
           libebml
           libexif
           libmatroska
           libupnp
           pugixml
           spdlog
           sqlite
           taglib
           `(,util-linux "lib")
           zlib))
    (native-inputs
     (list googletest pkg-config))
    (home-page "https://gerbera.io/")
    (synopsis "UPnP media server")
    (description "Gerbera is a UPnP media server which allows you to stream
your digital media through your home network and consume it on a variety of
UPnP compatible devices.")
    (license license:gpl2)))
7df6f27c88258c5d3b78720a07fe60ef'>Merge branch 'master' into stagingMarius Bakke 2020-02-15gnu: le-certs: Update input hashes....These unversioned files were modified upstream. The result of $ openssl x509 -in <FILE> -text for each old/new pair remains the same, however. * gnu/packages/certs.scm (le-certs)[inputs]: Update hash for isrgrootx1.pem, letsencryptauthorityx3.pem, and letsencryptauthorityx4.pem. Tobias Geerinckx-Rice 2020-02-14gnu: nss, nss-certs: Update to 3.50....* gnu/packages/nss.scm (nss): Update to 3.50. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2020-01-19gnu: nss, nss-certs: Update to 3.49.1....* gnu/packages/certs.scm (nss-certs): Update to 3.49.1. * gnu/packages/nss.scm (nss): Likewise. Marius Bakke 2020-01-12gnu: nss, nss-certs: Update to 3.49....* gnu/packages/certs.scm (nss-certs): Update to 3.49. * gnu/packages/nss.scm (nss): Likewise. Marius Bakke 2019-10-08gnu: nss, nss-certs: Update to 3.46.1....* gnu/packages/nss.scm (nss): Update to 3.46.1. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2019-08-04gnu: nss, nss-certs: Update to 3.45....* gnu/packages/certs.scm (nss-certs): Update to 3.45. * gnu/packages/nss.scm (nss): Likewise. Marius Bakke 2019-06-29gnu: nss, nss-certs: Update to 3.44.1....* gnu/packages/certs.scm (nss-certs): Update to 3.44.1. * gnu/packages/nss.scm (nss): Likewise. Marius Bakke 2019-05-24gnu: nss, nss-certs: Update to 3.44....* gnu/packages/nss.scm (nss): Update to 3.44. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2019-05-02gnu: le-certs: Update hashes....They added the 3 missing '^M' to all pem certs. * gnu/packages/certs.scm (le-certs)[inputs]: Update the hashes of isrgrootx1.pem, letsencryptauthorityx3.pem, letsencryptauthorityx4.pem. 宋文武 2019-03-21gnu: nss, nss-certs: Update to 3.43....* gnu/packages/gnuzilla.scm (nss): Update to 3.43. * gnu/packages/certs.scm (nss-certs): Ditto. Marius Bakke 2019-02-10gnu: nss, nss-certs: Update to 3.42.1....* gnu/packages/certs.scm (nss-certs): Update to 3.42.1. * gnu/packages/gnuzilla.scm (nss): Likewise. Marius Bakke 2018-12-12gnu: nss, nss-certs: Update to 3.41....* gnu/packages/certs.scm (nss-certs): Update to 3.41. * gnu/packages/gnuzilla.scm (nss): Likewise. Marius Bakke 2018-12-08gnu: nss, nss-certs: Update to 3.40.1....* gnu/packages/certs.scm (nss-certs): Update to 3.40.1. * gnu/packages/gnuzilla.scm (nss): Likewise. [arguments]: Adjust DOMSUF variable to upstream changes. Marius Bakke 2018-09-01gnu: nss, nss-certs: Update to 3.39 [fixes CVE-2018-12384]....* gnu/packages/gnuzilla.scm (nss): Update to 3.39. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2018-06-26gnu: nss, nss-certs: Update to 3.38 [fixes CVE-2018-0495]....* gnu/packages/certs.scm (nss-certs): Update to 3.38. * gnu/packages/gnuzilla.scm (nss): Likewise. Marius Bakke 2018-06-19gnu: nss, nss-certs: Update to 3.37.3....* gnu/packages/gnuzilla.scm (nss): Update to 3.37. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2018-04-30Merge branch 'master' into core-updatesMark H Weaver 2018-04-15gnu: nss, nss-certs: Update to 3.36.1....* gnu/packages/gnuzilla.scm (nss): Update to 3.36.1. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2018-03-27gnu: Use invoke and return #t from all builders....* gnu/packages/admin.scm, gnu/packages/android.scm, gnu/packages/audio.scm, gnu/packages/avr.scm, gnu/packages/base.scm, gnu/packages/bioinformatics.scm, gnu/packages/certs.scm, gnu/packages/check.scm, gnu/packages/code.scm, gnu/packages/commencement.scm, gnu/packages/dictionaries.scm, gnu/packages/docbook.scm, gnu/packages/emacs.scm, gnu/packages/embedded.scm, gnu/packages/fonts.scm, gnu/packages/games.scm, gnu/packages/gnome.scm, gnu/packages/gnu-doc.scm, gnu/packages/guile.scm, gnu/packages/hurd.scm, gnu/packages/javascript.scm, gnu/packages/libreoffice.scm, gnu/packages/linux.scm, gnu/packages/lisp.scm, gnu/packages/lxde.scm, gnu/packages/mail.scm, gnu/packages/markup.scm, gnu/packages/mate.scm, gnu/packages/pkg-config.scm, gnu/packages/qt.scm, gnu/packages/rust.scm, gnu/packages/scheme.scm, gnu/packages/sdl.scm, gnu/packages/statistics.scm, gnu/packages/syncthing.scm, gnu/packages/tex.scm, gnu/packages/web.scm, gnu/packages/wine.scm, gnu/packages/xfce.scm: In the builders of packages using 'trivial-build-system', use invoke where appropriate, raise exceptions on errors, and otherwise return #t. Mark H Weaver 2018-03-23gnu: le-certs: Use invoke....* gnu/packages/certs.scm (le-certs)[arguments]: Use invoke in the builder. Mark H Weaver 2018-03-23gnu: nss-certs: Use invoke....* gnu/packages/certs.scm (nss-certs)[arguments]: Use invoke to detect errors while running 'certdata2pem.py'. Mark H Weaver 2018-03-12gnu: nss, nss-certs: Update to 3.36....* gnu/packages/gnuzilla.scm (nss): Update to 3.36. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2018-02-20Merge branch 'master' into stagingMarius Bakke 2018-02-20gnu: nss-certs: Update phase style....* gnu/packages/certs.scm (nss-certs)[arguments]: Use MODIFY-PHASES syntax, substitute INVOKE for SYSTEM*, and end phas with #t. Tobias Geerinckx-Rice 2018-01-22gnu: nss-certs: Update to 3.35....* gnu/packages/certs.scm (nss-certs): Update to 3.35. Tobias Geerinckx-Rice 2017-12-02gnu: nss-certs: Update to 3.34.1....* gnu/packages/certs.scm (nss-certs): Update to 3.34.1. Tobias Geerinckx-Rice 2017-11-19gnu: nss, nss-certs: Update to 3.34....* gnu/packages/certs.scm (nss-certs): Update to 3.34. * gnu/packages/gnuzilla.scm (nss): Update to 3.34. Marius Bakke 2017-09-20gnu: nss, nss-certs: Update to 3.33....* gnu/packages/gnuzilla.scm (nss): Update to 3.33. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2017-07-28gnu: le-certs: Create OpenSSL hash symlinks....* gnu/packages/certs.scm (le-certs)[arguments]: Run 'c_rehash' on the result. [native-inputs]: New fields. Ludovic Courtès 2017-07-28gnu: nss, nss-certs: Update to 3.32....This release includes minor code changes and many certificate updates: <https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_3.32_release_notes> * gnu/packages/certs.scm (nss-certs): Update to 3.32. * gnu/packages/gnuzilla.scm (nss): Update to 3.32. [arguments]: Prevent another test file from being installed. * gnu/packages/patches/nss-pkgconfig.patch: Adjust. Marius Bakke