aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages unrtf)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages m4)
  #:use-module (gnu packages base))

(define-public unrtf
  (package
    (name "unrtf")
    (version "0.21.10")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/unrtf/unrtf-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "1bil6z4niydz9gqm2j861dkxmqnpc8m7hvidsjbzz7x63whj17xl"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/unrtf/")
    (synopsis "Convert Rich Text Format documents to other formats")
    (description
     "GNU UnRTF converts text documents from RTF to HTML, LaTeX, or troff.
It supports changes in font characteristics, underlines and strikethroughs,
superscripts and subscripts, and more.")
    (license gpl3+)))
497b8c1493c309bdf4cf709c0cc Vinicius Monego 2024-08-31gnu: opencolorio: Fix cmake file....* gnu/packages/image-processing.scm (opencolorio)[arguments]: Add fix-OpenColorIOConfig phase. Change-Id: I317870801f77dc59bcd07b0d11a750bbbb63b327 Zheng Junjie 2024-08-31gnu: itk-snap: Add 'bash' input for 'wrap-program'....It is required for cross-compilation. * gnu/packages/image-processing.scm (itk-snap)[inputs]: Add 'bash-minimal'. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I700d4819aa240ab8d6dc3722336e8fe91d896d96 Maxime Devos 2024-08-31gnu: metapixel: Rewrite with G-Expressions....* gnu/packages/image-processing.scm (metapixel)[arguments]: Rewrite with G-Expressions. [inputs, native-inputs]: Drop labels. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Bruno Victal 2024-08-31gnu: metapixel: Drop docbook workaround....* gnu/packages/image-processing.scm (metapixel)[arguments]<#:phases>: Drop 'make-local-docbook-xml phase. [native-inputs]: Use docbook-xml-4.2 instead of docbook-xml. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Bruno Victal 2024-08-29gnu: opencv: Update to 4.10.0...* gnu/packages/image-processing.scm (opencv): Update to 4.10.0. Change-Id: I4de85cdaa744386deb8162a689dca23003c150ef Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Andy Tai 2024-07-07gnu: gmic: Update source hash....Fixes: https://issues.guix.gnu.org/71970 * gnu/packages/image-processing.scm (gmic): Update source hash. Change-Id: Id7ad742086139263d5677339f1c7b91de350a3f2 Zheng Junjie 2024-07-05gnu: gmic: Update to 3.4.0....* gnu/packages/image-processing.scm (gmic): Update to 3.4.0. Change-Id: I2c9335a96bb22625012f35b60620b9b9ad435a64 Vinicius Monego 2024-06-27gnu: vtk: Update to 9.3.0....* gnu/packages/image-processing.scm (vtk): Update to 9.3.0. Change-Id: Id31d41e7dc457d1f17c0e8e824c170942d81698c Signed-off-by: Andreas Enge <andreas@enge.fr> Lars Bilke 2024-05-23gnu: dcmtk: Update to 3.6.8. [security-fixes]...This fixes CVE-2022-43272. * gnu/packages/image-processing.scm (dcmtk): Update to 3.6.8. Change-Id: I4e0203219280a2571267f566cdfc8c2a9ea3fd18 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Nicolas Graves via Guix-patches via