aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages unrtf)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages m4)
  #:use-module (gnu packages base))

(define-public unrtf
  (package
    (name "unrtf")
    (version "0.21.10")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/unrtf/unrtf-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "1bil6z4niydz9gqm2j861dkxmqnpc8m7hvidsjbzz7x63whj17xl"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/unrtf/")
    (synopsis "Convert Rich Text Format documents to other formats")
    (description
     "GNU UnRTF converts text documents from RTF to HTML, LaTeX, or troff.
It supports changes in font characteristics, underlines and strikethroughs,
superscripts and subscripts, and more.")
    (license gpl3+)))
class='msg-avail'>...Reza Alizadeh Majd 2022-06-24image: Add support for 32bit UEFI....Denis 'GNUtoo' Carikli 2022-06-06bootloader: grub: Add removable grub-efi bootloader option....Karl Hallsby 2022-01-13bootloader: grub: Fix serial mode....Mathieu Othacehe 2021-12-01gnu: system: Add LUKS2 support for the root file system....Josselin Poiret 2021-08-29Migrate to the new 'targets' field of bootloader-configuration....Maxim Cournoyer 2021-05-29gnu: bootloader: Fix install-allwinner64-u-boot....Vagrant Cascadian 2021-04-10bootloader: grub: Fix typo in docstring....Tobias Geerinckx-Rice 2021-02-08gnu: bootloader: Update install-allwinner64-u-boot....Vagrant Cascadian 2021-02-08gnu: u-boot-puma-rk3399: Switch to using arm-trusted-firmware-rk3399....Vagrant Cascadian 2021-01-17gnu: grub: Use installed unicode font....Stefan 2020-12-21system: Allow separated /boot and encrypted root....Miguel Ángel Arruga Vivas 2020-12-15Revert "gnu: grub: Fix unicode font loading when booting over TFTP."...Ludovic Courtès 2020-12-14gnu: grub: Fix unicode font loading when booting over TFTP....Stefan 2020-11-17bootloader: grub: Skip install-grub-efi when producing a disk image....Maxim Cournoyer 2020-11-01system: Generate grub locale directory for grub.cfg....Miguel Ángel Arruga Vivas 2020-10-30system: Fix dependency for grub.cfg generation....Miguel Ángel Arruga Vivas 2020-10-30system: Fix grub keymap with store in btrfs subvolume....Miguel Ángel Arruga Vivas 2020-10-18system: Use locale information in grub.cfg....Miguel Ángel Arruga Vivas 2020-10-05bootloader: Fix u-boot installation....Mathieu Othacehe 2020-09-27gnu: grub: Support for network boot via TFTP....Stefan 2020-09-14gnu: grub: Support loading files from TFTP if the root filesystem is NFS....Stefan 2020-09-07bootloader: Use "define" instead of "define*" for all records....Stefan 2020-09-06bootloader: Add comment about grub configuration files....Stefan 2020-06-09bootloader: grub: Fix cross-compilation....Mathieu Othacehe 2020-06-09gnu: grub: Support graphical gfxterm on all systems....Stefan 2020-06-08bootloader: grub: Add support for multiboot....Jan (janneke) Nieuwenhuizen 2020-05-29bootloader: grub: Rename the btrfs-subvolume-file-name parameter....Maxim Cournoyer 2020-05-29bootloader: grub: Use inheritance to define grub-minimal-bootloader....Mathieu Othacehe 2020-05-29bootloader: grub: Do not run grub-install when creating a disk-image....Mathieu Othacehe 2020-05-29bootloader: Add 'disk-image-installer'....Mathieu Othacehe 2020-05-20bootloader: grub: Allow booting from a Btrfs subvolume....Maxim Cournoyer 2020-05-19gnu: grub: Allow a PNG image and replace "aspect-ratio" with "resolution"....Stefan 2020-05-16bootloader: grub: Refer to the native 'grub-mklayout' and font file....Ludovic Courtès 2020-04-23Merge branch 'master' into core-updates...Marius Bakke 2020-04-20gnu: Add u-boot-pinebook-pro-rk3399....Vagrant Cascadian 2020-04-08Merge branch 'master' into core-updates...Marius Bakke 2020-04-06system: Allow for comma-separated keyboard layouts....Ludovic Courtès 2020-03-29gnu: bootloader: Add grub-minimal-bootloader....Jan Nieuwenhuizen 2020-03-17bootloader: grub: Refactor eye-candy a bit....Maxim Cournoyer 2020-03-17bootloader: grub: Use the all_video module in graphic mode....Maxim Cournoyer