aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages unrtf)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages m4)
  #:use-module (gnu packages base))

(define-public unrtf
  (package
    (name "unrtf")
    (version "0.21.10")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/unrtf/unrtf-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "1bil6z4niydz9gqm2j861dkxmqnpc8m7hvidsjbzz7x63whj17xl"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/unrtf/")
    (synopsis "Convert Rich Text Format documents to other formats")
    (description
     "GNU UnRTF converts text documents from RTF to HTML, LaTeX, or troff.
It supports changes in font characteristics, underlines and strikethroughs,
superscripts and subscripts, and more.")
    (license gpl3+)))
8f0b20066471274df23400'>nls: Update 'fr' translation.Julien Lepiller 2018-06-23nls: Update 'fr' translation.Julien Lepiller 2018-06-18nls: Update 'da' translation.Ludovic Courtès 2018-04-19nls: Update 'es' translation.Ludovic Courtès 2018-04-11nls: Add Spanish translation.Ludovic Courtès 2018-03-05nls: Add Simplified Chinese translation.Ludovic Courtès 2018-02-19nls: Update 'fr' translation.Ludovic Courtès 2018-01-17nls: Update 'hu' translation.Leo Famulari 2017-12-18nls: Update 'hu' translation.Ludovic Courtès 2017-11-28services: certbot: Add default value and description....* gnu/services/certbot.scm (certbot-service-type) [default-value, description]: New fields. * po/packages/POTFILES.in: Add it. Ludovic Courtès 2017-11-28services: cgit, git-daemon: Add description and default value....* gnu/services/version-control.scm (git-daemon-service-type) [description, default-value]: New fields. (cgit-service-type)[default-value]: New field. * po/packages/POTFILES.in: Add version-control.scm. Ludovic Courtès 2017-09-16services: networking: Add descriptions....* gnu/services/networking.scm (static-networking-service-type) (ntp-service-type, inetd-service-type, tor-service-type) (tor-hidden-service-type, bitlbee-service-type) (wicd-service-type, network-manager-service-type) (connman-service-type, openvswitch-service-type): Add 'description' field. * po/packages/POTFILES.in: Add gnu/services/networking.scm. Ludovic Courtès 2017-09-16services: base: Add descriptions....* gnu/services/base.scm (fstab-service-type) (file-system-service-type, urandom-seed-service-type) (session-environment-service-type) (console-font-service-type) (login-service-type, agetty-service-type) (mingetty-service-type, nscd-service-type) (pam-limits-service-type, guix-service-type) (guix-publish-service-type, udev-service-type) (gpm-service-type): Add 'description' field. * po/packages/POTFILES.in: Add gnu/services/base.scm. Ludovic Courtès 2017-09-02nls: Update 'fr' translation.Ludovic Courtès 2017-07-15nls: Adjust to qemu.scm renaming....This is a followup to 59132b800093e486e4d81aed6b837e9ac76aa86c. * po/packages/POTFILES.in: Remove qemu.scm and add virtualization.scm. 宋文武 2017-06-20gnu: Move contents of zip module into compression module....* gnu/packages/zip.scm (zip, unzip, zziplib, perl-zip): Move to... * gnu/packages/compression.scm: ...here. * gnu/packages/zip.scm: Delete file. * gnu/local.mk (GNU_SYSTEM_MODULES): Unregister deleted file. * po/packages/POTFILES.in: Unregister deleted file. * gnu/packages/{audio, avr, bioinformatics, busybox, cdrom, ci, compression, docbook, documentation, fonts, fpga, game-development, games, gl, gnome, gnuzilla, graphics, guile, haskell, image, java, kodi, ldc, libreoffice, markup, maths, mc, monitoring, music, php, pretty-print, python, scheme, smalltalk, statistics, synergy, tex, textutils, video, web-browsers, xml, zip}.scm, guix/build-system/{ant, font}.scm, guix/{download, packages}.scm: Adapt module import. Arun Isaac 2017-05-23nls: Update 'da' translation.Leo Famulari 2017-05-14maint: Do not update PO files upon "make dist"....This works around a non-determinstic build failure when doing "make distcheck -j4". * po/guix/Makevars (DIST_DEPENDS_ON_UPDATE_PO): New variable. * po/packages/Makevars (DIST_DEPENDS_ON_UPDATE_PO): New variable. Ludovic Courtès 2016-12-19nls: Update 'da' package translation.Ludovic Courtès 2016-12-05nls: Adjust to geeqie.scm removal....This is a followup to d1a5b20081c30da7503201df260cf20b8d0ba633. * po/packages/POTFILES.in: Remove gnu/packages/geeqie.scm. Ludovic Courtès 2016-12-04nls: Adjust to feh.scm renaming....This is a followup to d1a5b20081c30da7503201df260cf20b8d0ba633. * po/packages/POTFILES.in: Remove feh.scm and add image-viewers.scm. Ludovic Courtès 2016-12-04nls: Update 'da' package translation.Marius Bakke 2016-08-04nls: Adjust to zsh.scm renaming....* po/packages/POTFILES.in: Adjust to zsh.scm renaming in commit 7ccb874a299d6c6d86a3f1625a68c08ed20dbab6. Ludovic Courtès 2016-05-26nls: Adjust to texlive.scm renaming....* po/packages/POTFILES.in: Adjust to texlive.scm rename in commit 8f9ac90182c022c69600f17ef9c1149e029bc301. Ludovic Courtès