aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages unrtf)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages m4)
  #:use-module (gnu packages base))

(define-public unrtf
  (package
    (name "unrtf")
    (version "0.21.10")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/unrtf/unrtf-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "1bil6z4niydz9gqm2j861dkxmqnpc8m7hvidsjbzz7x63whj17xl"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/unrtf/")
    (synopsis "Convert Rich Text Format documents to other formats")
    (description
     "GNU UnRTF converts text documents from RTF to HTML, LaTeX, or troff.
It supports changes in font characteristics, underlines and strikethroughs,
superscripts and subscripts, and more.")
    (license gpl3+)))
href='/guix/commit/gnu/packages/gl.scm?id=6832edf8044cac6514a9e23536b31b4d0a3919f8'>gnu: mesa: Enable NVK driver for x86_64 architecture....* gnu/packages/gl.scm (mesa)[native-inputs]: Add rust, rust-bindgen-cli, rust-cbindgen-0.26 for x86_64. [arguments]<#:meson>: Use newer version of meson to satisfy NVK build requirements. <#:configure-flags>: Use "auto" for 'vulkan-drivers' flag when target arch is x86_64. <#:phases>: Add 'patch-subproject-sources phase to patch rust subproject sources when target arch is x86_64. * gnu/packages/crates-io.scm (rust-paste-1, rust-proc-macro2-1, rust-quote-1, rust-syn-2, rust-unicode-ident-1): Add a comment about being dependencies of mesa. Change-Id: I76e3db5072ca3c718155b188ca64b52766d55f36 Signed-off-by: John Kehayias <john.kehayias@protonmail.com> aurtzy 2024-11-05gnu: mesa: Fix build on arm architectures....* gnu/packages/gl.scm (mesa)[inputs]: When building for an arm platform add python-pycparser. [arguments]: When building for aarch64 or armhf don't add kmsro as a gallium driver. * gnu/packages/python-xyz.scm (python-pycparser): Mark as a dependency for mesa. Change-Id: I61182157418a6667fcbb0d4280c959a708119b0d Efraim Flashner 2024-11-05gnu: mesa: Update configure flags....Previously, in 1ed0283fcc12b4b48f5b61be026a7b832d9781dc, mesa's configuration options were altered to use "auto" as needed, while it looks like this was inadvertently changed in 9b2a3e023f7090d19c98e7582220340df3962555. This meant i915 dropped from x86/x86_64. This commit restores the "auto" behavior where it matched our previous driver list (or restored missing drivers). See mesa's meson.build for all options. * gnu/packages/gl.scm (mesa)[arguments]: For gallium-drivers, use "softpipe,llvmpipe" instead of the deprecated "swrast" option. Use "auto" in gallium-drivers and vulkan-drivers where it provides the same driver list (or restores ones dropped from x86/x86_64). Comment on differences from "auto" where we don't use it. Change-Id: I920701f71d19578f4913fda7372273955f0a9847 John Kehayias 2024-11-05gnu: mesa: Update to 24.2.2....Note the clang input for mesa was in inputs for aarch64-linux but more generally in native-inputs for mesa-opencl. Moved to native-inputs for all (mesa does not retain a reference to clang). * gnu/packages/gl.scm (mesa): Update to 24.2.2. [inputs]: Move clang-18 when building for aarch64-linux to ... [native-inputs]: ... here for all architectures. Add python-ply, and python-pyyaml. Use libclc for all architectures. (mesa-opencl)[inputs, native-inputs]: Remove fields. * gnu/packages/python-xyz.scm (python-pyyaml, python-ply): Add a comment about being dependencies of mesa. Change-Id: Ie262e6ea5a31fda0e410277256c203ea3caed96b John Kehayias 2024-11-05gnu: llvm-for-mesa: Update to llvm-18....* gnu/packages/llvm.scm (llvm-for-mesa): Update to llvm-18. * gnu/packages/gl.scm (mesa)[inputs]: Always use llvm-for-mesa (remove llvm-18 for aarch64 to use llvm-for-mesa). (mesa-opencl)[native-inputs]: Remove clang-15. Add clang-18. Change-Id: I767d40d62a827864d3d109c44f82a43302875eb8 John Kehayias 2024-09-24gnu: glfw: Fix a missing path to a dlopen call....Recent release of glfw introduced a new dlopen call to `libwayland-client.so.0´. This small fix adds this library to the list of libraries to be patched. It does not affect earlier versions. * gnu/packages/gl.scm (glfw): Add `libwayland-client.so.0' to the list of libraries to be patched. Change-Id: I9436c63f49a9b2fed18e06d593e67a593e3c6cad Arnaud Lechevallier 2024-09-04gnu: glfw-3.4: Fix build....* gnu/packages/glfw.scm (glfw-3.4)[arguments]: Don't build out of source. Change-Id: I42437c60f7adbc0b087f7149b17181fbc8eab4ce Guillaume Le Vaillant 2024-08-31gnu: mesa: Fix building on aarch64-linux....* gnu/packages/gl.scm (mesa)[inputs]: When building for aarch64-linux use clang-18 and llvm-18 instead of llvm-for-mesa. [native-inputs]: When building for aarch64-linux add libclc. [arguments]: Adjust the 'disable-failing-test phase when building for aarch64-linux to skip a test. (mesa-opencl)[native-inputs]: When building for aarch64-linux don't add clang-15. * gnu/packages/check.scm (python-lit), * gnu/packages/llvm.scm (libclc), * gnu/packages/vulkan.scm (spirv-llvm-translator): Add a note about it being a dependency for mesa. Change-Id: I0bf5ab019ffd0626ad2d0c38bafceec401e3c886 Efraim Flashner 2024-08-31Agnu: mesa: Build asahi driver on aarch64....* gnu/packages/gl.scm (mesa): Build asahi driver on aarch64. Change-Id: I597e70732b9ebd18960131f1b664b2dc83683b8e Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Roman Scherer 2024-08-12gnu: glfw-3.4: New variable....* gnu/packages/gl.scm (glfw-3.4): New variable. Change-Id: I77f2214c78f35455436897a3fbff083331295314 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Artyom V. Poptsov 2024-08-12gnu: glfw: Update to 3.3.10....* gnu/packages/gl.scm (glfw): Update to 3.3.10. Change-Id: I9d789fb74af4ed649102195891adc5e437883d30 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Artyom V. Poptsov