aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages unrtf)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages m4)
  #:use-module (gnu packages base))

(define-public unrtf
  (package
    (name "unrtf")
    (version "0.21.10")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/unrtf/unrtf-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "1bil6z4niydz9gqm2j861dkxmqnpc8m7hvidsjbzz7x63whj17xl"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/unrtf/")
    (synopsis "Convert Rich Text Format documents to other formats")
    (description
     "GNU UnRTF converts text documents from RTF to HTML, LaTeX, or troff.
It supports changes in font characteristics, underlines and strikethroughs,
superscripts and subscripts, and more.")
    (license gpl3+)))
ail'>...It is required for cross-compilation. * gnu/packages/crypto.scm (tomb)[inputs]: Add 'bash-minimal'. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Maxime Devos 2024-08-22gnu: libsecp256k1: Update to 0.5.1....* gnu/packages/crypto.scm (libsecp256k1): Update to 0.5.1. [source]: Add snippet to remove pre-generated files. [arguments]: Remove --enable-module-ecdh and --enable-module-schnorrsig from configure-flags as they are enabled by default. Change-Id: I418ee47c1761ddae9cf4684b4c0ab49768b3f523 Co-authored-by: Jean-Pierre De Jesus DIAZ <jean@foundation.xyz> Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Michael Ford 2024-08-11system: Add privileged-programs to <operating-system>....* gnu/system.scm (<operating-system>): Add new privileged-programs field, that defaults to… (%default-privileged-programs): …this new variable, renamed from… (%setuid-programs): …this, which is now defined as the empty list. * doc/guix.texi (Setuid Programs): Rename this… (Privileged Programs): …to this. Adjust all refs. Update all mentions of ‘setuid’ (whether in prose, variable names, or code samples) to use the new ‘privilege[d]’ terminology instead. (operating-system Reference, X Window, Invoking guix system) (Service Reference): Adjust likewise. Tobias Geerinckx-Rice 2024-07-19gnu: rust-blake3-1: Update to 1.5.1....* gnu/packages/crypto.scm (rust-blake3-1): Update to 1.5.1. [cargo-inputs]: Replace rust-memmap2-0.7 with 0.9. Change-Id: Ie84bf55d93e04fa072476295461dd183a48ab881 Efraim Flashner 2024-04-23gnu: Add ssh-to-pgp....* gnu/packages/crypto.scm (ssh-to-pgp): New variable. Reviewed-by: Dale Mellor <guix-devel-0brg6a@rdmp.org> Signed-off-by: Christopher Baines <mail@cbaines.net> Change-Id: Ic8e55ede6b19d9a90291e3ac2cf608e8a59bc061 Giacomo Leidi 2024-04-05gnu: signify: Update to 32....* gnu/packages/crypto.scm (signify): Update to 32. Change-Id: I5dedc5d8c6e0acb5bec94befe5aafd1642edb68e Signed-off-by: Ludovic Courtès <ludo@gnu.org> Timotej Lazar 2024-02-20gnu: rust-crypto: Move to (gnu packages crates-crypto)....* gnu/packages/crates-io.scm (rust-crypto-secretbox-0.1, rust-crypto-bigint-0.5, rust-crypto-bigint-0.4, rust-crypto-bigint-0.3, rust-crypto-bigint-0.2, rust-crypto-common-0.1, rust-crypto-mac-0.11, rust-crypto-mac-0.10, rust-crypto-mac-0.8, rust-crypto-mac-0.7, rust-crypto-mac-0.5, rust-crypto-mac-0.4, rust-crypto-tests-0.5, rust-crypto-hash-0.3): Move from here ... * gnu/packages/crates-crypto.scm: ... to here. Change-Id: Ice6d8f1b35afe75f1b0219dc1288ddd4ac8ab4a8 Efraim Flashner 2024-02-13gnu: go-golang-org-x-crypto: Move to golang-build....* gnu/packages/golang.scm (go-golang-org-x-crypto): Move from here ... * gnu/packages/golang-build.scm: ... to here. * gnu/packages/backup.scm: Add (gnu packages golang-build) module. * gnu/packages/crypto.scm: As above. Change-Id: I5daad7fe90e1507958fe73c04fc043ebbc006395 Sharlatan Hellseher 2023-10-18Revert "build: cargo-build-system: Disable tests by default."...This reverts commit 37667443074a6de29f7665868f102111d62f0af9. This change needs more discussion. Efraim Flashner 2023-10-18build: cargo-build-system: Disable tests by default....* guix/build-system/cargo.scm (cargo-build): Disable tests by default. * gnu/packages/admin.scm (greetd, wlgreet, du-dust), * gnu/packages/bioinformatics.scm (circtools, python-gseapy), * gnu/packages/crypto.scm (rust-minisign, b3sum), * gnu/packages/gnome.scm (librsvg), * gnu/packages/python-crypto.scm (python-blake3, python-cryptography-rust), * gnu/packages/python-xyz.scm (python-orjson), * gnu/packages/rust-apps.scm (agate, alfis, bat, diffr, drill, dutree, exa, fd, hexyl, hyperfine, i3status-rust, just, maturin, ripgrep, rot8, rust-swc, rust-cargo-edit, git-interactive-rebase-tool, rust-cbindgen, rust-cbindgen-0.24, rust-cbindgen-0.19, sniffglue, tectonic, treefmt, hex, tokei, vivid, watchexec, rbw, rust-analyzer, rust-cargo-c, rtss, skim, skim-0.7, svd2rust, swayhide, tealdeer, git-absorb, zoxide, htmlq), * gnu/packages/sequoia.scm (sequoia-sqv), * gnu/packages/syndication.scm (newsboat), * gnu/packages/terminals.scm (alacritty), * gnu/packages/text-editors.scm (kak-lsp, parinfer-rust), * gnu/packages/tree-sitter.scm (tree-sitter-cli), * gnu/packages/video.scm (rav1e), * gnu/packages/web.scm (monolith, castor) [arguments]: Enable tests. Efraim Flashner 2023-10-18gnu: b3sum: Update to 1.5.0....* gnu/packages/crypto.scm (b3sum): Update to 1.5.0. [cargo-inputs]: Replace rust-blake3-0.3 with 1, rust-clap-2 with 4. Remove rust-memmap-0.7. Add rust-memmap2-0.7. Efraim Flashner 2023-10-18gnu: rust-blake3-1: Update to 1.5.0....* gnu/packages/crypto.scm (rust-blake3-1): Update to 1.5.0. [source]: Download using url-fetch. [arguments]: Skip tests. [cargo-inputs]: Add rust-memmap2-0.7, rust-serde-1, rust-zerioze-1. Replace rust-constant-time-eq-0.1 with 0.3, rust-digest-0.9 with 0.10. Remove rust-crypto-mac-0.11. [cargo-development-inputs]: Add rust-serde-json-1, rust-tempfile-3. Replace rust-page-size-0.4 with 0.6. Remove rust-cc-1. Efraim Flashner 2023-10-18gnu: rust-minisign: Update to 0.7.5....* gnu/packages/crates-io.scm (rust-minisign): Update to 0.7.5. [cargo-inputs]: Replace rust-getrandom-0.1 with 0.2, rust-rpassword-4 with 7, rust-scrypt-0.3 with 0.11. Efraim Flashner 2023-10-17gnu: crypto++: Add tunable property....* gnu/packages/crypto.scm (crypto++): Set tunable? property to true. Signed-off-by: Christopher Baines <mail@cbaines.net> Jean-Pierre De Jesus DIAZ 2023-10-17gnu: crypto++: Update to 8.8.0....* gnu/packages/crypto.scm (crypto++): Update to 8.8.0. [arguments]: Update to new style. Remove .so symbolic link installation as the project does it now. Fix cross-compilation for GNU/Linux and MinGW targets. Signed-off-by: Christopher Baines <mail@cbaines.net> Jean-Pierre De Jesus DIAZ 2023-08-07gnu: signify: Complete update to 31....* gnu/packages/crypto.scm (signify)[source]: Add snippet to delete bundled libbsd. [license]: Drop bsd-4 as it was replaced with bsd-3. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Timotej Lazar 2023-07-23gnu: fuse@3: Bind to default FUSE variable....* gnu/packages/linux.scm (fuse): Rename this… (fuse-2): …to this, and… (fuse-3): …rename this… (fuse): …to this! (fuse-static): Rename this… (fuse-2-static): …to this. Adjust all users. Tobias Geerinckx-Rice