aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2022, 2024 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages uml)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix utils)
  #:use-module (guix build-system ant)
  #:use-module (gnu packages graphviz)
  #:use-module (gnu packages java))

(define-public plantuml
  (package
    (name "plantuml")
    (version "1.2024.6")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/plantuml/plantuml/")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "0h6hk34x5qc8cyqlw90wnakji8w6n9bykpr3dygvfwg2kvw5rhlv"))))
    (build-system ant-build-system)
    (arguments
     `(#:tests? #f                      ; no tests
       #:build-target "dist"
       #:phases
       (modify-phases %standard-phases
         (add-before 'build 'delete-extra-from-classpath
           (lambda _
             (substitute* "build.xml"
               (("1.6") "1.7")
               (("<attribute name=\"Class-Path\"") "<!--")
               (("ditaa0_9.jar\" />") "-->"))
             #t))
         (add-after 'delete-extra-from-classpath 'patch-usr-bin-dot
           (lambda* (#:key inputs #:allow-other-keys)
             (let ((dot (search-input-file inputs "/bin/dot")))
               (substitute*
                   "src/net/sourceforge/plantuml/dot/GraphvizLinux.java"
                 (("/usr/bin/dot") dot)))
             #t))
         (replace 'install
           (lambda* (#:key outputs #:allow-other-keys)
             (install-file "plantuml.jar" (string-append
                                           (assoc-ref outputs "out")
                                           "/share/java"))
             #t))
         (add-after 'install 'make-wrapper
           (lambda* (#:key inputs outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (wrapper (string-append out "/bin/plantuml")))
               (mkdir-p (string-append out "/bin"))
               (with-output-to-file wrapper
                 (lambda _
                   (display
                    (string-append
                     "#!/bin/sh\n\n"
                     (assoc-ref inputs "jre") "/bin/java -jar "
                     out "/share/java/plantuml.jar \"$@\"\n"))))
               (chmod wrapper #o555))
             #t)))))
    (inputs
     `(("graphviz" ,graphviz)
       ("jre" ,icedtea)))
    (home-page "https://plantuml.com/")
    (synopsis "Draw UML diagrams from simple textual description")
    (description
     "Plantuml is a tool to generate sequence, usecase, class, activity,
component, state, deployment and object UML diagrams, using a simple and
human readable text description.  Contains @code{salt}, a tool that can design
simple graphical interfaces.")
    (license license:gpl3+)))
7c91297b0ad4e0d0985783b64 Signed-off-by: Hilton Chain <hako@ultrarare.space> André Batista 2024-12-21gnu: make-torbrowser: Unbundle libvpx....* gnu/packages/tor-browsers.scm (make-torbrowser)[arguments] <#:configure-flags>: Uncomment '--with-system-libvpx'. <#:phases>: Remove bundled libvpx. Change-Id: Ie77cf4052a2b1e3e0959598c5e5d42bb397c666c Signed-off-by: Hilton Chain <hako@ultrarare.space> André Batista 2024-12-11gnu: mullvadbrowser: Update to 14.0.3 [security fixes]....Fixes CVE 2024-9680, 2024-10458, 2024-10459, 2024-10460, 2024-10461, 2024-10462, 2024-10463, 2024-10464, 2024-10465, 2024-10466, 2024-10467, 2024-11691, 2024-11692, 2024-11693, 2024-11694, 2024-11695, 2024-11696, 2024-11697, 2024-11698 and 2024-11699. See the Mozilla Foundation Security Advisories <https://www.mozilla.org/en-US/security/advisories/mfsa2024-51/>, <https://www.mozilla.org/en-US/security/advisories/mfsa2024-57/> and <https://www.mozilla.org/en-US/security/advisories/mfsa2024-64/> for details. * gnu/packages/tor-browsers.scm (%mullvadbrowser-build-date): Update to 20241125154204. (%mullvadbrowser-version): Update to 14.0.3. (%mullvadbrowser-firefox-version): Update to 128.5.0esr-14.0-1-build2. (mullvadbrowser-translation-base): Update to caa431bbea1a76d7ad61eeda94086a1513762605. (mullvadbrowser-translation-specific): Update to 2f7d98b46ce480cdb4d7e9ddab912650c8673d6c. Change-Id: Ia5d445e387351b3d5d08ecb14c2f31bf4cc81396 Signed-off-by: Hilton Chain <hako@ultrarare.space> André Batista 2024-12-11gnu: torbrowser: Update to 14.0.3 [security-fixes]....Fixes CVEs 2024-10458, 2024-10459, 2024-10460, 2024-10461, 2024-10462, 2024-10463, 2024-10464, 2024-10465, 2024-10466, 2024-10467, 2024-11691, 2024-11692, 2024-11693, 2024-11694, 2024-11695, 2024-11696, 2024-11697, 2024-11698 and 2024-11699. See <https://www.mozilla.org/en-US/security/advisories/mfsa2024-48/> and <https://www.mozilla.org/en-US/security/advisories/mfsa2024-64/> for details. * gnu/packages/patches/torbrowser-compare-paths.patch: New file. * gnu/local.mk (dist_patch_DATA): Regisiter it. * gnu/packages/tor-browsers.scm (firefox-locales): Update to f75c1e6a305e68161037337767ece88e9de940b9. (%torbrowser-build-date): Update to 20241125154204. (%torbrowser-version): Update to 14.0.3. (%torbrowser-firefox-version): Update to 128.5.0esr-14.0-1-build2. (torbrowser-translation-base): Update to caa431bbea1a76d7ad61eeda94086a1513762605. (torbrowser-translation-specific): Update to 4314d0a7ce780ffdf82b84e324bfbc437198f993. (make-torbrowser) [arguments] <#:phases>: On 'apply-guix-specific-patches change icecat-compare-paths.patch to torbrowser-compare-paths.patch as the patched file has changed its name between major versions. On 'remove-cargo-frozen-flag, update the regex to match this newer version string. Change-Id: Ia5d445e387351b3d5d08ecb14c2f31bf4cc81396 Signed-off-by: Hilton Chain <hako@ultrarare.space> André Batista 2024-11-28gnu: mullvadbrowser: Fix build....* gnu/packages/tor-browsers.scm (make-torbrowser)[inputs]: Replace rust-cbindgen with rust-cbindgen-0.26. Change-Id: If89d357ca90df016cf8a4d4ec8ef85e523b12b10 Efraim Flashner 2024-11-28gnu: make-torbrowser: Fix building with newer rust....* gnu/packages/tor-browsers.scm (make-torbrowser)[arguments]: Adjust the configure-flags to temporarily disable rust SIMD optimizations. Change-Id: I54431581f2a681ec2b5402238e0bc78c038cfbc1 Efraim Flashner 2024-10-12gnu: torbrowser: Update to 13.5.7 [security fixes]....Fixes CVEs 2024-9392, 2024-9393, 2024-9394, 2024-9401 and 2024-9680. See the Mozilla Foundation Security Advisories <https://www.mozilla.org/en-US/security/advisories/mfsa2024-48/> and <https://www.mozilla.org/en-US/security/advisories/mfsa2024-51/> for details. * gnu/packages/tor-browsers.scm (%torbrowser-build-date): Update to 20241008182800. (%torbrowser-version): Update to 13.5.7. (%torbrowser-firefox-version): Update to 115.16.0esr-13.5-1-build3. (torbrowser-translation-base): Update to ceb66dd0937da14962cb535699242b2526e11f02. (torbrowser-translation-specific): Update to dbf1454fdbd3256d65985cc1c46391ce0ec159e7. (make-torbrowser) [arguments] <#:phases>: On 'copy-basebrowser-locales stop copying 'cryptoSafetyPrompt.properties'. See <https://gitlab.torproject.org/tpo/applications/tor-browser-build/-/commit/cf68476c67f6c5159dab3d7c241392c597fd3988>. Change-Id: Ic17a669c1311d92da347e11ea08acc7a218bc728 Signed-off-by: Ludovic Courtès <ludo@gnu.org> André Batista 2024-10-11gnu: mullvadbrowser: Update to 13.5.6 [security fixes]....Fixes CVEs 2024-9392, 2024-9393, 2024-9394 and 2024-9401. See the Mozilla Foundation Security Advisory <https://www.mozilla.org/en-US/security/advisories/mfsa2024-48/> for details. * gnu/packages/tor-browsers.scm (%mullvadbrowser-build-date): Update to 20240930230510. (%mullvadbrowser-version): Update to 13.5.6. (%mullvadbrowser-firefox-version): Update to 115.16.0esr-13.5-1-build2. (mullvadbrowser-translation-base): Update to a142f78af87f994913faa15fb4b0f34f0ce1a22b. (mullvadbrowser-translation-specific): Update to 78212a3da2439e436ac5f73d8e3eb908145c3ece. Change-Id: Id65315c9aa829815e00dcfe74098680654592f20 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> André Batista 2024-09-30gnu: mullvadbrowser: Update to 13.5.3 [security fixes]....Fixes CVEs 2024-6600, 2024-6601, 2024-6602, 2024-6603, 2024-6604, 2024-7519, 2024-7521, 2024-7522, 2024-7524, 2024-7525, 2024-7526, 2024-7527, 2024-7529, 2024-7531, 2024-8381, 2024-8382, 2024-8383 and 2024-8384. See the Mozilla Foundation Security advisories <https://www.mozilla.org/en-US/security/advisories/mfsa2024-30/>, <https://www.mozilla.org/en-US/security/advisories/mfsa2024-34/> and <https://www.mozilla.org/en-US/security/advisories/mfsa2024-41/> for details. * gnu/packages/mullvad-browsers.scm (mozilla-locale): Remove it. (mozilla-locales): Likewise. (firefox-locales): Move to the top. (%mullvadbrowser-locales): Change it to be a plain list of supported locales. (%mullvadbrowser-build-date): Update to 20240903073000. (%mullvadbrowser-version): Update to 13.5.3. (%mullvadbrowser-firefox-version): Update to 115.15.0esr-13.5-1-build2. (mullvadbrowser-translation-base): Update to daed2afc487d1b20efc17feb153156524c6f714b. (mullvadbrowser) [arguments] <#:phases>: Adjust copy-torbrowser-locales replacement accordingly. Change-Id: I5acf486d5f22da9145827b12b48c6c764daaa9bf Signed-off-by: Ludovic Courtès <ludo@gnu.org> André Batista 2024-09-30gnu: torbrowser: Update to 13.5.3 [security fixes]....Fixes CVEs 2024-6600, 2024-6601, 2024-6602, 2024-6603, 2024-6604, 2024-7519, 2024-7521, 2024-7522, 2024-7524, 2024-7525, 2024-7526, 2024-7527, 2024-7529, 2024-7531, 2024-8381, 2024-8382, 2024-8383 and 2024-8384. See the Mozilla Foundation Security advisories <https://www.mozilla.org/en-US/security/advisories/mfsa2024-30/>, <https://www.mozilla.org/en-US/security/advisories/mfsa2024-34/> and <https://www.mozilla.org/en-US/security/advisories/mfsa2024-41/> for details. * gnu/packages/tor-browsers.scm (%torbrowser-build-date): Update to 20240903073000. (%torbrowser-version): Update to 13.5.3. (%torbrowser-firefox-version): Update to 115.15.0esr-13.5-1-build3. (%torbrowser-locales): Change it to be a plain list of supported locales. (firefox-locales): New variable. (torbrowser-translation-base): Update to daed2afc487d1b20efc17feb153156524c6f714b. (torbrowser-translation-specific): Update to 6374e3b09c0894b8452fa1ba0b99c807722fc805. (lld-as-ld-wrapper-16): New variable. (make-torbrowser)[native-inputs]: Add lld-as-ld-wrapper-16. Use llvm-16 and clang-16. [inputs]: Add firefox-locales. [arguments] <#:phases>: Remove add-bridges. setenv, copy-firefox-locales: Update MOZ_CHROME_MULTILOCALE to the new %torbrowser-locales format. copy-basebrowser-locales, copy-torbrowser-locales: Likewise and adjust fluent file path. deploy-fonts: Adjust regex expression. autoconfig: Remove file-picker configuration workaround. See #71181. Change-Id: Idf182607798d9111c30db63fe926b7f8cb3ce300 Signed-off-by: Ludovic Courtès <ludo@gnu.org> André Batista