aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2022, 2024 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages uml)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix utils)
  #:use-module (guix build-system ant)
  #:use-module (gnu packages graphviz)
  #:use-module (gnu packages java))

(define-public plantuml
  (package
    (name "plantuml")
    (version "1.2024.6")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/plantuml/plantuml/")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "0h6hk34x5qc8cyqlw90wnakji8w6n9bykpr3dygvfwg2kvw5rhlv"))))
    (build-system ant-build-system)
    (arguments
     `(#:tests? #f                      ; no tests
       #:build-target "dist"
       #:phases
       (modify-phases %standard-phases
         (add-before 'build 'delete-extra-from-classpath
           (lambda _
             (substitute* "build.xml"
               (("1.6") "1.7")
               (("<attribute name=\"Class-Path\"") "<!--")
               (("ditaa0_9.jar\" />") "-->"))
             #t))
         (add-after 'delete-extra-from-classpath 'patch-usr-bin-dot
           (lambda* (#:key inputs #:allow-other-keys)
             (let ((dot (search-input-file inputs "/bin/dot")))
               (substitute*
                   "src/net/sourceforge/plantuml/dot/GraphvizLinux.java"
                 (("/usr/bin/dot") dot)))
             #t))
         (replace 'install
           (lambda* (#:key outputs #:allow-other-keys)
             (install-file "plantuml.jar" (string-append
                                           (assoc-ref outputs "out")
                                           "/share/java"))
             #t))
         (add-after 'install 'make-wrapper
           (lambda* (#:key inputs outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (wrapper (string-append out "/bin/plantuml")))
               (mkdir-p (string-append out "/bin"))
               (with-output-to-file wrapper
                 (lambda _
                   (display
                    (string-append
                     "#!/bin/sh\n\n"
                     (assoc-ref inputs "jre") "/bin/java -jar "
                     out "/share/java/plantuml.jar \"$@\"\n"))))
               (chmod wrapper #o555))
             #t)))))
    (inputs
     `(("graphviz" ,graphviz)
       ("jre" ,icedtea)))
    (home-page "https://plantuml.com/")
    (synopsis "Draw UML diagrams from simple textual description")
    (description
     "Plantuml is a tool to generate sequence, usecase, class, activity,
component, state, deployment and object UML diagrams, using a simple and
human readable text description.  Contains @code{salt}, a tool that can design
simple graphical interfaces.")
    (license license:gpl3+)))
s/mpd.scm?id=a61b08ffa70793708ce0bd3f425381f87067f6c4'>gnu: ncmpc: Update to 0.48....* gnu/packages/mpd.scm (ncmpc): Update 0.48. Leo Famulari 2023-04-21gnu: mpdevil: Update to 1.10.2....* gnu/packages/mpd.scm (mpdevil): Update to 1.10.2. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> kiasoc5 2023-03-27gnu: mympd: Update to 10.2.6....* gnu/packages/mpd.scm (mympd): Update to 10.2.6. Signed-off-by: Christopher Baines <mail@cbaines.net> Bruno Victal 2023-03-02gnu: mympd: Update to 10.2.4....* gnu/packages/mpd.scm (mympd): Update to 10.2.4. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Bruno Victal 2023-02-23gnu: mpdris2: Remove input labels and add inputs....* gnu/packages/mpd.scm (mpdris2)[arguments]: Use G-expressions. Remove trailing #T from phase. [inputs]: Remove labels. Add BASH-MINIMAL and PYTHON-MUTAGEN. [native-inputs]: Remove labels. [description]: Use complete sentence. Simon Streit 2023-02-12gnu: mympd: Update to 10.2.3....* gnu/packages/mpd.scm (mympd): Update to 10.2.3. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Bruno Victal 2023-02-11gnu: mympd: Update to 10.2.2....* gnu/packages/mpd.scm (mympd): Update to 10.2.2. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Bruno Victal 2023-02-05gnu: mpd: Update to 0.23.12....* gnu/packages/mpd.scm (mpd): Update to 0.23.12. Signed-off-by: Leo Famulari <leo@famulari.name> Bruno Victal 2023-02-05gnu: mpd: Add missing inputs....Enable more features for MPD. * gnu/packages/mpd.scm (mpd)[inputs]: Add liburing, chromaprint, expat, libgme, libnfs, libopenmpt, libshout, pcre2, soxr, yajl and zziplib. Signed-off-by: Leo Famulari <leo@famulari.name> Bruno Victal 2023-02-03gnu: mympd: Update to 10.2.1....* gnu/packages/mpd.scm (mympd): Update to 10.2.1. Signed-off-by: Christopher Baines <mail@cbaines.net> Bruno Victal 2023-01-29gnu: mpdevil: Update to 1.10.0...* gnu/packages/mpd.scm (mpdevil): Update to 1.10.0. [inputs]: Add python-pycairo. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Simon Streit 2023-01-28gnu: mympd: Update to 10.2.0....* gnu/packages/mpd.scm (mympd): Update to 10.2.0. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Bruno Victal 2023-01-08gnu: Switch to default pipewire....This is a follow-up of: 590700ce00177a826872c867066eeba6eb7c4641. * gnu/packages/kde-plasma.scm (kwin, plasma-desktop, plasma-workspace)[inputs]: Switch to pipewire. * gnu/packages/mpd.scm (mpd)[inputs]: Ditto. Mathieu Othacehe 2022-12-11gnu: mpd: Update to 0.23.11....* gnu/packages/mpd.scm (mpd): Update to 0.23.11. Tobias Geerinckx-Rice 2022-12-13gnu: mympd: Update to 10.1.6....* gnu/packages/mpd.scm (mympd): Update to 10.1.6. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Bruno Victal 2022-12-11gnu: yajl: Drop custom ‘lib-’ prefix....* gnu/packages/web.scm (yajl): New variable, renamed from… (libyajl): …this one, which is now a DEPRECATED-PACKAGE alias of yajl. Adjust all users. Tobias Geerinckx-Rice 2022-11-28gnu: mympd: Update to 10.1.3...* gnu/packages/mpd.scm (mympd): Update to 10.1.3. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Bruno Victal 2022-11-24gnu: Add mympd....* gnu/packages/mpd.scm (mympd): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net> Bruno Victal 2022-11-22gnu: ashuffle: Update to 3.13.4....* gnu/packages/mpd.scm (ashuffle): Update to 3.13.4. [inputs]: Add ABSEIL-CPP-CXXSTD17, GOOGLETEST, and YAML-CPP. [arguments]: New field. Marius Bakke 2022-10-23gnu: mpd: Update to 0.23.10....* gnu/packages/mpd.scm (mpd): Update to 0.23.10. [inputs]: Add pipewire-0.3. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> kiasoc5 2022-10-13gnu: cantata: Update to 2.5.0....* gnu/packages/mpd.scm (cantata): Update to 2.5.0. [inputs]: Add "avahi" and "musicbrainz". Signed-off-by: Christopher Baines <mail@cbaines.net> Simon Streit 2022-10-12gnu: mcg: Cleanup style....* gnu/packages/mpd.scm (mcg)[source]: Indent as with ‘guix style’. [arguments]: Convert to list of G-Expressions. [inputs, native-inputs]: Move below arguments. Liliana Marie Prikler 2022-10-12gnu: mcg: Update to 3.1....* gnu/packages/mpd.scm (mcg): Update to 3.1. [native-inputs]: Use the new inputs style. Add desktop-file-utils, gettext-minimal and gtk+:bin. [inputs]: Add python. [build-system]: Change to meson-build-system. [arguments]<#:imported-modules,#:modules>: Remove. <#:glib-or-gtk?>: Set to #t. <#:phases>: Delete ‘glib-or-gtk-wrap’. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Simon Streit 2022-10-12gnu: mcg: Use new input style....* gnu/packages/mpd.scm (mcg)[inputs]: Re-indent according to ‘guix style’. [native-inputs]: Drop labels. Liliana Marie Prikler 2022-09-10gnu: Add mpdevil....* gnu/packages/mpd.scm (mpdevil): New variable. Liliana Marie Prikler 2022-07-31gnu: qtmultimedia: Rename to qtmultimedia-5....Automated via: git grep -l qtmultimedia | xargs sed 's/qtmultimedia/qtmultimedia-5/g' -i git checkout NEWS Maxim Cournoyer 2022-07-31gnu: qtsvg: Rename variable to qtsvg-5....This is in preparation of the qtsvg update to version 6. This change was automated via the following command: git grep -l '\bqtsvg\b' | xargs sed 's/qtsvg/qtsvg-5/g' -i Maxim Cournoyer 2022-07-24gnu: ncmpc: Update to 0.47....* gnu/packages/mpd.scm (ncmpc): Update to 0.47. Tobias Geerinckx-Rice 2022-07-24gnu: mpd: Update to 0.23.8....* gnu/packages/mpd.scm (mpd): Update to 0.23.8. Tobias Geerinckx-Rice 2022-05-21gnu: mpd: Add support for socket activation....* gnu/packages/mpd.scm (mpd)[#:configure-flags]: Convert to G-Expression. Add “-Dsystemd=enabled”. [#:phases]: New argument. [inputs]: Add elogind. Liliana Marie Prikler 2022-05-14gnu: MPD: Update to 0.23.7....* gnu/packages/mpd.scm (mpd): Update to 0.23.7. Leo Famulari