aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2022, 2024 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages uml)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix utils)
  #:use-module (guix build-system ant)
  #:use-module (gnu packages graphviz)
  #:use-module (gnu packages java))

(define-public plantuml
  (package
    (name "plantuml")
    (version "1.2024.6")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/plantuml/plantuml/")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "0h6hk34x5qc8cyqlw90wnakji8w6n9bykpr3dygvfwg2kvw5rhlv"))))
    (build-system ant-build-system)
    (arguments
     `(#:tests? #f                      ; no tests
       #:build-target "dist"
       #:phases
       (modify-phases %standard-phases
         (add-before 'build 'delete-extra-from-classpath
           (lambda _
             (substitute* "build.xml"
               (("1.6") "1.7")
               (("<attribute name=\"Class-Path\"") "<!--")
               (("ditaa0_9.jar\" />") "-->"))
             #t))
         (add-after 'delete-extra-from-classpath 'patch-usr-bin-dot
           (lambda* (#:key inputs #:allow-other-keys)
             (let ((dot (search-input-file inputs "/bin/dot")))
               (substitute*
                   "src/net/sourceforge/plantuml/dot/GraphvizLinux.java"
                 (("/usr/bin/dot") dot)))
             #t))
         (replace 'install
           (lambda* (#:key outputs #:allow-other-keys)
             (install-file "plantuml.jar" (string-append
                                           (assoc-ref outputs "out")
                                           "/share/java"))
             #t))
         (add-after 'install 'make-wrapper
           (lambda* (#:key inputs outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (wrapper (string-append out "/bin/plantuml")))
               (mkdir-p (string-append out "/bin"))
               (with-output-to-file wrapper
                 (lambda _
                   (display
                    (string-append
                     "#!/bin/sh\n\n"
                     (assoc-ref inputs "jre") "/bin/java -jar "
                     out "/share/java/plantuml.jar \"$@\"\n"))))
               (chmod wrapper #o555))
             #t)))))
    (inputs
     `(("graphviz" ,graphviz)
       ("jre" ,icedtea)))
    (home-page "https://plantuml.com/")
    (synopsis "Draw UML diagrams from simple textual description")
    (description
     "Plantuml is a tool to generate sequence, usecase, class, activity,
component, state, deployment and object UML diagrams, using a simple and
human readable text description.  Contains @code{salt}, a tool that can design
simple graphical interfaces.")
    (license license:gpl3+)))
dddda15fb9f191d'>gnu: ldns: Update to 1.8.1....* gnu/packages/dns.scm (ldns): Update to 1.8.1. [source]: Remove needless parameterisation. Tobias Geerinckx-Rice 2021-12-22gnu: knot: Update to 3.1.5....* gnu/packages/dns.scm (knot): Update to 3.1.5. Tobias Geerinckx-Rice 2021-12-17gnu: knot-resolver: Update to 5.4.3....* gnu/packages/dns.scm (knot-resolver): Update to 5.4.3. [arguments]: Don't explicitly return #t from phases. Tobias Geerinckx-Rice 2021-12-17gnu: nsd: Update to 4.3.9....* gnu/packages/dns.scm (nsd): Update to 4.3.9. Tobias Geerinckx-Rice 2021-12-15gnu: bind: Update to 9.16.24....* gnu/packages/dns.scm (isc-bind): Update to 9.16.24. Tobias Geerinckx-Rice 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-12-10Merge remote-tracking branch 'signed/master' into core-updatesMathieu Othacehe 2021-12-09gnu: bind: Update to 9.16.23 [fixes CVE-2021-25218, CVE-2021-25219]....* gnu/packages/dns.scm (isc-bind): Update to 9.16.23. [source]: Add patch. * gnu/packages/patches/bind-re-add-attr-constructor-priority.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Tobias Geerinckx-Rice 2021-12-05Merge remote-tracking branch 'origin/master' into core-updates-frozenRicardo Wurmus 2021-11-27gnu: yadifa: Update to 2.5.3....* gnu/packages/dns.scm (yadifa): Update to 2.5.3. [arguments]: Don't explicitly return #t from phases. Tobias Geerinckx-Rice 2021-11-22gnu: openresolv: Wrap resolvconf....* gnu/packages/dns.scm (openresolv) [phases]: Wrap resolvconf to set PATH, for coreutils programs mkdir and rm. [inputs]: Add coreutils-minimal. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Vivien Kraus 2021-11-08gnu: knot: Update to 3.1.4....* gnu/packages/dns.scm (knot): Update to 3.1.4. Tobias Geerinckx-Rice 2021-11-03gnu: knot: Update to 3.1.3....* gnu/packages/dns.scm (knot): Update to 3.1.3. Tobias Geerinckx-Rice 2021-11-03gnu: snd: Update to 4.3.8....* gnu/packages/dns.scm (snd): Update to 4.3.8. [arguments]: Don't explicitly return #t from phases. Tobias Geerinckx-Rice 2021-10-29gnu: knot-resolver: Update to 5.4.2....* gnu/packages/dns.scm (knot-resolver): Update to 5.4.2. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Simon South 2021-10-13gnu: Add cloudflare-cli...* gnu/packages/dns.scm (cloudflare-cli): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Stephen Paul Weber 2021-10-05gnu: Add rbldnsd....* gnu/packages/dns.scm (rbldnsd): New public variable. Tobias Geerinckx-Rice 2021-10-04gnu: knot: Unambiguously enable XDP....* gnu/packages/dns.scm (knot)[arguments]: Replace "--enable-xdp=auto" with "--enable-xdp=yes" which now supports using the system libbpf. Tobias Geerinckx-Rice 2021-10-03gnu: knot: Honour PARALLEL-BUILD?....* gnu/packages/dns.scm (knot)[arguments]: Spawn multiple make jobs if requested. Tobias Geerinckx-Rice 2021-10-03gnu: knot: Don't build static libraries....* gnu/packages/dns.scm (knot)[arguments]: Add "--disable-static" to #:configure-flags. Tobias Geerinckx-Rice 2021-10-03gnu: knot: Update to 3.1.2....* gnu/packages/dns.scm (knot): Update to 3.1.2. [source]: Remove explicit #t snippet return value. [arguments]: Don't explicitly return #t from phases. [inputs]: Add libmnl. Tobias Geerinckx-Rice 2021-10-03gnu: yadifa: Update to 2.5.1 [security fixes]....* gnu/packages/dns.scm (yadifa): Update to 2.5.1. Tobias Geerinckx-Rice 2021-10-03gnu: dnsmasq: Prepare for cross-compilation....* gnu/packages/dns.scm (dnsmasq)[arguments]: Use CC-FOR-TARGET. Tobias Geerinckx-Rice 2021-10-03gnu: dnsmasq: Update to 2.86....* gnu/packages/dns.scm (dnsmasq): Update to 2.86. Tobias Geerinckx-Rice 2021-09-04gnu: nsd: Update to 4.3.7....* gnu/packages/dns.scm (nsd): Update to 4.3.7. Tobias Geerinckx-Rice 2021-09-04gnu: unbound: Update to 1.13.2....* gnu/packages/dns.scm (unbound): Update to 1.13.2. Tobias Geerinckx-Rice 2021-08-25gnu: knot-resolver: Update to 5.4.1....* gnu/packages/dns.scm (knot-resolver): Update to 5.4.1. Simon South 2021-07-27gnu: knot-resolver: Update to 5.4.0....* gnu/packages/dns.scm (knot-resolver): Update to 5.4.0. Signed-off-by: Leo Famulari <leo@famulari.name> Simon South 2021-06-20gnu: knot: Update to 3.0.7....* gnu/packages/dns.scm (knot): Update to 3.0.7. Tobias Geerinckx-Rice 2021-06-13doc, gnu, guix: Fix typos....* doc/guix.texi: Fix various typos and reword a sentence. * gnu/packages/cpp.scm (cpplint)[description]: Fix typo. * gnu/packages/dns.scm (ldns): Fix typo in comment. * gnu/packages/games.scm (yamagi-quake2): Fix typo in comment. * gnu/packages/qt.scm (python-pyqtwebengine): Fix typo in comment. * gnu/packages/rails.scm (ruby-autoprefixer-rails): Fix typo in comment. * gnu/packages/syndication.scm (quiterss)[description]: Fix typo. * gnu/packages/terminals.scm (kmscon): Fix typo in comment. * gnu/packages/xml.scm (perl-xml-sax-base)[description]: Fix typo. (python-elementpath)[description]: Fix typo. * guix/build/asdf-build-system.scm (output-translation): Fix typo in docstring. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Paul A. Patience 2021-06-09gnu: maradns: Update to 3.5.0020....* gnu/packages/dns.scm (maradns): Update to 3.5.0020. Tobias Geerinckx-Rice 2021-06-09gnu: yadifa: Enable the TCP manager....* gnu/packages/dns.scm (yadifa)[arguments]: Add "--enable-tcp-manager" to #:configure-flags. Tobias Geerinckx-Rice 2021-06-09gnu: yadifa: Update to 2.5.0....* gnu/packages/dns.scm (yadifa): Update to 2.5.0. Tobias Geerinckx-Rice 2021-06-01gnu: unbound: Enable DoH support....* gnu/packages/dns.scm (unbound)[inputs]: Add NGHTTP2:LIB. [arguments]: Add "--with-libnghttp2" to #:configure-flags. Marius Bakke 2021-05-20gnu: bind: Update to 9.16.16....* gnu/packages/dns.scm (isc-bind): Update to 9.16.16. Tobias Geerinckx-Rice 2021-05-13gnu: knot: Update to 3.0.6....* gnu/packages/dns.scm (knot): Update to 3.0.6. Tobias Geerinckx-Rice 2021-05-06gnu: knot-resolver: Update to 5.3.2....* gnu/packages/dns.scm (knot-resolver): Update to 5.3.2. Tobias Geerinckx-Rice 2021-04-28gnu: bind: Update to 9.16.15 [fixes CVE-2021-25214, CVE-2021-25215, CVE-2021-......* gnu/packages/dns.scm (isc-bind): Update to 9.16.15. Tobias Geerinckx-Rice