aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2022, 2024 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages uml)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix utils)
  #:use-module (guix build-system ant)
  #:use-module (gnu packages graphviz)
  #:use-module (gnu packages java))

(define-public plantuml
  (package
    (name "plantuml")
    (version "1.2024.6")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/plantuml/plantuml/")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "0h6hk34x5qc8cyqlw90wnakji8w6n9bykpr3dygvfwg2kvw5rhlv"))))
    (build-system ant-build-system)
    (arguments
     `(#:tests? #f                      ; no tests
       #:build-target "dist"
       #:phases
       (modify-phases %standard-phases
         (add-before 'build 'delete-extra-from-classpath
           (lambda _
             (substitute* "build.xml"
               (("1.6") "1.7")
               (("<attribute name=\"Class-Path\"") "<!--")
               (("ditaa0_9.jar\" />") "-->"))
             #t))
         (add-after 'delete-extra-from-classpath 'patch-usr-bin-dot
           (lambda* (#:key inputs #:allow-other-keys)
             (let ((dot (search-input-file inputs "/bin/dot")))
               (substitute*
                   "src/net/sourceforge/plantuml/dot/GraphvizLinux.java"
                 (("/usr/bin/dot") dot)))
             #t))
         (replace 'install
           (lambda* (#:key outputs #:allow-other-keys)
             (install-file "plantuml.jar" (string-append
                                           (assoc-ref outputs "out")
                                           "/share/java"))
             #t))
         (add-after 'install 'make-wrapper
           (lambda* (#:key inputs outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (wrapper (string-append out "/bin/plantuml")))
               (mkdir-p (string-append out "/bin"))
               (with-output-to-file wrapper
                 (lambda _
                   (display
                    (string-append
                     "#!/bin/sh\n\n"
                     (assoc-ref inputs "jre") "/bin/java -jar "
                     out "/share/java/plantuml.jar \"$@\"\n"))))
               (chmod wrapper #o555))
             #t)))))
    (inputs
     `(("graphviz" ,graphviz)
       ("jre" ,icedtea)))
    (home-page "https://plantuml.com/")
    (synopsis "Draw UML diagrams from simple textual description")
    (description
     "Plantuml is a tool to generate sequence, usecase, class, activity,
component, state, deployment and object UML diagrams, using a simple and
human readable text description.  Contains @code{salt}, a tool that can design
simple graphical interfaces.")
    (license license:gpl3+)))
d>2024-03-30Merge branch 'gnome-team'Liliana Marie Prikler 2024-03-23gnu: mullvadbrowser: Update to 13.0.13 [fixes CVE-2024-29944]....* gnu/packages/mullvad-browsers.scm (%mullvadbrowser-build-date): Update to 20240322132912. (%mullvadbrowser-version): Update to 13.0.13. (%mullvadbrowser-firefox-version): Update to 115.9.1esr-13.0-1-build1. (mullvadbrowser-translation-base): Update to 8e04ca3c5f440ed8f16b2069ae9565e4b044ec29. Change-Id: Id19ba361e9867200edd5ee9f35142d8dbe5447ab Clément Lassieur 2024-03-23gnu: torbrowser: Update to 13.0.13 [fixes CVE-2024-29944]....* gnu/packages/tor-browsers.scm (%torbrowser-build-date): Update to 20240322115718. (%torbrowser-version): Update to 13.0.13. (%torbrowser-firefox-version): Update to 115.9.1esr-13.0-1-build1. (torbrowser-translation-base): Update to 8e04ca3c5f440ed8f16b2069ae9565e4b044ec29. (torbrowser-translation-specific): Update to bf2fac60a6c41aa67b8147f22a638d498ac2dcdd. Change-Id: Ife0cb3b2d42dc5d6b39d5a11827c0a234c950126 Clément Lassieur 2024-03-21gnu: mullvadbrowser: Update to 13.0.12....* gnu/packages/mullvad-browsers.scm (%mullvadbrowser-build-date): Update to 20240313183935. (%mullvadbrowser-version): Update to 13.0.12. (%mullvadbrowser-firefox-version): Update to 115.9.0esr-13.0-1-build2. (mullvadbrowser-translation-base): Update to 595dcd5efe752cddc1b6ba47082ad9f5f4917fee. (mullvadbrowser-translation-specific): Update to c5361cb496ae7e047fd9226139537f1fcfc7938d. Change-Id: I365d5517cc145c0b66b502b5ed1738bf978a29da Clément Lassieur 2024-03-21gnu: torbrowser: Update to 13.0.12....* gnu/packages/tor-browsers.scm (%torbrowser-build-date): Update to 20240318163712. (%torbrowser-version): Update to 13.0.12. (%torbrowser-firefox-version): Update to 115.9.0esr-13.0-1-build3. (torbrowser-translation-base): Update to a4d224e82808529e135259e04fb58fb39b90da2d. (torbrowser-translation-specific): Update to e7aabc54138211e23bc60af1abe492c8bc68ce4b. Change-Id: I878f26149b22f5703e2e9bb7ee0aa1f4c4ada589 Clément Lassieur 2024-03-21gnu: make-torbrowser: Make products independent from each other....* gnu/packages/tor-browsers.scm (translation-base-browser): Rename to torbrowser-translation-base. (mullvadbrowser-translation-base): New variable. (translation-tor-browser): Rename to torbrowser-translation-specific. (translation-mullvad-browser): Rename to mullvadbrowser-translation-specific. (make-torbrowser): Add ‘translation-base’ and ‘translation-specific’ parameters and use them. (torbrowser, mullvadbrowser-base): Use the above parameters. (mullvadbrowser): Handle renaming. This allows translation-base-browser (now torbrowser-translation-base) and translation-tor-browser (now torbrowser-translation-specific) to be updated without triggering an update for Mullvad Browser. Change-Id: I2a94636eb6b0531c3a03cdb73c560d68060721ef Clément Lassieur 2024-03-16Merge remote-tracking branch 'savannah/master' into gnome-team...Change-Id: I775274c2693536e2efa36c9abca4c54c5c458e26 Christopher Baines 2024-03-12gnu: tor-browser: Build with newest rust-cbindgen....* gnu/packages/tor-browsers.scm (make-torbrowser)[inputs]: Replace rust-cbindgen-0.24 with rust-cbindgen. Change-Id: I6263a11342cb506c6c271e0360b7273c35be585d Efraim Flashner 2024-03-10Merge branch 'master' into gnome-teamLiliana Marie Prikler 2024-03-08gnu: torbrowser: Update to 13.0.11....* gnu/packages/tor-browsers.scm (%torbrowser-build-date): Update to 20240305132801. (%torbrowser-version): Update to 13.0.11. (%torbrowser-firefox-version): Update to 115.8.0esr-13.0-1-build2. (translation-base-browser): Update to 16211a4b8524d71525f0ea73c07771c634132b30. (translation-tor-browser): Update to 012f643d2d6b04ebf868bf62cdb7ad5b727734f5. Change-Id: I1d5cd4a0d7c3a01f8489db7b69b65a9451ead315 Clément Lassieur 2024-02-25Merge branch 'master' into gnome-teamLiliana Marie Prikler 2024-02-21gnu: mullvadbrowser: Update to 13.0.10....* gnu/packages/tor-browsers.scm (%mullvadbrowser-build-date): Update to 20240213150358. (%mullvadbrowser-version): Update to 13.0.10. (%mullvadbrowser-firefox-version): Update to 115.8.0esr-13.0-1-build1. Change-Id: Ia3c444e893bf7c3299d2d091c6c6578be272a782 Clément Lassieur 2024-02-21gnu: torbrowser: Update to 13.0.10....* gnu/packages/tor-browsers.scm (%torbrowser-build-date): Update to 20240213172118. (%torbrowser-version): Update to 13.0.10. (%torbrowser-firefox-version): Update to 115.8.0esr-13.0-1-build1. (translation-tor-browser): Update to a50fa943d7428ebe6e4e6b09f175e098a97eec63. Change-Id: Idbb708d8bdd5e75bed1423c0748007864f96da0f Clément Lassieur 2024-02-16gnu: icu4c-73: Move it from gnuzilla.scm to icu4c.scm....* gnu/packages/gnuzilla.scm (icu4c-73-promise): Delete variable. (icecat-minimal)[inputs]: Use ‘icu4c-73’ instead of the promise. * gnu/packages/icu4c.scm (icu4c-73): New variable. (make-torbrowser)[inputs]: Use ‘icu4c-73’ instead of the promise. Change-Id: I017e1416b70ecb94313aeb71aa4a0cafdfe0e9ab Signed-off-by: Clément Lassieur <clement@lassieur.org> Ian Eure 2024-02-13Merge branch 'master' into gnome-teamLiliana Marie Prikler 2024-02-05gnu: Add mullvadbrowser....* gnu/packages/tor-browsers.scm (%moz-build-date): Rename to %torbrowser-build-date. (make-torbrowser, torbrowser): Add a ‘build-date’ parameter and use it. (%mullvadbrowser-locales, %mullvadbrowser-build-date, %mullvadbrowser-version, %mullvadbrowser-firefox-version, translation-mullvad-browser, mullvadbrowser-assets, mullvadbrowser-base, mullvadbrowser): New variables. Change-Id: Ie6d48823b3794710f60f0ae201a0297925221f66 Clément Lassieur 2024-02-03gnu: tor-browsers: Use freedesktop module....The shared-mime-info package has been moved from gnome to freedesktop, causing the variable to be unbound where this module is not imported. * gnu/packages/tor-browsers.scm <define-package>: Add #:use-module (gnu packages freedesktop). Fixes: Unbound variable ‘shared-mime-info’. Liliana Marie Prikler 2024-02-02gnu: torbrowser: Stop inheriting Icecat....* gnu/local.mk (GNU_SYSTEM_MODULES): Add packages/tor-browsers.scm. * gnu/packages/gnupg.scm: Remove fix for dependency loop (fixed because we use a new file). * gnu/packages/tor-browsers.scm (mozilla-locale, mozilla-locales, %torbrowser-locales, %moz-build-date, %torbrowser-version, %torbrowser-firefox-version, translation-base-browser, translation-tor-browser, torbrowser-assets, torbrowser): New variables. (make-torbrowser): New procedure, which is a merge of ‘make-torbrowser’ (from tor.scm) with ‘icecat-minimal’ (from gnuzilla.scm). * gnu/packages/tor.scm (%moz-build-date, %torbrowser-version, %torbrowser-firefox-version, %torbrowser-locales, translation-base-browser, translation-tor-browser, torbrowser-assets, torbrowser): Remove variables. Change-Id: I5fcf73e53fe4481a18e13cdeb3515c3dc4430090 Clément Lassieur