aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2021 Charles <charles.b.jackson@protonmail.com>
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages uglifyjs)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (guix build-system node)
  #:use-module (gnu packages node-xyz))

(define-public node-uglify-js
  (package
    (name "node-uglify-js")
    (version "3.19.3")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/mishoo/UglifyJS")
             (commit (string-append "v" version))))
       (file-name (git-file-name name version))
       (sha256
        (base32 "0a3pyf6wnix7v0vdjhag3dd32l4fm2hxhxpjdgr1zfvy3m4d1hmh"))))
    (build-system node-build-system)
    (native-inputs
     (list node-acorn node-semver))
    (home-page "https://lisperator.net/uglifyjs/")
    (synopsis "JavaScript parser / mangler / compressor / beautifier toolkit")
    (description "UglifyJS is a JavaScript compressor/minifier written in
JavaScript.  It also contains tools that allow one to automate working with
JavaScript code: parser, code generator, compressor, mangler, scope analyzer,
tree walker, and tree transformer.")
      (license license:bsd-2)))

(define-public uglifyjs node-uglify-js)
0059d01de92'>gnu: abc: Update to 0.0-3.707442e....* gnu/packages/fpga.scm (abc): Update to 0.0-3.707442e. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Cayetano Santos 2024-10-14gnu: nvc: Update to 1.14.0....* gnu/packages/fpga.scm (nvc): Update to 1.14.0. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Cayetano Santos 2024-09-10gnu: fpga.scm: Sort module imports....* gnu/packages/fpga.scm: Sort package module imports alphabetically. Change-Id: Ic847b7e577287fd711b5258583f2a02925594df2 Efraim Flashner 2024-09-10gnu: verilator: Remove input labels....* gnu/packages/fpga.scm (verilator)[native-inputs]: Remove input labels. Change-Id: Ia3efa473b909540f972f706e24238d6dc2a2dc43 Efraim Flashner 2024-09-10gnu: verilator: Update to 5.028....* gnu/packages/fpga.scm (verilator): Update to 5.028. [native-inputs]: Add cmake-minimal, gdb/pinned, which. [inputs]: Add help2man, python. [arguments]: Remove configure-flags and make-flags. Add a phase to remove hardcoded location of binaries. Add a phase to help the test suite run. Change-Id: I6a07622f8de8067fa767c0118c8f114cf09c3b0d Efraim Flashner 2024-09-10gnu: systemc: Update to 3.0.0....* gnu/packages/fpga.scm (systemc): Update to 3.0.0. [source]: Download using git-fetch. [build-system]: Switch to cmake-build-system. [arguments]: Remove configure-flags. Add test-target. Change-Id: Id5097a4fc8cd5f3c131990cf3596f5fd581be088 Efraim Flashner