aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016, 2017, 2018 Alex Kost <alezost@gmail.com>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages tv)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages image)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xml)
  #:use-module (gnu packages xorg))

(define-public tvtime
  (package
    (name "tvtime")
    (version "1.0.11")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "https://linuxtv.org/downloads/tvtime/tvtime-"
                    version ".tar.gz"))
              (sha256
               (base32
                "1367rl3n6qxwf30lqyz234zpb43s9xjhig3hrvbg7cbqcl8g4fs0"))))
    (build-system gnu-build-system)
    (arguments
     '(#:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'fix-glibc-compatability
           (lambda _
             (substitute* "src/get_media_devices.c"
               (("<sys/stat.h>")
                "<sys/stat.h>\n#include <sys/sysmacros.h>"))
             #t)))))
    (inputs
     (list alsa-lib
           libx11
           libxext
           libxt
           libxtst
           libxinerama
           libxv
           libxxf86vm
           libpng
           libxml2
           freetype
           zlib))
    (native-inputs
     (list pkg-config))
    (home-page "https://tvtime.sourceforge.net")
    (synopsis "Television viewer")
    (description
     "Tvtime processes the input from your video capture card and
displays it on a monitor.  It focuses on a high visual quality.")
    (license license:gpl2+)))
s='msg-avail'>...kiasoc5 2023-04-03gnu: uwufetch: Update to 2.1....Juliana Sims 2023-04-03gnu: thermald: Update to 2.5.2....Jelle Licht 2023-04-03gnu: Add dool....Yovan Naumovski 2023-03-20Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-03-19gnu: atop: Update to 2.8.1....Yovan Naumovski 2023-03-12gnu: doctl: Update to 1.93.1....Matthew James Kraai 2023-03-02Merge remote-tracking branch 'savannah/master' into core-updates...Christopher Baines 2023-02-27gnu: hyfetch: Update to 1.4.7....Hilton Chain 2023-02-26gnu: sudo: Update to 1.9.13p2....Tobias Geerinckx-Rice 2023-02-19gnu: Use HTTPS package home pages wherever possible....Tobias Geerinckx-Rice 2023-02-21gnu: xfel: Update to 1.2.9....LuHui 2023-02-19gnu: hyfetch: Update to 1.4.6....Hilton Chain 2023-02-12gnu: inxi-minimal: Update to 3.3.25-1....Tobias Geerinckx-Rice 2023-02-12gnu: fdupes: Update to 2.2.1....Tobias Geerinckx-Rice 2023-02-12gnu: sudo: Update to 1.9.13p1....Tobias Geerinckx-Rice 2023-02-12gnu: igt-gpu-tools: Update to 1.27.1....Tobias Geerinckx-Rice 2023-02-12gnu: htop: Update to 3.2.2....Tobias Geerinckx-Rice 2023-02-12gnu: nmap: Remove input labels....Tobias Geerinckx-Rice 2023-02-12gnu: nmap: Update to 7.93....Tobias Geerinckx-Rice 2023-02-12gnu: sudo: Update to 1.9.13....Tobias Geerinckx-Rice 2023-02-13gnu: wpa-supplicant: Add netdev group dbus policy....Sergey Trofimov 2023-02-11gnu: doctl: Update to 1.92.1....Matthew James Kraai 2023-02-09gnu: greetd: Use new-style inputs....Felix Lechner 2023-02-09gnu: greetd: Update to 0.9.0....Felix Lechner