aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016, 2017, 2018 Alex Kost <alezost@gmail.com>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages tv)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages image)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xml)
  #:use-module (gnu packages xorg))

(define-public tvtime
  (package
    (name "tvtime")
    (version "1.0.11")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "https://linuxtv.org/downloads/tvtime/tvtime-"
                    version ".tar.gz"))
              (sha256
               (base32
                "1367rl3n6qxwf30lqyz234zpb43s9xjhig3hrvbg7cbqcl8g4fs0"))))
    (build-system gnu-build-system)
    (arguments
     '(#:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'fix-glibc-compatability
           (lambda _
             (substitute* "src/get_media_devices.c"
               (("<sys/stat.h>")
                "<sys/stat.h>\n#include <sys/sysmacros.h>"))
             #t)))))
    (inputs
     (list alsa-lib
           libx11
           libxext
           libxt
           libxtst
           libxinerama
           libxv
           libxxf86vm
           libpng
           libxml2
           freetype
           zlib))
    (native-inputs
     (list pkg-config))
    (home-page "https://tvtime.sourceforge.net")
    (synopsis "Television viewer")
    (description
     "Tvtime processes the input from your video capture card and
displays it on a monitor.  It focuses on a high visual quality.")
    (license license:gpl2+)))
mit/gnu/packages/mpd.scm?id=ac9ccf03a6dabaf385901dd927e2e2de0a9ee0f4'>gnu: mympd: Update to 10.2.4....Bruno Victal 2023-02-23gnu: mpdris2: Remove input labels and add inputs....Simon Streit 2023-02-12gnu: mympd: Update to 10.2.3....Bruno Victal 2023-02-11gnu: mympd: Update to 10.2.2....Bruno Victal 2023-02-05gnu: mpd: Update to 0.23.12....Bruno Victal 2023-02-05gnu: mpd: Add missing inputs....Bruno Victal 2023-02-03gnu: mympd: Update to 10.2.1....Bruno Victal 2023-01-29gnu: mpdevil: Update to 1.10.0...Simon Streit 2023-01-28gnu: mympd: Update to 10.2.0....Bruno Victal 2023-01-08gnu: Switch to default pipewire....Mathieu Othacehe 3792cbe943b5c4d318733d'>gnu: Add rogue....Jakob Kirsch 2023-05-30gnu: warzone2100: Rewrite package arguments to G-expressions....宋文武 2023-05-30gnu: warzone2100: Update to 4.3.5....宋文武 2023-05-14gnu: Rename json-modern-cxx to nlohmann-json....Liliana Marie Prikler 2023-05-11gnu: laby: Add patch for being able to execute game code....Ivana Drazovic 2023-05-11gnu: laby: Make laby function in pure environments....Ivana Drazovic 2023-05-11gnu: laby: Use new package style....Ivana Drazovic 2023-05-08gnu: openttd-engine: Update to 13.1....Yovan Naumovski 2023-05-03gnu: pinball: Update to 0.3.20230219....Eric Bavier 2023-05-03gnu: open-adventure: Update to 1.16....Nicolas Goaziou 2023-05-02gnu: mars: Update to commit 84664cda....Eric Bavier 2023-04-26gnu: gnome-2048: Fix build....Liliana Marie Prikler 2023-04-25Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-04-25gnu: nethack: Update to 3.6.7....Nicolas Goaziou 2023-04-25gnu: slimevolley: Build with gcc-7....Efraim Flashner 2023-04-25gnu: Add deal....Nicolas Goaziou 2023-04-22Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-04-21gnu: Add alienblaster....Yovan Naumovski 2023-04-19gnu: ultrastar-deluxe: Build with ffmpeg-5....Efraim Flashner 2023-04-18gnu: openttd-opengfx: Fix build....Julien Lepiller 2023-04-18gnu: ultrastar-deluxe: Build with ffmpeg-5....Efraim Flashner 2023-04-13gnu: freeciv: Update to 3.0.7....Yovan Naumovski 2023-04-13gnu: minetest: Update to 5.7.0....Parnikkapore 2023-04-09gnu: open-adventure: Update to 1.15....Nicolas Goaziou 2023-04-07gnu: curl-minimal: Remove variable....Bruno Victal 2023-04-03gnu: bambam: Update to 1.2.1....宋文武 2023-04-03gnu: fheroes2: Update to 1.0.2....宋文武 2023-04-02gnu: endless-sky: Update to 0.10.0....Zheng Junjie 2023-03-30gnu: open-adventure: Update to 1.14....Nicolas Goaziou