aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages terraform)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system go))

(define-public terraform-docs
  (package
    (name "terraform-docs")
    (version "0.6.0")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/segmentio/terraform-docs")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "1p6prhjf82qnhf1zwl9h92j4ds5g383a6g9pwwnqbc3wdwy5zx7d"))))
    (build-system go-build-system)
    (arguments
     '(#:import-path "github.com/segmentio/terraform-docs"))
    (synopsis "Generate documentation from Terraform modules")
    (description
     "The @code{terraform-docs} utility can generate documentation describing
the inputs and outputs for modules of the Terraform infrastructure management
tool.  These can be shown, or written to a file in JSON or Markdown formats.")
    (home-page "https://github.com/segmentio/terraform-docs")
    (license license:expat)))
pan class='msg-avail'>...* gnu/packages/haskell-apps.scm (git-annex): Update to 10.20240831. Change-Id: I6204f4a681b0fc1c176bb2da92c2556a018cd412 Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Matthias Riße 2024-09-09gnu: git-annex: Update to 10.20240808....* gnu/packages/haskell-apps.scm (git-annex): Update to 10.20240808. Change-Id: Id9b3b4ace4871cf9ba04404b43784269a9c45daa Signed-off-by: Ludovic Courtès <ludo@gnu.org> Matthias Riße 2024-08-31gnu: raincat: Add 'bash' input for 'wrap-program'....It is required for cross-compilation. * gnu/packages/haskell-apps.scm (raincat)[inputs]: Add 'bash-minimal'. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I43678905da46d4ab6638d2c7744a547d5ee00089 Maxime Devos 2024-08-18gnu: kmonad: Update to 0.4.2-1.07cd1cb....* gnu/packages/haskell-apps.scm (kmonad): Update to 0.4.2-1.07cd1cb. Change-Id: I8a8d36577804d2221b39b430d26e9fd17204c0de Andrew Tropin 2024-08-16gnu: shellcheck: Update to 0.10.0....* gnu/packages/haskell-apps.scm (shellcheck): Update to 0.10.0. [arguments]: Use modern style and make manpage script executable. Change-Id: Id9dd03df4f8f0033dd3fc9a23b0b4d65ea1a73c6 jgart 2024-07-26gnu: kmonad: Update to 0.4.2-0.31c591b....* gnu/packages/haskell-apps.scm (kmonad): Update to 0.4.2-0.31c591b. Change-Id: I3e374285b075e34e7bb4b82d574c4c6305f6b9a7 Andrew Tropin 2024-07-23gnu: Add matterhorn....* gnu/packages/haskell-apps.scm (matterhorn): New variable. Change-Id: I8f83b39fdc5f94251239129814068000fb492336 Romain GARBAGE