aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages terraform)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system go))

(define-public terraform-docs
  (package
    (name "terraform-docs")
    (version "0.6.0")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/segmentio/terraform-docs")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "1p6prhjf82qnhf1zwl9h92j4ds5g383a6g9pwwnqbc3wdwy5zx7d"))))
    (build-system go-build-system)
    (arguments
     '(#:import-path "github.com/segmentio/terraform-docs"))
    (synopsis "Generate documentation from Terraform modules")
    (description
     "The @code{terraform-docs} utility can generate documentation describing
the inputs and outputs for modules of the Terraform infrastructure management
tool.  These can be shown, or written to a file in JSON or Markdown formats.")
    (home-page "https://github.com/segmentio/terraform-docs")
    (license license:expat)))
69a4'>gnu: makepasswd: Add libxcrypt dependency....* gnu/packages/password-utils.scm (makepasswd)[inputs]: Add libxcrypt. Change-Id: I4296a814148b42032c8f66449ea945a37bc768de 宋文武 2024-08-31gnu: passwdqc: Add libxcrypt dependency....* gnu/packages/password-utils.scm (passwdqc)[inputs]: Add libxcrypt. Change-Id: I71e7261170cc433952bcaa0a4a1bdda95cd94d65 宋文武 2024-08-31gnu: password-utils: Add 'bash' input for 'wrap-program'....It is required for cross-compilation. * gnu/packages/password-utils.scm (shroud)[inputs]: Likewise. (assword)[inputs]: Likewise. (password-store)[inputs]: Likewise. (pass-age)[inputs]: Likewise. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I6400ef2a53f9ffe7c5e6690069f58e6a54bf3af6 Maxime Devos 2024-07-23gnu: keepassxc: Update to 2.7.9....* gnu/packages/password-utils.scm (keepassxc): Update to 2.7.9. Change-Id: Ifcdfa5b58e4d7407c270bfa715fb94019015c089 Nicolas Goaziou 2024-06-26gnu: Add rofi-pass-wayland....This variant of rofi-pass swaps out the X-related tools used for Wayland versions and changes the default configuration file to use them. * gnu/packages/password-utils.scm (rofi-pass-wayland): New variable. Change-Id: Ie844fc2f3a7f49fd6322e5418a6944b6b941abce John Kehayias 2024-06-26gnu: rofi-pass: Update to 2.0.2-0.8aa6b92....With no release in over 5 years, update to the most recent commit to include features like Wayland support. Rewrite the package definition to use the makefile, patch paths, and generally improve the style. * gnu/packages/password-utils.scm (rofi-pass): Update to 2.0.2-0.8aa6b92. [origin]: Use git-fetch rather than just the individual script. [build-system]: Switch to gnu-build-system. [arguments]: Remove modules and builder. Disable tests. Add make-flags. <phases>: Add fix-etc-path and wrap-path phases. Remove configure and build. [propagated-inputs]: Move to ... [inputs]: ... here. Add bash-minimal, pwgen, xclip, and xset. Change-Id: Ia03ef46f3b567bc2eb6d1350db3612043f06d94b John Kehayias 2024-06-11gnu: keepassxc: Update to 2.7.8....* gnu/packages/password-utils.scm (keepassxc): Update to 2.7.8. Change-Id: Ibcd4097972ea2878f461044c82784eecd194dd13 Signed-off-by: jgart <jgart@dismail.de> Timotej Lazar 2024-04-06gnu: go-github-com-mattn-go-zglob: Move to golang-xyz....* gnu/packages/golang.scm (go-github-com-mattn-go-zglob): Move from here ... * gnu/packages/golang-xyz.scm: ... to here * gnu/packages/password-utils.scm: Add (gnu packages golang-xyz) module. Change-Id: I3777ff257c6baa91930e141f84f9da94be0634b6 Sharlatan Hellseher