aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages terraform)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system go))

(define-public terraform-docs
  (package
    (name "terraform-docs")
    (version "0.6.0")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/segmentio/terraform-docs")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "1p6prhjf82qnhf1zwl9h92j4ds5g383a6g9pwwnqbc3wdwy5zx7d"))))
    (build-system go-build-system)
    (arguments
     '(#:import-path "github.com/segmentio/terraform-docs"))
    (synopsis "Generate documentation from Terraform modules")
    (description
     "The @code{terraform-docs} utility can generate documentation describing
the inputs and outputs for modules of the Terraform infrastructure management
tool.  These can be shown, or written to a file in JSON or Markdown formats.")
    (home-page "https://github.com/segmentio/terraform-docs")
    (license license:expat)))
/Makefile.am?id=5ce3defed18c204989dceed64d3434ed9f3f1a92'>system: Add (guix build install) module....Ludovic Courtès 2014-05-10Add (guix build syscalls)....Ludovic Courtès 2014-05-07Remove now unneeded (guix build gnome) module....Ludovic Courtès 2014-04-30system: Add (guix build activation)....Ludovic Courtès 2014-04-28Add (guix gexp)....Ludovic Courtès 2014-04-11vm: Add (guix build vm) module....Ludovic Courtès 2014-04-07build: Add 'hydra.gnu.org.pub' to the distribution....Ludovic Courtès 2014-04-05hydra: Add 'qemu-image' job....Ludovic Courtès 2014-03-30Add hydra.gnu.org's narinfo signing public key....Ludovic Courtès 2014-03-30substitute-binary: Support the Signature field of a narinfo file....Nikita Karetnikov 2014-03-27Add (guix svn-download)....Sree Harsha Totakura 2014-03-09Change the default store file name to /gnu/store....Ludovic Courtès 2014-02-21Add (guix git-download)....Ludovic Courtès 2014-02-18Add 'guix system'....Ludovic Courtès 2014-01-24Add 'guix offload' as a daemon build hook....Ludovic Courtès 2013-12-29Add (guix pki)....Ludovic Courtès 2013-12-22Add 'guix archive'....Ludovic Courtès 2013-12-21authenticate: Add test....Ludovic Courtès 2013-12-20daemon: Implement signed archive import/export....Ludovic Courtès 2013-12-20Add (guix pk-crypto)....Ludovic Courtès 2013-12-16pull: Move build code to (guix build pull)....Ludovic Courtès 2013-12-15gnu: gtk+: enable introspection....Cyril Roelandt 2013-12-05build: Work around build problem on systems that lack (gnutls)....Ludovic Courtès 2013-11-01guix package: Allow removal of a specific package output....Ludovic Courtès 2013-11-01Add (guix profiles)....Ludovic Courtès 2013-10-15build: Add 'clean-go' target....Ludovic Courtès