aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2016, 2020 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages synergy)
  #:use-module (guix packages)
  #:use-module ((guix licenses) #:select (gpl2))
  #:use-module (guix git-download)
  #:use-module (guix build-system cmake)
  #:use-module (gnu packages)
  #:use-module (gnu packages avahi)
  #:use-module (gnu packages curl)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages python)
  #:use-module (gnu packages qt)
  #:use-module (gnu packages tls)
  #:use-module (gnu packages xorg)
  #:use-module (srfi srfi-26))

(define-public synergy
  (package
    (name "synergy")
    (version "1.11.1")
    (source
     (origin
      (method git-fetch)
      (uri (git-reference
            (url "https://github.com/symless/synergy-core")
            (commit (string-append "v" version "-stable"))))
      (file-name (git-file-name name version))
      (sha256
       (base32
        "0dn0h3mdqy0mbg4yyhsh4rhvvsssqlknnln3naplc97my10lk2a0"))
      (modules '((guix build utils)))
      (snippet
       ;; Remove unnecessary bundled source and binaries
       '(begin
          (delete-file-recursively "ext/openssl")
          #t))))
    (build-system cmake-build-system)
    (arguments
     `(#:tests? #f ; there is no test target
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'fix-headers
           (lambda* (#:key inputs #:allow-other-keys)
             (setenv "CPLUS_INCLUDE_PATH"
                     (string-append (assoc-ref inputs "avahi")
                                    "/include/avahi-compat-libdns_sd:"
                                    (or (getenv "CPLUS_INCLUDE_PATH") "")))
             #t))
         (add-after 'install 'patch-desktop
           (lambda* (#:key outputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out")))
               (substitute* (string-append out "/share/applications/synergy.desktop")
                 (("/usr") out))
               #t))))))
    (native-inputs
     (list qttools-5))           ; for Qt5LinguistTools
    (inputs
     `(("avahi" ,avahi)
       ("python"  ,python-wrapper)
       ("openssl" ,openssl)
       ("curl"    ,curl)
       ("libxi"   ,libxi)
       ("libx11"  ,libx11)
       ("libxtst" ,libxtst)
       ("qtbase" ,qtbase-5)))
    (home-page "https://symless.com/synergy")
    (synopsis "Mouse and keyboard sharing utility")
    (description
     "Synergy brings your computers together in one cohesive experience; it's
software for sharing one mouse and keyboard between multiple computers on your
desk.")
    (license gpl2)))
commit/gnu/packages/guile.scm?id=24163eea584663568b68e19f364256fc7396b61f'>gnu: guile: Update to 3.0.10....* gnu/packages/guile.scm (guile-3.0-latest): Update to 3.0.10. Change-Id: Id9d58199f1fa3307c94f442c185307d2f4a9ce6f David Thompson 2024-05-01gnu: guile-git: Update to 0.7.0....* gnu/packages/guile.scm (guile-git): Update to 0.7.0. Change-Id: I7a0a9d50a0f8a788963b05029a37ac9450ffa185 Ludovic Courtès 2024-04-30gnu: guile-next: Update to commit 3b76a30....* gnu/packages/guile.scm (guile-next): Update to commit 3b76a30. Change-Id: I9af6593f6a7f2babdac19201bd1be541ea78e8e5 David Thompson 2024-04-30gnu: guile-lzlib: Switch to ‘url-fetch’....Fixes <https://issues.guix.gnu.org/70659>. Fixes a regression introduced in 7cef6b7ba555a9dfaf6d09cb7e112b0df77d5141, which would create a circular dependency on systems lacking “builtin:git-download”. * gnu/packages/guile.scm (guile-lzlib)[source]: Switch to ‘git-fetch’. Reported-by: Peacememories <peacememories@posteo.net> Change-Id: Iad684564d0dc18f0a7a76e1c4c6464ba4f39f2e8 Ludovic Courtès 2024-04-28gnu: guile-lzlib: Update to 0.3.0....Fixes <https://issues.guix.gnu.org/69596>. * gnu/packages/guile.scm (guile-lzlib): Update to 0.3.0. [source]: Switch to ‘git-fetch’. Change-Id: Ic9f8fe2d0ab24b66cfba618840773a3e89aea48c Ludovic Courtès 2024-04-08gnu: guile-next: Update to commit db7efa5....* gnu/packages/guile.scm (guile-next): Update to commit db7efa5. Change-Id: Ia9629b4494b9d8968d9caa1b6c6ce362ee24a24d David Thompson 2024-02-26gnu: guile-git: Depend on libgit2 1.7....* gnu/packages/guile.scm (guile-git)[inputs]: Replace LIBGIT2-1.3 with LIBGIT2-1.7. Change-Id: Ia386f977b0888b7bd9b26443ac6150428fda2155 Ludovic Courtès 2024-02-26gnu: guile-git: Update to 0.6.0....* gnu/packages/guile.scm (guile-git): Update to 0.6.0. [source]: Remove ‘patches’ field. * gnu/packages/patches/guile-git-adjust-for-libgit2-1.2.0.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove it. Change-Id: I49300461389bc24a9802fbda5e374a330ffc3715 Ludovic Courtès 2024-02-12gnu: Add guile-bzip2....* gnu/packages/guile.scm (guile-bzip2): New package. Change-Id: I450395f6699d4b622c8043c17a197c799255a9bb Timothy Sample 2024-02-02gnu: guile-next: Don't patch posix-spawn for the hurd....As the patch doesn't apply. * gnu/packages/guile.scm (guile-3.0)[arguments]: Remove 'patch-posix-spawn-usage' phase. Change-Id: I17f4878f7bbd74b71e559b16dc68ccf68c639987 Christopher Baines 2024-01-29gnu: guile-next: Update to commit fb1f5e2....* gnu/packages/guile.scm (guile-next): Update to commit fb1f5e2. Change-Id: Ia699bf7bf950b8780366146508eec566a738fb80 David Thompson