aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2023, 2024 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages sycl)
  #:use-module (guix build-system cmake)
  #:use-module (guix git-download)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (gnu packages)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages llvm)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages python)
  #:use-module (gnu packages rocm)
  #:use-module (gnu packages vulkan))

;; This file adds SYCL implementation related packages. Due to the fact that
;; SYCL devices like GPU are not available during build (store environment),
;; tests that require such devices are all disabled.
;; Check https://lists.gnu.org/archive/html/guix-devel/2018-04/msg00293.html

(define-public adaptivecpp
  (package
    (name "adaptivecpp")
    (version "24.06.0")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/AdaptiveCpp/AdaptiveCpp/")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "1d7ld2azk45sv7124zkrkj1nfkmq0dani5zlalyn8v5s7q6vdxjc"))))
    (build-system cmake-build-system)
    (native-inputs (list clang-15 llvm-15 python spirv-tools))
    (inputs (list boost rocm-opencl-runtime spirv-headers))
    (arguments `(#:tests? #f)) ; no tests
    (home-page "https://adaptivecpp.github.io/")
    (synopsis "Implementation of the SYCL programming language for accelerators")
    (description
     "AdaptiveCpp is aImplementation of SYCL and C++ standard parallelism
for CPUs and GPUs from all vendors, with independent, community-driven
compiler for C++-based heterogeneous programming models")
    (license license:bsd-2)))

(define-public opensycl
  (deprecated-package "opensycl" adaptivecpp))
cd1721d9b6299dc44bc7bb1a94e Leo Famulari 2024-01-09Authorize Oleg (Sharlatan)'s key....* .guix-authorizations (sharlatan): Register PGP key fingerprint. Change-Id: I0d20e50a37971237721964852a404c5cf136f0be Maxim Cournoyer 2023-07-23.guix-authorizations: Update lfam's key....* .guix-authorizations: Update lfam's signing key fingerprint. Change-Id: Ic34f364dfc46e403e1d431e5860a63b36143b6f3 Leo Famulari 2023-08-13.guix-authorizations: Authorise Hilton Chain....* .guix-authorizations (hako): Add OpenPGP key fingerprint. Tobias Geerinckx-Rice 2023-06-14.guix-authorizations: Remove Lars-Dominik Braun’s professional key....* .guix-authorizations: Remove from lbraun (professional). Lars-Dominik Braun 2023-05-15.guix-authorizations: Authorize Jorge Gomez....* .guix-authorizations (jgart): Add OpenPGP key fingerprint. Maxim Cournoyer 2023-05-11.guix-authorizations: Authorize Josselin Poiret....* .guix-authorizations (jpoiret): Add OpenPGP key fingerprint. Maxim Cournoyer 2023-05-11.guix-authorizations: Authorize Simon Tournier....* .guix-authorizations (zimoun): Add OpenPGP key fingerprint. Maxim Cournoyer 2023-03-24.guix-authorizations: Remove Paul Garlick due to inactivity....* .guix-authorizations: Remove from pgarlick. Leo Famulari 2023-03-24.guix-authorizations: Remove Jakub Kądziołka due to inactivity....* .guix-authorizations: Remove niedzejkob. Leo Famulari 2023-03-24.guix-authorizations: Remove Chris Marusich due to inactivity....* .guix-authorizations: Remove marusich. Leo Famulari 2023-03-24.guix-authorizations: Remove Brice Waegeneire due to inactivity....* .guix-authorizations: Remove bricewge. Leo Famulari 2023-03-24.guix-authorizations: Remove Alex Kost due to inactivity....* .guix-authorizations: Remove alezost. Leo Famulari 2022-12-11.guix-authorizations: Authorise John Kehayias....* .guix-authorizations (podiki): Add OpenPGP key fingerprint. Tobias Geerinckx-Rice 2022-11-08authorizations: Remove old key for "davexunit"....* .guix-authorizations ("davexunit"): Remove. ("davexunit (2nd)"): Rename to "dthompson". David Thompson 2022-08-11.guix-authorizations: Authorize Andrew Tropin's subkey instead....Addresses <https://issues.guix.gnu.org/57091> for now. * .guix-authorizations (abcdw): Use signing subkey instead of primary. Tobias Geerinckx-Rice 2022-08-05.git-authorizations: Authorize Andrew Tropin....* .git-authorizations (abcdw): Add OpenPGP key fingerprint. Efraim Flashner