aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2018, 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2019, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages swig)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix licenses)
  #:use-module (guix build-system gnu)
  #:use-module (guix utils)
  #:use-module (gnu packages)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages guile)
  #:use-module (gnu packages pcre)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages python))

(define-public swig
  (package
    (name "swig")
    (version "4.0.2")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://sourceforge/" name "/" name "/"
                                 name "-" version "/"
                                 name "-" version ".tar.gz"))
             (sha256
              (base32
               "1z06m5zv87mha6hvys1iay810ghc1jngilfby1ms2n4d1mryjfym"))
             ;; Remove with next release.
             (patches (search-patches "swig-support-gcc-12.patch"))))
    (build-system gnu-build-system)
    (native-inputs (list boost
                         `(,pcre "bin") ;for 'pcre-config'
                         ;; The following are for tests and examples:
                         guile-3.0
                         perl))
                     ;;("python" ,python-wrapper)
    (inputs (list pcre))
    (arguments (list #:tests? (not (or (target-hurd?)
                                       (%current-target-system)))))
    (home-page "https://swig.org/")
    (synopsis
     "Interface compiler that connects C/C++ code to higher-level languages")
    (description
     "SWIG is an interface compiler that connects programs written in C and
C++ with languages such as Perl, Python, Ruby, Scheme, and Tcl.  It works by
taking the declarations found in C/C++ header files and using them to generate
the wrapper code that scripting languages need to access the underlying C/C++
code.  In addition, SWIG provides a variety of customization features that let
you tailor the wrapping process to suit your application.")

    ;; See http://www.swig.org/Release/LICENSE for details.
    (license gpl3+)))

(define-public swig-next
  ;; a number of packages using swig do not build with this version
  ;; so we need to keep swig 4.0.2 above and place the current release
  ;; as swig-next
  (package
    (inherit swig)
    (name "swig")
    (version "4.2.1")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://sourceforge/" name "/" name "/"
                                 name "-" version "/"
                                 name "-" version ".tar.gz"))
              (sha256
               (base32
                "1n5pb77hwadjpbqgqn28i5v4cp94ar19wmv9vk6v4j6hw9a5617s"))))
    (inputs (list pcre2))))
.* gnu/packages/password-utils.scm (tessen): Update to 2.2.1. [arguments]<#:make-flags>: Set DESTDIR. [license]: License has been changed to GPL2-only. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Hilton Chain 2023-07-16gnu: yapet: Fix documentation directory....* gnu/packages/password-utils.scm (yapet)[arguments]: Add missing stroke. Tobias Geerinckx-Rice 2023-07-16gnu: yapet: Update to 2.6....* gnu/packages/password-utils.scm (yapet): Update to 2.6. Tobias Geerinckx-Rice 2023-07-16gnu: passwdqc: Update to 2.0.3....* gnu/packages/password-utils.scm (passwdqc): Update to 2.0.3. Tobias Geerinckx-Rice 2023-07-16gnu: otpclient: Update to 3.1.9....* gnu/packages/password-utils.scm (otpclient): Update to 3.1.9. Tobias Geerinckx-Rice 2023-07-16gnu: hydra: Update to 9.5....* gnu/packages/password-utils.scm (hydra): Update to 9.5. Tobias Geerinckx-Rice 2023-07-11gnu: keepassxc: Fix broken home-page url....* gnu/packages/password-utils.scm (keepassxc): Fix broken url. [home-page]: Fix broken url. jgart 2023-07-05gnu: Add passwdqc....* gnu/packages/password-utils.scm (passwdqc): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> flabbergasted 2023-07-01gnu: password-store: Fix program name in usage and tmpdir....* gnu/packages/password-utils.scm (password-store): Fix program name in usage and tmpdir. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Tobias Kortkamp 2023-06-14gnu: browserpass-native: Use new package style....* gnu/packages/password-utils.scm (browserpass-native)[arguments]: Use gexps. Drop trailing #t from phases. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Timotej Lazar 2023-06-14gnu: browserpass-native: Update to 3.1.0....* gnu/packages/password-utils.scm (browserpass-native): Update to 3.1.0. [inputs]: Add bash-minimal. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Timotej Lazar 2023-06-11gnu: Add otpclient....* gnu/packages/password-utils.scm (otpclient): New variable. Liliana Marie Prikler 2023-06-04gnu: keepassxc: Update to 2.7.5....* gnu/packages/password-utils.scm (keepassxc): Update to 2.7.5. Efraim Flashner 2023-03-21gnu: ssh-to-age: Update to 1.1.2....* gnu/packages/password-utils.scm (ssh-to-age): Update to 1.1.2. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Jack Hill 2023-03-21gnu: pass-age: Update to 1.7.4a1....* gnu/packages/password-utils.scm (pass-age): Update to 1.7.4a1. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Jack Hill