aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2018, 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2019, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages swig)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix licenses)
  #:use-module (guix build-system gnu)
  #:use-module (guix utils)
  #:use-module (gnu packages)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages guile)
  #:use-module (gnu packages pcre)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages python))

(define-public swig
  (package
    (name "swig")
    (version "4.0.2")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://sourceforge/" name "/" name "/"
                                 name "-" version "/"
                                 name "-" version ".tar.gz"))
             (sha256
              (base32
               "1z06m5zv87mha6hvys1iay810ghc1jngilfby1ms2n4d1mryjfym"))
             ;; Remove with next release.
             (patches (search-patches "swig-support-gcc-12.patch"))))
    (build-system gnu-build-system)
    (native-inputs (list boost
                         `(,pcre "bin") ;for 'pcre-config'
                         ;; The following are for tests and examples:
                         guile-3.0
                         perl))
                     ;;("python" ,python-wrapper)
    (inputs (list pcre))
    (arguments (list #:tests? (not (or (target-hurd?)
                                       (%current-target-system)))))
    (home-page "https://swig.org/")
    (synopsis
     "Interface compiler that connects C/C++ code to higher-level languages")
    (description
     "SWIG is an interface compiler that connects programs written in C and
C++ with languages such as Perl, Python, Ruby, Scheme, and Tcl.  It works by
taking the declarations found in C/C++ header files and using them to generate
the wrapper code that scripting languages need to access the underlying C/C++
code.  In addition, SWIG provides a variety of customization features that let
you tailor the wrapping process to suit your application.")

    ;; See http://www.swig.org/Release/LICENSE for details.
    (license gpl3+)))

(define-public swig-next
  ;; a number of packages using swig do not build with this version
  ;; so we need to keep swig 4.0.2 above and place the current release
  ;; as swig-next
  (package
    (inherit swig)
    (name "swig")
    (version "4.2.1")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://sourceforge/" name "/" name "/"
                                 name "-" version "/"
                                 name "-" version ".tar.gz"))
              (sha256
               (base32
                "1n5pb77hwadjpbqgqn28i5v4cp94ar19wmv9vk6v4j6hw9a5617s"))))
    (inputs (list pcre2))))
nts]<#:test-flags>: Disable failing test (requires network connection). Change-Id: I7273c4f0bcc3b8cf3d34633a0d6c1df4d76d9170 Signed-off-by: jgart <jgart@dismail.de> Nicolas Graves 2024-09-03gnu: python-httpx: Fix tests....* gnu/packages/python-web.scm (python-httpx)[native-inputs]: Add nss-certs-for-test. Change-Id: If8e98564e44a2e5e7bc520c31553aa83bc597946 John Kehayias 2024-09-03gnu: python-geventhttpclient: Fix tests....Fixes <https://issues.guix.gnu.org/72950>. * gnu/packages/python-web.scm (python-geventhttpclient)[native-inputs]: Add nss-certs-for-test. Reported-by: Dr. Arne Babenhauserheide <arne_bab@web.de> Change-Id: I22d0774a88b91e0d33191c0dea5b1aaafb992301 Guillaume Le Vaillant 2024-09-03gnu: python-httpcore: Fix tests....* gnu/packages/python-web.scm (python-httpcore)[native-inputs]: Add nss-certs-for-test. Change-Id: I1e1b2f067e672278f86389d5f7b686a45715f861 John Kehayias 2024-09-03gnu: python-google-auth: Update to 2.34.0....* gnu/packages/python-web.scm (python-google-auth): Update to 2.34.0. [origin]: Update pypi-uri. Change-Id: I56d88c29645d780c5555d374ca81e5f7834360be John Kehayias 2024-09-03gnu: python-google-auth: Fix tests....* gnu/packages/python-web.scm (python-google-auth)[native-inputs]: Add nss-certs-for-test. Change-Id: Ia12e98de8c2c8d335b98cef941692611c76ad2fa John Kehayias 2024-08-31gnu: Add nss-certs-for-test....* gnu/packages/certs.scm (nss-certs-for-test): New variable. * gnu/packages/python-web.scm (python-requests-next)[native-inputs]: Add it. Change-Id: Id808e058835556717a6585ecd86dd14d0d2a5039 Zheng Junjie