aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020, 2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2021 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2022 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2023 Parnikkapore <poomklao@yahoo.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages stenography)
  #:use-module (guix build-system python)
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module (guix git-download)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (gnu packages)
  #:use-module (gnu packages bash)
  #:use-module (gnu packages check)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages libusb)
  #:use-module (gnu packages python)
  #:use-module (gnu packages python-check)
  #:use-module (gnu packages python-xyz)
  #:use-module (gnu packages qt)
  #:use-module (gnu packages wxwidgets))

(define-public python-plover-stroke
  (package
    (name "python-plover-stroke")
    (version "1.1.0")
    (source (origin
              (method url-fetch)
              (uri (pypi-uri "plover_stroke" version))
              (sha256
               (base32
                "0lyifam9xqpx2jzqcbah84sv909n4g2frm7pd5gvcrpf98zv40yy"))))
    (build-system python-build-system)
    (native-inputs (list python-pytest))
    (home-page "https://github.com/benoit-pierre/plover_stroke")
    (synopsis "Stroke handling helper library for Plover")
    (description "This package provides a helper class for working with steno strokes.")
    (license license:gpl2+)))

(define-public plover
  (package
    (name "plover")
    (version "4.0.0.dev12")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/openstenoproject/plover")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "0vk6nh2gpn7f7rv2spi2a7n3m0d9kaan6r22mx3vwxprpbvrkbm8"))))
    (build-system python-build-system)
    (arguments
     (list
      #:phases
      #~(modify-phases %standard-phases
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
                (invoke "python" "-m" "pytest"
                        "-p" "pytest-qt"
                        "-p" "xvfb"
                        "test"
                        ;; FIXME: Ignore failing test.
                        "--ignore" "test/gui_qt/test_dictionaries_widget.py"))))
          ;; Ensure that icons are found at runtime.
          (add-after 'install 'wrap-executable
            (lambda* (#:key inputs #:allow-other-keys)
              (wrap-program (string-append #$output "/bin/plover")
                `("QT_PLUGIN_PATH" prefix
                  (,(search-input-directory inputs "/lib/qt5/plugins/")))
                `("LD_LIBRARY_PATH" prefix
                  (,(string-append #$(this-package-input "dbus") "/lib")))))))))
    (native-inputs
     (list python-babel
           python-mock
           python-pytest
           python-pytest-qt
           python-pytest-xvfb))
    (inputs
     (list bash-minimal
           dbus
           python-appdirs
           python-dbus
           python-hidapi
           python-plover-stroke
           python-pyqt
           python-pyserial
           python-rtf-tokenize
           python-wcwidth
           python-xlib
           qtsvg-5))
    (home-page "https://www.openstenoproject.org/plover/")
    (synopsis "Stenography engine")
    (description
     "Plover (rhymes with @emph{lover}) is a desktop application that
allows anyone to use stenography to write on their computer, up to
speeds of 200WPM and beyond.")
    (license license:gpl2+)))

0687'>gnu: gdb: Apply cross-build fix without changing the native variant....Commit 76129cd3edb1eb62778344de0b1b44365f82ee06 accidentally changed the gdb derivation, causing too many rebuilds for the 'master' branch. * gnu/packages/gdb.scm (gdb-9.1)[arguments]: Only apply cross-build fix when cross-compiling. Marius Bakke 2020-06-27gnu: Add gdb-minimal....* gnu/packages/gdb.scm (gdb-minimal): New variable. Jan (janneke) Nieuwenhuizen 2020-06-26gnu: gdb: Add support for the Hurd....* gnu/packages/gdb.scm (gdb-9.1)[native-inputs]: When compiling for the Hurd, add required build dependency mig. ["arguments"]: Add "binutils" fall-back lookup in native-inputs for cross-builds. * gnu/packages/patches/gdb-hurd.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gdb.scm (gdb-9.2): Use it. Jan (janneke) Nieuwenhuizen 2020-05-29Merge branch 'master' into stagingMarius Bakke 2020-05-28gnu: gdb: Add version 9.2....* gnu/packages/gdb.scm (gdb-9.2): New variable. Ludovic Courtès 2020-05-26Merge branch 'master' into stagingMarius Bakke 2020-04-04gnu: gdb: Make some inputs native....* gnu/packages/gdb.scm (gdb)[inputs]: Move dejagnu from here... [native-inputs]: ...to here. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com> Vincent Legoll 2020-03-18gnu: gdb: Remove duplicate input....* gnu/packages/gdb.scm (gdb-9.1)[inputs]: Remove PYTHON. Marius Bakke 2020-02-14gnu: Remove gdb@8.3....* gnu/packages/gdb.scm (gdb-8.3): Rename to ... (gdb-9.1): ... this. Update to 9.1. [properties]: Remove. [inputs]: Add SOURCE-HIGHLIGHT. [arguments]: Add #:out-of-source?. (gdb-8.2): Inherit from GDB-9.1. (gdb): Set to GDB-9.1. Marius Bakke 2020-02-11gnu: gdb: Update to 9.1....* gnu/packages/gdb.scm (gdb/next): Update to 9.1. Ludovic Courtès 2020-01-30gnu: gdb: Add separate variant with source highlighting support....This partially reverts commit 480b3279fd8f937fac986a88592ee5cb968ab3ff in order to prevent a huge rebuild. * gnu/packages/gdb.scm (gdb-8.3)[properties]: New field. [inputs]: Remove SOURCE-HIGHLIGHT. * gnu/packages/gdb.scm (gdb-8.2)[inputs]: Remove. (gdb/next): New public variable. Marius Bakke 2020-01-30gnu: gdb: Add dependency on source-highlight....* gnu/packages/gdb.scm (gdb-8.3)[inputs]: Add SOURCE-HIGHLIGHT. (gdb-8.2)[inputs]: New field. Ludovic Courtès 2019-10-18gnu: rust: Use GDB 8.2 for tests....* gnu/packages/gdb.scm (gdb-8.2): New public variable. * gnu/packages/rust.scm (rust-1.27)[native-inputs]: Use GDB-8.2 instead of GDB. Marius Bakke 2019-10-12gnu: Remove GDB@8.2....* gnu/packages/gdb.scm (gdb-8.2): Rename to ... (gdb-8.3): ... this. Update to 8.3.1. (gdb): Refer to GDB-8.3. Marius Bakke 2019-09-23gnu: gdb-8.3: Update to 8.3.1....* gnu/packages/gdb.scm (gdb-8.3): Update to 8.3.1. Efraim Flashner 2019-05-13gnu: gdb: Add version 8.3....* gnu/packages/gdb.scm (gdb): Rename to... (gdb-8.2): ... this. (gdb-8.3): New variable. (gdb): Define as an alias for GDB-8.2. Ludovic Courtès 2019-02-10gnu: gdb: Update to 8.2.1....* gnu/packages/gdb.scm (gdb): Update to 8.2.1. Marius Bakke 2018-09-07gnu: gdb: Update to 8.2....* gnu/packages/gdb.scm (gdb): Update to 8.2. Ludovic Courtès 2018-08-24gnu: gdb: Update to 8.1.1....* gnu/packages/gdb.scm (gdb): Update to 8.1.1. Ludovic Courtès 2018-04-12gnu: gdb: Return #t from all phases....* gnu/packages/gdb.scm (gdb)[arguments]: Return #t from all phases. Mark H Weaver 2018-01-31gnu: gdb: Update to 8.1....* gnu/packages/gdb.scm (gdb): Update to 8.1. Ludovic Courtès