aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Li-cheng (Andy) Tai <atai@atai.org>
;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages squirrel)
  #:use-module (gnu packages)
  #:use-module (gnu packages cmake)
  #:use-module (gnu packages sphinx)
  #:use-module (guix build-system cmake)
  #:use-module (guix download)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix build utils)
  #:use-module (guix packages)
  #:use-module (guix utils))

(define-public squirrel
  (package
    (name "squirrel")
    (version "3.1")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://sourceforge/squirrel/squirrel3/"
                                  "squirrel " version " stable/squirrel_"
                                  (string-join (string-split version #\.) "_")
                                  "_stable.tar.gz"))
              (file-name (string-append name "-" version ".tar.gz"))
              (sha256
               (base32
                "1jyh1523zrrnh9swanfrda0s14mvwc9431dh07g0nx74hbxsfia8"))))
    (build-system cmake-build-system)
    (arguments
     '(#:configure-flags '("-DDISABLE_STATIC=ON")
       #:tests? #f ; no tests
       #:phases
       (modify-phases %standard-phases
         (add-after 'install 'install-documentation
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (doc-dir (string-append out "/share/doc/squirrel")))
               (for-each
                (lambda (file)
                  (install-file (string-append "../squirrel3/" file) doc-dir))
                '("COPYRIGHT" "HISTORY" "README"
                  "doc/sqstdlib3.pdf" "doc/squirrel3.pdf")))
             #t))
         (add-after 'install 'install-headers
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (include-dir (string-append out "/include/squirrel")))
               (mkdir-p include-dir)
               (for-each
                (lambda (header-file)
                  (copy-recursively header-file
                                    (string-append include-dir
                                                   "/"
                                                   (basename header-file))))
                (find-files "../squirrel3/include")))
             #t)))))
    (native-inputs
     `(("cmake" ,cmake-minimal)
       ("python-sphinx" ,python-sphinx)))
    (home-page "https://squirrel-lang.org/")
    (synopsis "High level imperative, object-oriented programming language")
    (description
     "Squirrel is a high level imperative, object-oriented programming
language, designed to be a light-weight scripting language that fits in the
size, memory bandwidth, and real-time requirements of applications like video
games.")
    (license license:expat)))
2017-10-22gexp: Add 'file-union'....Ludovic Courtès 2017-10-12services: cleanup: Remove Shadow lock files from /etc....Ludovic Courtès 2017-09-22services: network-manager: Add support for VPN plug-ins....Ludovic Courtès 2017-09-16services: Add 'fold-service-types'....Ludovic Courtès 2017-09-16services: Add a description and location for each service type....Ludovic Courtès 2017-07-11services: Make error message less scary....Ludovic Courtès 2017-05-03ui: Rename '_' to 'G_'....Ludovic Courtès 2017-04-16services: Service types can now specify a default value for instances....Ludovic Courtès 2017-04-16services: 'service-parameters' becomes 'service-value'....Ludovic Courtès 2017-04-13services: Define '%linux-bare-metal-service' using 'simple-service'....Ludovic Courtès 2017-03-10services: Create /var/log upon activation....Christopher Baines 2017-02-08services: Add 'special-files-service-type'....Ludovic Courtès 2017-01-24services: Create /var/log/wtmp upon activation....Ludovic Courtès 2017-01-19services: Create /var/run/utmpx upon activation....Ludovic Courtès 2017-01-16services: Export 'service-extension' procedures....Christopher Baines 2016-12-11services: Activate system prior to services....Christopher Baines 2016-09-20services: Use 'source-module-closure' for (gnu build activation)....Ludovic Courtès 2016-09-19services: Add 'simple-service'....Ludovic Courtès 2016-07-12gnu: Use 'gexp->file' in conjunction with 'with-imported-modules'....Ludovic Courtès 2016-07-12gnu: Switch to 'with-imported-modules'....Ludovic Courtès 2016-06-20services: Add 'gc-root-service-type'....Ludovic Courtès 2016-03-15doc: Clarify and consolidate modify-services documentation....Chris Marusich 2016-03-07services: Use 'packages->manifest' in 'packages->profile-entry'....宋文武 2016-02-08file-systems: Spawn a Bournish REPL upon fsck failure....Ludovic Courtès 2016-02-03services: 'file-union' makes sure each source file exists....Ludovic Courtès 2016-01-29services: Rename 'dmd' services to 'shepherd'....Alex Kost 2016-01-06services: cleanup-service: Catch 'system-error' instead of everything....Ludovic Courtès 2016-01-05services: Move /tmp cleanup to a separate service....Ludovic Courtès 2016-01-05services: boot: Reinstate /tmp and /var/run deletion....Ludovic Courtès