aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2023 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages sourcehut)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix utils)
  #:use-module (guix packages)
  #:use-module (guix gexp)
  #:use-module (guix git-download)
  #:use-module (guix build-system pyproject)
  #:use-module (gnu packages check)
  #:use-module (gnu packages databases)
  #:use-module (gnu packages markup)
  #:use-module (gnu packages monitoring)
  #:use-module (gnu packages python-build)
  #:use-module (gnu packages python-check)
  #:use-module (gnu packages python-crypto)
  #:use-module (gnu packages python-web)
  #:use-module (gnu packages python-xyz)
  #:use-module (gnu packages))

(define-public python-core-sr-ht
  (package
    (name "python-core-sr-ht")
    (version "0.69.15")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://git.sr.ht/~sircmpwn/core.sr.ht")
             (commit version)
             (recursive? #true)))
       (file-name (git-file-name name version))
       (sha256
        (base32
         "00d633lmdiqamyv24szmd441dhkjh1n1qkvf47vn57da0z1rxp2g"))))
    (build-system pyproject-build-system)
    (arguments
     (list
      #:tests? #false                   ;there are none
      #:phases
      #~(modify-phases %standard-phases
          (add-after 'unpack 'set-version
            (lambda _ (setenv "PKGVER" #$version))))))
    (propagated-inputs
     (list python-alembic
           python-beautifulsoup4
           python-bleach
           python-celery
           python-cryptography
           python-flask
           python-humanize
           python-markdown
           python-mistletoe
           python-prometheus-client
           python-psycopg2
           python-pygments
           python-redis
           python-requests
           python-sqlalchemy
           python-sqlalchemy-utils))
    (native-inputs (list python-setuptools python-wheel))
    (home-page "https://git.sr.ht/~sircmpwn/core.sr.ht")
    (synopsis "Shared code for all sourcehut projects")
    (description
     "This package contains code shared among all sr.ht projects.")
    (license license:bsd-3)))

(define-public python-scm-sr-ht
  (package
    (name "python-scm-sr-ht")
    (version "0.22.23")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://git.sr.ht/~sircmpwn/scm.sr.ht")
             (commit version)))
       (file-name (git-file-name name version))
       (sha256
        (base32
         "1p1nlwqfqfb89nky8sp4jh4vjnh8fm2mdx8inziqs3898qw1v7yk"))))
    (build-system pyproject-build-system)
    (arguments
     (list
      #:tests? #false                   ;there are none
      #:phases
      #~(modify-phases %standard-phases
          (add-after 'unpack 'set-version
            (lambda _ (setenv "PKGVER" #$version))))))
    (propagated-inputs
     (list python-core-sr-ht))
    (native-inputs (list python-setuptools python-wheel))
    (home-page "https://git.sr.ht/~sircmpwn/scm.sr.ht")
    (synopsis "Shared support code for sr.ht source control services")
    (description
     "This package provides shared support code for sr.ht source control
services.")
    (license license:agpl3)))
d=b096b939f74913cfed5ed3efb5701a9132854760'>gnu: lightdm: Apply patch to fix color depth issue with VNC....* gnu/packages/patches/lightdm-vnc-color-depth.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/display-managers.scm (lightdm): Apply it. Maxim Cournoyer 2022-08-28gnu: lightdm: Apply patch to allow using VNC options....* gnu/packages/patches/lightdm-arguments-ordering.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/display-managers.scm (lightdm): Apply it. Maxim Cournoyer 2022-08-28gnu: lightdm: Apply patch to fix a problem with VNC integration....* gnu/packages/patches/lightdm-vncserver-check.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/display-managers.scm (lightdm): Apply it. Maxim Cournoyer 2022-08-28gnu: lightdm-gtk-greeter: Adjust --enable-at-spi-command value....* gnu/packages/display-managers.scm (lightdm-gtk-greeter) [configure-flags]: Add the '--launch-immediately' option to the at-spi-bus-launcher to match what is used in the source. Maxim Cournoyer 2022-08-28gnu: lightdm-gtk-greeter: Adjust default config file path....* gnu/packages/display-managers.scm (lightdm-gtk-greeter) [phases]{customize-default-config-path}: New phase. Maxim Cournoyer 2022-08-28gnu: lightdm-gtk-greeter: Enable libklavier support....* gnu/packages/display-managers.scm (lightdm-gtk-greeter) [configure-flags]: Add '--with-libxklavier'. [inputs]: Add libxklavier. Maxim Cournoyer 2022-08-28gnu: lightdm-gtk-greeter: Use the glib-or-gtk-wrap phase as-is....* gnu/packages/display-managers.scm (lightdm-gtk-greeter) [configure-flags]: Install binaries to bin/, so the wrap phase of glib-or-gtk handles them. [phases]{wrap-program}: Delete. {custom-wrap}: New phase, wrapping the wrapper with a few extra environment variables. Maxim Cournoyer 2022-08-28gnu: lightdm-gtk-greeter: Add GDK_PIXBUF_MODULE_FILE to wrapper....* gnu/packages/display-managers.scm (lightdm-gtk-greeter) [build-system]: Use glib-or-gtk-build-system. [phases]{wrap-program}: Add GDK_PIXBUF_MODULE_FILE to wrapper. [inputs]: Add librsvg. Maxim Cournoyer 2022-08-05gnu: lightdm: Add bash-minimal as an input....Suggested by 'guix lint'. * gnu/packages/display-managers.scm (lightdm)[inputs]: Add BASH-MINIMAL. Replace COREUTILS by COREUTILS-MINIMAL. Ludovic Courtès 2022-08-03gnu: lightdm-gtk-greeter: Set XCURSOR_PATH in wrapper....* gnu/packages/display-managers.scm (lightdm-gtk-greeter) [phases]{wrap-program}: Set XCURSOR_PATH to the current system share/icons. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> L p R n d n 2022-08-03gnu: lightdm-gtk-greeter: Disable indicator services....* gnu/packages/display-managers.scm (lightdm-gtk-greeter) [configure-flags]: Add '--disable-indicator-services-command'. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> L p R n d n 2022-08-03gnu: lightdm-gtk-greeter: Use gexps and new style inputs....* gnu/packages/display-managers.scm (lightdm-gtk-greeter)[arguments]: Use gexps. [configure-flags]: Use search-input-file. [phases]{fix-.desktop-file}: Likewise. {wrap-program}: Use search-input-file and this-package-input. [inputs]: Use new style. Add glib. Maxim Cournoyer 2022-08-03gnu: lightdm: Update to 1.32.0....* gnu/packages/display-managers.scm (lightdm): Update to 1.32.0. Maxim Cournoyer 2022-08-03gnu: lightdm: Enable XDMCP support....* gnu/packages/display-managers.scm (lightdm)[inputs]: Add libxdmcp. Maxim Cournoyer 2022-08-03gnu: lightdm: Build AccountsService files....* gnu/packages/display-managers.scm (lightdm) [native-inputs]: Add accountsservice. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> L p R n d n 2022-08-03gnu: lightdm: Install documentation....* gnu/packages/display-managers.scm (lightdm) [configure-flags]: Add --enable-gtk-doc. Maxim Cournoyer 2022-07-31gnu: qttools: Rename to qttools-5....Automated with: git grep -l qttools | xargs sed 's/\bqttools\b/\0-5/g' -i git checkout NEWS Maxim Cournoyer 2022-07-31gnu: qtquickcontrols2: Rename to qtquickcontrols2-5....Automated via: git grep -l qtquickcontrols2 | xargs sed 's/\bqtquickcontrols2\b/\0-5/g' -i git checkout NEWS Maxim Cournoyer 2022-07-31gnu: qtquickcontrols: Rename to qtquickcontrols-5....Automated via: git grep -l qtquickcontrols | xargs sed 's/\bqtquickcontrols\b/\0-5/g' -i git checkout NEWS Maxim Cournoyer 2022-07-31gnu: qtdeclarative: Rename to qtdeclarative-5....Automated via the following commands: git grep -l '\bqtdeclarative\b' | xargs sed -E 's/qtdeclarative/\0-5/g' -i git checkout NEWS Maxim Cournoyer 2022-07-31gnu: qtsvg: Rename variable to qtsvg-5....This is in preparation of the qtsvg update to version 6. This change was automated via the following command: git grep -l '\bqtsvg\b' | xargs sed 's/qtsvg/qtsvg-5/g' -i Maxim Cournoyer 2022-06-08gnu: lightdm: Fix build....This is a follow-up to commit 26876b66001a1dc45ee6d05015fddd7f5a88676e, migrate the package from Python 2 to Python 3 (but left some commented inputs for tests, breaking the build). * gnu/packages/display-managers.scm (lightdm)[native-inputs]: Un-comment python-wrapper and python-pygobject. Maxim Cournoyer 2022-05-31gnu: lightdm: Update to 1.30.0-0.b7fc321....* gnu/packages/display-managers.scm (lightdm): Update to 1.30.0-0.b7fc321. [source]: Use git. [configure-flags]: Add CFLAGS=-Wno-error=missing-prototypes. [phases]: Delete trailing #t. {fix-paths}: Use search-input-file. [inputs]: Add coreutils. [native-inputs]: Use new style. Replace python-2 by python-wrapper and python2-pygobject by python-pygobject. Add autoconf, automake, gtk-doc, libtool, which and yelp-tools. Maxim Cournoyer 2021-12-22gnu: Add sugar-light-sddm-theme....* gnu/packages/display-manager.scm (sugar-light-sddm-theme): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Petr Hodina 2021-12-22gnu: Add sugar-dark-sddm-theme....* gnu/packages/display-manager.scm (sugar-dark-sddm-theme): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Petr Hodina 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-10-31Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner 2021-10-28gnu: lightdm-gtk-greeter: Add bash-minimal dependency....The bash-minimal dependency is required by the wrap-program, and guix lint suggests to add it in the inputs. * gnu/packages/display-managers.scm (lightdm): add bash-minimal dependency Signed-off-by: Ludovic Courtès <ludo@gnu.org> Denis 'GNUtoo' Carikli 2021-10-28gnu: lightdm-gtk-greeter: Update to 2.0.8...This also fixes the build. Before configure failed with the following error: checking for exo-csource... no configure: error: in `/tmp/guix-build-lightdm-gtk-greeter-2.0.7.drv-0/lightdm-gtk-greeter-2.0.7': configure: error: exo-csource not installed * gnu/packages/display-managers.scm (lightdm): update to 2.0.8 Signed-off-by: Ludovic Courtès <ludo@gnu.org> Denis 'GNUtoo' Carikli 2021-09-03gnu: sddm: Refer to the 'shadow' input....This change was suggested by Ludovic Courtès <ludo@gnu.org> to allow users to replace the shadow input in the package. * gnu/packages/display-manager.scm (sddm)[arguments]: In configure-flags refer to the shadow package that is an input. Efraim Flashner 2021-09-02gnu: sddm: Fix build....* gnu/packages/display-managers.scm (sddm)[arguments]: Use gexp for configure-flags. Efraim Flashner 2021-06-19Merge branch 'master' into core-updates...Note: this merge actually changes the 'curl' and 'python-attrs' derivations, as part of solving caf4a7a2770ef4d05a6e18f40d602e51da749ddc and 12964df69a99de6190422c752fef65ef813f3b6b respectively. 4604d43c0e (gnu: gnutls@3.6.16: Fix cross-compilation.) was ignored because it cannot currently be tested. Conflicts: gnu/local.mk gnu/packages/aidc.scm gnu/packages/boost.scm gnu/packages/curl.scm gnu/packages/nettle.scm gnu/packages/networking.scm gnu/packages/python-xyz.scm gnu/packages/tls.scm Marius Bakke 2021-06-14gnu: Rename qtbase to qtbase-5....This change was automated via the following command: $ git ls-files | xargs sed -i 's/,qtbase)/,qtbase-5)/g' $ git ls-files | xargs sed -i 's/inherit qtbase)/inherit qtbase-5)/g' $ git ls-files | xargs sed -i 's/package-version qtbase)/package-version qtbase-5)/g' $ git checkout etc # to clear some spurious changes This is done so the qtbase package can be upgraded to version 6 in the following commit. Maxim Cournoyer 2021-03-06Merge branch 'master' into core-updatesChristopher Baines 2021-02-25gnu: Add chili-sddm-theme....* gnu/packages/display-managers.scm (chili-sddm-theme): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Zheng Junjie