aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages smalltalk)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix utils)
  #:use-module (guix build-system cmake)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages assembly)
  #:use-module (gnu packages audio)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages base)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages gl)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages libffi)
  #:use-module (gnu packages libsigsegv)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages multiprecision)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages pulseaudio)
  #:use-module (gnu packages xorg))

(define-public smalltalk
  (package
    (name "smalltalk")
    (version "3.2.91")
    (source
     (origin
      (method url-fetch)
      ;; XXX: Revert to mirror://gnu with the next release of Smalltalk.
      (uri (string-append "https://alpha.gnu.org/gnu/smalltalk/smalltalk-"
                          version ".tar.xz"))
      (sha256
       (base32
        "1zb2h5cbz1cwybqjl24lflw359lwj7sjvvhwb4x6miypzhwq4qh0"))
      ;; XXX: To be removed with the next release of Smalltalk.
      (patches (search-patches "smalltalk-multiplication-overflow.patch"))))
    (build-system gnu-build-system)
    (native-inputs
     (list pkg-config
           (libc-utf8-locales-for-target)
           ;; XXX: To be removed with the next release of Smalltalk.
           autoconf
           automake
           libtool
           zip))
    ;; TODO: These optional dependencies raise the closure size to ~1 GiB
    ;; from the current ~100 MiB, although some of them might be very
    ;; useful for end users:
    ;;  - freeglut
    ;;  - glib
    ;;  - gobject-introspection
    ;;  - gtk+-2
    ;;  - tcl/tk
    ;;  - SDL (sdl-union)
    ;;  - sqlite
    ;;  - zlib
    (inputs
     (list gmp libffi libltdl libsigsegv lightning))
    (arguments
     `(;; FIXME: Tests fail on x86-64 in the build container, but they pass
       ;; in a regular shell.
       #:tests? ,(not (target-x86-64?))
       #:phases
       (modify-phases %standard-phases
         ;; XXX: To be removed with the next release of Smalltalk.
         ;; The overflow patch modifies configure.ac, therefore remove
         ;; old configure script and enforce an autoreconf.
         (add-before 'bootstrap 'remove-unpatched-configure
           (lambda _
             (delete-file "configure")
             #t))
         ;; XXX: To be removed with the next release of Smalltalk.
         ;; We don't want to regenerate the info files.
         (add-after 'build 'keep-generated-info-manual
           (lambda _
             (for-each (lambda (file)
                         (invoke "touch" file))
                       (find-files "doc" "\\.info"))
             #t))
         (add-before 'configure 'fix-libc
           (lambda* (#:key inputs #:allow-other-keys)
             (let ((libc (or (assoc-ref inputs "libc")
                             ;; When cross-compiling, the input
                             ;; is named "cross-libc" instead of
                             ;; simply "libc".
                             (assoc-ref inputs "cross-libc"))))
               (substitute* "libc.la.in"
                 (("@LIBC_SO_NAME@") "libc.so")
                 (("@LIBC_SO_DIR@")  (string-append libc "/lib"))))
             #t)))))
    (home-page "https://smalltalk.gnu.org/")
    (synopsis "Programming language environment")
    (description
     "GNU Smalltalk is a free implementation of the Smalltalk language.  It
implements the ANSI standard for the language and also includes extra classes
such as ones for networking and GUI programming.")
    (license license:gpl2+)))

(define-public squeak-vm
  (package
    (name "squeak-vm")
    (version "4.10.2.2614")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "http://squeakvm.org/unix/release/"
                           "Squeak-" version "-src.tar.gz"))
       (sha256
        (base32 "0bpwbnpy2sb4gylchfx50sha70z36bwgdxraym4vrr93l8pd3dix"))
       (modules '((guix build utils)))
       (snippet
        ;; Make builds bit-reproducible.
        '(begin
           (substitute* "unix/cmake/verstamp"
             (("vm_date=.*")
              "vm_date = \"1970-01-01\";\n")
             (("ux_version=.*")
              "ux_version = \"GNU\";\n"))
           (substitute* "unix/vm/config.cmake"
             (("\\(VM_BUILD_STRING.*")
              "(VM_BUILD_STRING \\\"Built with GNU Guix\\\")"))
           #t))))
    (inputs
     (list alsa-lib
           dbus
           freetype
           libffi
           libxrender
           mesa
           pulseaudio))
    (native-inputs
     (list pkg-config))
    (build-system cmake-build-system)
    (arguments
     `(#:tests? #f                      ;no check target
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'remove-hardcoded-PATH
           (lambda _
             ;; Remove hard-coded FHS PATH entries.
             (substitute* '("unix/cmake/squeak.in"
                            "unix/cmake/squeak.sh.in")
               (("^PATH=.*") ""))
             #t))
         (add-before 'configure 'enter-build-directory
           (lambda _
             (mkdir "build")
             (chdir "build")
             #t))
         (replace 'configure
           (lambda* (#:key outputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out")))
               (invoke "../unix/cmake/configure"
                       (string-append "--prefix=" out)
                       "--without-quartz")
               #t))))))
    (synopsis "Smalltalk programming language and environment")
    (description "Squeak is a full-featured implementation of the Smalltalk
programming language and environment based on (and largely compatible with)
the original Smalltalk-80 system.  Squeak has very powerful 2- and 3-D
graphics, sound, video, MIDI, animation and other multimedia capabilities.  It
also includes a customisable framework for creating dynamic HTTP servers and
interactively extensible Web sites.")
    (home-page "http://squeakvm.org/")
    (license license:x11)))
/a>...* etc/teams.scm (Ludovic Courtès): Add to documentation team. Change-Id: Icf71ad8e2ebbe2b65ab3b6c0cf8cd8fe60cf2d0a Ludovic Courtès 2024-05-01teams: Add documentation team....* etc/teams.scm (documentation): New team. Change-Id: I34d4ed9029f369ebf0d1f510cc0810baca2ced89 Ludovic Courtès 2024-04-09teams: Remove Björn Höfling from their team due to inactivity....* etc/teams.scm (Björn Höfling): Remove from the JAVA team. Change-Id: I384e4aebff18485ea5c5bf444a46dc88a64af72d Leo Famulari 2024-04-09teams: Remove Raghav Gururajan from their teams due to inactivity....* etc/teams.scm (Raghav Gururajan): Remove from the GNOME and MENTORS teams. Change-Id: Ic1a583f08636f4cfd34635ab04091844b9957e08 Leo Famulari 2024-03-14teams: Add Tanguy Le Carrour....* etc/teams.scm.in ("Tanguy Le Carrour"): New member. Change-Id: Ic1b1588a5a8bc67ee8e135c3069966f139374529 Signed-off-by: Christopher Baines <mail@cbaines.net> Tanguy Le Carrour 2024-03-08teams: Add 宋文武 to the qt team....* etc/teams.scm (宋文武): Add qt team. Change-Id: Ib1b50b109ded4dbbcfd0649d3e0c1e6884585c5e 宋文武 2024-03-08teams: lxqt: Remove qt.scm from scope....* etc/teams.scm (lxqt)[#:scope]: Remove "gnu/packages/qt.scm". Change-Id: If05ea534a827eba5a2acf6526d906cea43f72442 宋文武 2024-03-08teams: Add entry for Adam Faiz....* etc/teams.scm ("Adam Faiz"): New member. Signed-off-by: Andreas Enge <andreas@enge.fr> Change-Id: Idb913da5e4f622b8efdbadc87d2cf3e5aec118eb AwesomeAdam54321 2024-02-13teams: Add Sugar team....* etc/teams.scm (sugar): New team; add Ricardo to it. Change-Id: I4d7af2a8f4077fa60ff8400b0b8b1b6127a77448 Ricardo Wurmus 2024-02-13teams: go: Add all related files to the scope....* etc/teams.scm (go): Add regex search for any golang files. Change-Id: Ia6c95d8d49863de0381a907ca6309fa22d22927e Sharlatan Hellseher 2024-02-05teams: mozilla: Add tor-browsers.scm....* etc/teams.scm (mozilla): Add "gnu/packages/tor-browsers.scm". Change-Id: Id3aa1fe641c612000319a4ea4b236285f8d3b599 Clément Lassieur 2024-02-03teams: Add Mark H Weaver to the ‘mozilla’ team....* etc/teams.scm (Mark H Weaver): Add to the ‘mozilla’ team. Mark H Weaver 2024-01-30teams: go: Add golang-xyz.scm to scope....* etc/teams.scm (go): Add "gnu/packages/golang-xyz.scm". Change-Id: I580eadf52b631c6582e256a2900786b53483a466 Sharlatan Hellseher 2024-01-28teams: go: Add more related files to the scope....* etc/teams.scm (go): Add "gnu/packages/configuration-management.scm", "gnu/packages/golang-crypto.scm", "gnu/packages/golang-web.scm", "gnu/packages/syncthing.scm", "gnu/packages/terraform.scm". Sort list alphabetically. Change-Id: I56ce5bd21e487e5dbe2d84aa1d83e3239268fb71 Sharlatan Hellseher 2024-01-24teams: Remove Efraim Flashner from the science team....* etc/teams.scm (Efraim Flashner): Remove science team. Change-Id: I790fe329cde11fcb4b706b01b9aa59ad29d8c874 Efraim Flashner 2024-01-16teams: Add Wilko Meyer to kernel....* etc/teams.scm: Add Wilko Meyer. Change-Id: Ia7b85a090a4d8e81689bd137e1d12cb3708aa760 Signed-off-by: Leo Famulari <leo@famulari.name> Wilko Meyer 2024-01-14teams: Add Vivien Kraus....* etc/teams.scm.in ("Vivien Kraus"): New member. Change-Id: Iab2c9300f3e1e604fb2ee539a7eb05e7a3f54776 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Vivien Kraus 2024-01-12teams: Add entry for Sharlatan Hellseher....* etc/teams.scm ("Sharlatan Hellseher"): New member. Change-Id: I05f1442e90799e182feb153f45191e789c05461b Sharlatan Hellseher 2024-01-05teams: Add ‘core-packages’ team....* etc/teams.scm (bootstrap): Add “gnu/packages/commencement.scm”. (core-packages): New team. (Ludovic Courtès): Add to ‘core-packages’ team. Change-Id: I25f22d436a4dc9bf4c8f577f94cc178cbaa80768 Ludovic Courtès 2023-12-22teams: mozilla: Add icecat-extension.scm and browser-extensions.scm....* etc/teams.scm (mozilla): Add "gnu/build/icecat-extension.scm" and "gnu/packages/browser-extensions.scm". Change-Id: Id59fb307256e5870b3c19f0b7c41446775a57d9e Clément Lassieur 2023-12-20teams: Add entry for Clément Lassieur....* etc/teams.scm ("Clément Lassieur"): New member. Change-Id: If6456d9496f59b0a26608ad5e55aa8fdfb8af492 Clément Lassieur 2023-11-20teams: Include golang-check.scm in the go team....* etc/teams.scm (go): Add gnu/packages/golang-check.scm to scope. Change-Id: Ifc90eb0c3fc5d716b605e7e3e100a38431498a2c Signed-off-by: Christopher Baines <mail@cbaines.net> Benjamin 2023-11-12teams: Add Ekaitz Zarraga to bootstrap and zig....* etc/teams.scm: Add Ekaitz Zarraga. Change-Id: Idda2ffbc15adc3725bcd1600988582f0d4c2766a Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Ekaitz Zarraga 2023-11-12teams: Add Zig team....* etc/teams.scm (zig): New team for the zig programming language, packages and build system. Change-Id: I96f9ced1ad04b1cd9041c53aa8c86fe29014ccd1 Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Ekaitz Zarraga 2023-11-01teams.scm: Add file-local variable prop line for the mode....This tells Emacs to use the scheme-mode to edit the file. * etc/teams.scm (mode): New file-local variable. Change-Id: I9a48f552e831317402673d95cf6c1de506d388b5 Maxim Cournoyer 2023-10-27teams: Add myself to audio team....Message-ID: <cfad42ecdcd190893699ef28d42b35b706729bcd.1698355699.git.gabriel@erlikon.ch> In-Reply-To: <81d0877b2cb39164563dfbf2c551f1c99aad75ed.1698355699.git.gabriel@erlikon.ch> References: <81d0877b2cb39164563dfbf2c551f1c99aad75ed.1698355699.git.gabriel@erlikon.ch> From: Gabriel Wicki <gabriel@erlikon.ch> Date: Tue, 2 May 2023 16:47:41 +0200 Subject: [PATCH 2/2] teams: Add Gabriel Wicki. * etc/teams.scm.in ("Gabriel Wicki"): New member. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Gabriel Wicki 2023-10-27teams: Add audio team....Message-ID: <81d0877b2cb39164563dfbf2c551f1c99aad75ed.1698355699.git.gabriel@erlikon.ch> From: Gabriel Wicki <gabriel@erlikon.ch> Date: Tue, 2 May 2023 16:38:15 +0200 Subject: [PATCH 1/2] teams: Add audio team. * etc/teams.scm.in (audio): Add team. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Gabriel Wicki 2023-10-22teams: Adjust shebang to use 'guix repl'....This ensures the correct Guix dependencies are always available for the script. * etc/teams.scm.in: Rename to... * etc/teams.scm: ... this. Adjust shebang. * .gitignore: No longer ignore it. * configure.ac: Do not process it with AC_CONFIG_FILES. Reported-by: Clément Lassieur <clement@lassieur.org> Fixes: https://issues.guix.gnu.org/66605 Change-Id: I7a01750c6c5f0696b6c36b1e6caa9389d9e6822c Maxim Cournoyer