aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2023 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages skribilo)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix licenses)
  #:use-module ((guix utils) #:select (version-major+minor))
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages guile)
  #:use-module (gnu packages guile-xyz)
  #:use-module (gnu packages lout)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages plotutils)
  #:use-module (gnu packages imagemagick)
  #:use-module (gnu packages ghostscript))

(define-public skribilo
  (package
    (name "skribilo")
    (version "0.10.0")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://savannah/skribilo/skribilo-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "03pm2a9a5k0wkj10ywh6xi8flawm8sd396k4698gvvbc2zp4izwc"))))
    (build-system gnu-build-system)
    (arguments
     ;; Make the modules available under the usual location.
     `(#:phases
       (modify-phases %standard-phases
         (add-before 'configure 'pre-configure
           (lambda* (#:key inputs #:allow-other-keys)
             ;; Make sure the 'skribilo' command gets to see
             ;; Guile-Reader, even if Guile-Reader is not in the search
             ;; path.
             (let ((reader (assoc-ref inputs "guile-reader"))
                   (effective ,(version-major+minor
                                (package-version
                                 (car (assoc-ref (package-inputs this-package)
                                                 "guile"))))))
               (substitute* "src/skribilo.in"
                 (("^exec (.*) -c" _ things)
                  (string-append "exec " things
                                 " -L " reader "/share/guile/site/" effective
                                 " -C " reader
                                 "/lib/guile/" effective "/site-ccache"
                                 " -c"))))
             #t)))

       #:parallel-build? #f

       ;; XXX: Temporarily disable tests because they rely on
       ;; 'test-runner-current' *not* returning #f after 'test-end', which is
       ;; no longer the case in Guile >= 3.0.6.  This is fixed upstream.
       #:tests? #f))

    (native-inputs (list pkg-config))

    (inputs (list guile-3.0
                  imagemagick
                  ghostscript ; for 'convert'
                  ploticus
                  lout))

    ;; The 'skribilo' command needs them, and for people using Skribilo as a
    ;; library, these inputs are needed as well.
    (propagated-inputs (list guile-reader guile-lib))

    (home-page "https://www.nongnu.org/skribilo/")
    (synopsis "Document production tool written in Guile Scheme")
    (description
     "Skribilo is a free document production tool that takes a structured
document representation as its input and renders that document in a variety of
output formats: HTML and Info for on-line browsing, and Lout and LaTeX for
high-quality hard copies.

The input document can use Skribilo's markup language to provide information
about the document's structure, which is similar to HTML or LaTeX and does not
require expertise.  Alternatively, it can use a simpler, “markup-less” format
that borrows from Emacs' outline mode and from other conventions used in
emails, Usenet and text.

Lastly, Skribilo provides Guile Scheme APIs.")
    (license gpl3+)))
commit/gnu/packages/gpodder.scm?id=cfdfd5fe4cd3303c42e285ac5c6eb595b6f11eef'>gnu: gpodder: Do not alter PYTHONPATH....* gnu/packages/gpodder.scm (gpodder): Do not alter PYTHONPATH. Maxim Cournoyer 2020-11-23gnu: gpodder: Update to 3.10.17....* gnu/packages/gpodder.scm (gpodder): Update to 3.10.17. Tobias Geerinckx-Rice 2020-11-15gnu: python-podcastparser: Update to 0.6.6....* gnu/packages/gpodder.scm (python-podcastparser): Update to 0.6.6. [native-inputs, arguments]: Substitute python-pytest for python-coverage & python-nose. Tobias Geerinckx-Rice 2020-09-05gnu: Update gPodder to 3.10.16 and disable updater....* gnu/packages/gpodder.scm (gpodder): Update to 3.10.16 and add patch. * gnu/packages/patches/gpodder-disable-updater.patch: New file * gnu/local.mk (dist_patch_DATA): Add patch Signed-off-by: Andreas Enge <andreas@enge.fr> raingloom 2020-07-12gnu: Remove ".git" from "https://github/…/….git"....Until now, 'lookup-origin' and thus 'lookup-origin-revision' in (guix swh) would sometimes return #f for these because the ".git" URLs are redirects to the non-".git" URLs. Consequently, 'guix lint -c archival' would keep saying "scheduled Software Heritage archival"; likewise, the fallback download code would fail. * gnu/packages/ada.scm, gnu/packages/admin.scm, gnu/packages/aidc.scm, gnu/packages/algebra.scm, gnu/packages/android.scm, gnu/packages/animation.scm, gnu/packages/arcan.scm, gnu/packages/assembly.scm, gnu/packages/audio.scm, gnu/packages/authentication.scm, gnu/packages/avr.scm, gnu/packages/axoloti.scm, gnu/packages/backup.scm, gnu/packages/bash.scm, gnu/packages/benchmark.scm, gnu/packages/bioconductor.scm, gnu/packages/bioinformatics.scm, gnu/packages/bittorrent.scm, gnu/packages/boost.scm, gnu/packages/build-tools.scm, gnu/packages/c.scm, gnu/packages/calendar.scm, gnu/packages/cdrom.scm, gnu/packages/check.scm, gnu/packages/chemistry.scm, gnu/packages/chez.scm, gnu/packages/clojure.scm, gnu/packages/code.scm, gnu/packages/compression.scm, gnu/packages/compton.scm, gnu/packages/coq.scm, gnu/packages/cpp.scm, gnu/packages/cran.scm, gnu/packages/crypto.scm, gnu/packages/curl.scm, gnu/packages/databases.scm, gnu/packages/datastructures.scm, gnu/packages/debug.scm, gnu/packages/disk.scm, gnu/packages/distributed.scm, gnu/packages/django.scm, gnu/packages/dlang.scm, gnu/packages/dns.scm, gnu/packages/docker.scm, gnu/packages/education.scm, gnu/packages/efi.scm, gnu/packages/elixir.scm, gnu/packages/emacs-xyz.scm, gnu/packages/embedded.scm, gnu/packages/emulators.scm, gnu/packages/engineering.scm, gnu/packages/erlang.scm, gnu/packages/fabric-management.scm, gnu/packages/file-systems.scm, gnu/packages/finance.scm, gnu/packages/firmware.scm, gnu/packages/flashing-tools.scm, gnu/packages/fonts.scm, gnu/packages/fontutils.scm, gnu/packages/fpga.scm, gnu/packages/game-development.scm, gnu/packages/games.scm, gnu/packages/genealogy.scm, gnu/packages/genimage.scm, gnu/packages/geo.scm, gnu/packages/gimp.scm, gnu/packages/gl.scm, gnu/packages/gnome-xyz.scm, gnu/packages/gnome.scm, gnu/packages/gnuzilla.scm, gnu/packages/golang.scm, gnu/packages/gpodder.scm, gnu/packages/graph.scm, gnu/packages/graphics.scm, gnu/packages/graphviz.scm, gnu/packages/groff.scm, gnu/packages/groovy.scm, gnu/packages/gtk.scm, gnu/packages/guile-xyz.scm, gnu/packages/guile.scm, gnu/packages/hardware.scm, gnu/packages/haskell-apps.scm, gnu/packages/haskell-xyz.scm, gnu/packages/hexedit.scm, gnu/packages/i2p.scm, gnu/packages/ibus.scm, gnu/packages/image-processing.scm, gnu/packages/image-viewers.scm, gnu/packages/image.scm, gnu/packages/ipfs.scm, gnu/packages/java-graphics.scm, gnu/packages/java-maths.scm, gnu/packages/java.scm, gnu/packages/javascript.scm, gnu/packages/jrnl.scm, gnu/packages/julia.scm, gnu/packages/jupyter.scm, gnu/packages/kodi.scm, gnu/packages/language.scm, gnu/packages/lego.scm, gnu/packages/less.scm, gnu/packages/libusb.scm, gnu/packages/linux.scm, gnu/packages/lirc.scm, gnu/packages/lisp-xyz.scm, gnu/packages/llvm.scm, gnu/packages/logging.scm, gnu/packages/lolcode.scm, gnu/packages/lua.scm, gnu/packages/lxde.scm, gnu/packages/lxqt.scm, gnu/packages/machine-learning.scm, gnu/packages/mail.scm, gnu/packages/markup.scm, gnu/packages/maths.scm, gnu/packages/maven.scm, gnu/packages/mes.scm, gnu/packages/messaging.scm, gnu/packages/monitoring.scm, gnu/packages/mpd.scm, gnu/packages/music.scm, gnu/packages/networking.scm, gnu/packages/node-xyz.scm, gnu/packages/ocaml.scm, gnu/packages/ocr.scm, gnu/packages/onc-rpc.scm, gnu/packages/opencl.scm, gnu/packages/opencog.scm, gnu/packages/pantheon.scm, gnu/packages/password-utils.scm, gnu/packages/patchutils.scm, gnu/packages/pdf.scm, gnu/packages/perl6.scm, gnu/packages/phabricator.scm, gnu/packages/popt.scm, gnu/packages/printers.scm, gnu/packages/prolog.scm, gnu/packages/protobuf.scm, gnu/packages/pulseaudio.scm, gnu/packages/python-crypto.scm, gnu/packages/python-web.scm, gnu/packages/python-xyz.scm, gnu/packages/qt.scm, gnu/packages/radio.scm, gnu/packages/rails.scm, gnu/packages/rdf.scm, gnu/packages/rednotebook.scm, gnu/packages/rpc.scm, gnu/packages/rsync.scm, gnu/packages/ruby.scm, gnu/packages/rust.scm, gnu/packages/scheme.scm, gnu/packages/screen.scm, gnu/packages/security-token.scm, gnu/packages/selinux.scm, gnu/packages/serialization.scm, gnu/packages/shells.scm, gnu/packages/shellutils.scm, gnu/packages/simh.scm, gnu/packages/sml.scm, gnu/packages/ssh.scm, gnu/packages/statistics.scm, gnu/packages/stenography.scm, gnu/packages/sync.scm, gnu/packages/syncthing.scm, gnu/packages/synergy.scm, gnu/packages/telephony.scm, gnu/packages/terminals.scm, gnu/packages/tex.scm, gnu/packages/texinfo.scm, gnu/packages/text-editors.scm, gnu/packages/textutils.scm, gnu/packages/time.scm, gnu/packages/tmux.scm, gnu/packages/tor.scm, gnu/packages/toys.scm, gnu/packages/version-control.scm, gnu/packages/video.scm, gnu/packages/vim.scm, gnu/packages/virtualization.scm, gnu/packages/vlang.scm, gnu/packages/vnc.scm, gnu/packages/vpn.scm, gnu/packages/web-browsers.scm, gnu/packages/web.scm, gnu/packages/wireservice.scm, gnu/packages/wm.scm, gnu/packages/wxwidgets.scm, gnu/packages/xdisorg.scm, gnu/packages/xml.scm, gnu/packages/xorg.scm, tests/lint.scm: Remove trailing ".git" from 'git-reference' URL. Ludovic Courtès 2020-04-17gnu: python-podcastparser: Run tests....* gnu/packages/gpodder.scm (python-podcastparser)[native-inputs]: Add python-coverage. [arguments]: Replace 'check phase and invoke "nosetests". Signed-off-by: Ludovic Courtès <ludo@gnu.org> Pierre Langlois 2020-04-17gnu: gpodder: Run tests....* gnu/packages/gpodder.scm (gpodder)[native-inputs]: Add python-coverage and python-minimock. [arguments]: Replace the 'check phase and invoke "make unittest". Signed-off-by: Ludovic Courtès <ludo@gnu.org> Pierre Langlois 2020-04-17gnu: gpodder: Update to 3.10.15....* gnu/packages/gpodder.scm (gpodder): Update to 3.10.15. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Pierre Langlois 2020-04-14gnu: python-podcastparser: Update to 0.6.5....* gnu/packages/gpodder.scm (python-podcastparser): Update to 0.6.5. Tobias Geerinckx-Rice 2020-03-19gnu: libmygpo-qt: Update home page....* gnu/packages/gpodder.scm (libmygpo-qt)[home-page]: Update. Tobias Geerinckx-Rice 2020-02-05gnu: gpodder: Update to 3.10.13....* gnu/packages/gpodder.scm (gpodder): Update to 3.10.13. Signed-off-by: Marius Bakke <mbakke@fastmail.com> Pierre Langlois 2019-10-08gnu: gpodder: Update to 3.10.11....* gnu/packages/gpodder.scm (gpodder): Update to 3.10.11. Signed-off-by: Marius Bakke <mbakke@fastmail.com> Pierre Langlois 2019-09-28gnu: gpodder: Update to 3.10.10....* gnu/packages/gpodder.scm (gpodder): Update to 3.10.10. [inputs]: Add youtube-dl. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Pierre Langlois 2019-06-13gnu: gpodder: Only return #t when needed....* gnu/packages/gpodder.scm (gpodder)[arguments]: Return #t from 'do-not-run-msgmerge. Don't return #t from 'install. Efraim Flashner 2019-06-13gnu: gpodder: Update to 3.10.9....* gnu/packages/gpodder.scm (gpodder): Update to 3.10.9. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Pierre Langlois 2019-03-31gnu: gpodder: Build reproducibly....* gnu/packages/gpodder.scm (gpodder)[arguments]: Add 'do-not-run-msgmerge' phase before 'install'. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Pierre Langlois 2019-03-25gnu: Add gPodder....* gnu/packages/podcast.scm (gpodder): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Pierre Langlois 2019-03-25gnu: Add python-mygpoclient....* gnu/packages/gpodder.scm (python-mygpoclient): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Pierre Langlois 2019-03-23gnu: Add python-podcastparser....* gnu/packages/podcast.scm (python-podcastparser): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Pierre Langlois 2019-03-23gnu: libmygpo-qt: Move to new 'gpodder.scm' file....* gnu/packages/music.scm (libmygpo-qt): Move to 'gpodder.scm'. * gnu/packages/gpodder.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Pierre Langlois