aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages serveez)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages guile))

(define-public serveez
  (package
    (name "serveez")
    (version "0.3.0")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/serveez/serveez-"
                          version ".tar.lz"))
      (sha256
       (base32
        "0capm8i6fyjvh5rflxkfd07llfaa0kk4i3y836qpld9vzy49q6ky"))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags '("--enable-libserveez-install")
       #:phases
       (modify-phases %standard-phases
         (add-before 'patch-source-shebangs 'patch-test-source
           (lambda _
             (substitute*
                 (find-files "test" "^t[0-9]{3}$")
               (("/bin/sh") (which "sh")))
             #t)))))
    (native-inputs
     (list lzip))
    (inputs
     (list guile-2.2))
    (home-page "https://www.gnu.org/software/serveez/")
    (synopsis "Framework for implementing IP-based servers")
    (description
     "GNU Serveez is a server framework providing the routines necessary to
easily implement IP-based servers in your application.  It
demonstrates aspects of network programming in a portable manner,
making it convenient for both simplifying the process of adding a
server to your application or for learning about how network services
work.  Several example servers are provided already, such as an HTTP
server and an IRC server.")
    (license gpl3+)))
le='2019-03-24 00:13:53 +0100'>2019-03-24tests: Adjust 'guix pack -f squashfs' test....Ludovic Courtès 2018-11-06store-copy: Canonicalize the mtime and permissions of the store copy....Ludovic Courtès 2018-11-06pack: Add test for 'self-contained-tarball' with localstatedir....Ludovic Courtès 2018-11-06pack: Squashfs backend now honors '--localstatedir'....Ludovic Courtès 2018-11-06pack: Docker backend now honors '--localstatedir'....Ludovic Courtès 2018-11-06pack: Import (guix store database) only when '--localstatedir' is passed....Ludovic Courtès 2018-10-28tests: Fix typo....Ludovic Courtès 2018-10-19tests: Run 'guix pack' tests using the external store....Ludovic Courtès 2018-09-18tests: Skip 'self-contained-tarball' test unconditionally....Ludovic Courtès 2018-06-01pack: Adjust test to expect relative symlinks....Ludovic Courtès 2018-06-01tests: Fix arguments in pack test....Ricardo Wurmus 2017-03-22tests: Skip 'guix pack' test when networking is unavailable....Ludovic Courtès 2017-03-17pack: Move absolute file name to <compressor>....Ludovic Courtès 2017-03-14pack: Add unit test....Ludovic Courtès